RDP Remote Printing - Printers Don't Redirect

Hi,
I RDP from my home PC (Windows 7 not on domain) to my office PC (Windows 7 on domain). In my home I have a printer that usually gets redirected to the remote session and I will be able to print to it from the remote session. Now, none of my printers are there. When I go to "Print Management" I see that there are ports taken labeled "TS001, TS002" , and so on but I wouldn't see the name of the printer.

This has been working before so I don't know what happened. No settings were changed. The local printers drivers are installed on the remote PC. Printing is enabled for the remote session. I was in another house (with Windows 7) and RDP'ed to my office and was not able to see those printers either.

Thanks for looking and I appreciate your help in advance!

Ezra
eshiramAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lauchangkwangCommented:
From my point of view in this case, since both of the laptops from different house when using the RDP also cannot see the local printer, I am suspecting the group policy at the server end to restrict connecting to local printer has been implemented, would be good that you check with your IT department whether any update on the group policy recently.

http://technet.microsoft.com/en-us/library/ee791756(v=ws.10).aspx
0
Skyler KincaidNetwork/Systems EngineerCommented:
I agree with launchangkwang. The only other thing I can think of is that your profile on the server is correct or at least the printer part of it. You could try having IT clear out all your printers via the registry or rebuilding your profile if you don't have anything on the server that requires a large amount of setup for each user profile.

That would be where I would start troubleshooting it. The fact that you can see the ports but no printers makes me think there is a printer/printer port/printer queue problem on the server. You can also check to see when the last time they rebooted it was if the problem just started recently.
0
eshiramAuthor Commented:
I did that. I checked printer queues, group policy, I even deleted keys from the registry pertaining to inactive TS ports. I also set in GP to enable TS Easy Print drivers for being priority. I ran CCleaner to clean up the registry. I don't know where else to look.
0
Skyler KincaidNetwork/Systems EngineerCommented:
Have you looked in the Event Log at the time of your login. I have seen where the printers don't pull through because a driver is missing or corrupt. If printer redirection is enabled on the client remote desktop client then you will see errors on the event logs of the server when you connect.

That is where I would start looking next. Look under System Log and Application Log and let us know what you find!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eshiramAuthor Commented:
Sorry for wasting your time. It was a driver issue. I had installed the driver but it did not work so I assumed that was not the issue. When I installed the PostScript driver it worked.

Thanks for your time gentlemen.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.