[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 392
  • Last Modified:

Application running on Sql random disconnects

Good morning,

I am running into this issue that is insanely driving me up a wall.  We run this ERP application (Epicor Prophet 21 )  that connect to sql on the back end.  As of last week  a few users started experiencing random disconnect errors from the application.  now it is happening to everyone at different times.

SQLSTATE= 08s01
Microsoft OLE DB Provider for SQL Server.
Connection failure


The server hosting sql is running on VMware ESxi3.5.  I have taken several steps:
 replaced the Nic card -  I moved the server to a dedicated nic -  Moved the server to a different switch
and we are still seeing the same problem what  could the cause be?
Server: Power Edge 2950 - Intel Xeon E5420 @2.50GHz, 24Gigs of RamSelect Error:  
no errors in windows logs or Sql logs.
0
tips54
Asked:
tips54
  • 5
  • 3
1 Solution
 
Lee SavidgeCommented:
Is the database set to autoclose?

If so, try setting autoclose to off or false.
0
 
tips54Author Commented:
I will check.   SQL 2005 by the way.
If it was set to auto close wouldn't everyone get disconnected at the same time?
0
 
Lee SavidgeCommented:
No. Autoclose closes the connection after each query. I've had issues in the past with it being enabled. It lead to random disconnections and more strangely it didn't affect my customer for months and then suddenly it was a problem.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
tips54Author Commented:
ok. This issue just started a couple of weeks ago. The server has been up since 2008. Where do I found this feature in SQL?
0
 
tips54Author Commented:
no suggestions?  I am about to replace this server?
0
 
Lee SavidgeCommented:
Load SQL Management Studio
Expand the server tree on the left until you see your database
Right mouse click on your database and choose Properties
On the left in the pop up choose Options
First option = Auto Close

If it is set to true, highlight it, change the option in the drop down to false.
Press OK.
0
 
tips54Author Commented:
I ended up migrating the SQL server role to another box.
0
 
tips54Author Commented:
ok
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now