Solved

XenApp session disconnects unexpected

Posted on 2013-10-22
7
1,169 Views
Last Modified: 2014-01-07
new established or reconnected sessions disconnects 2-10 sec after connection is established. At the server the session keeps running and I can reconnect (for 2-10 sec)

The problem occurs only, if the client has a connection to the old PS4.5 Farm before.
If I connect to the new farm first and than to the old ... and back to the new ... there are no problems.
Client is WinXP - no problems with new Win7/win8 Clients.
it is not a server-problem! I try connecting to different good running farms and the problem is the same every time.
Versions:
XA 6.5 HRP2
Win 2k8R2
Client: XP
CTXClient 12.0, 13.1 3.2
0
Comment
Question by:Dirk Kotte
  • 4
  • 3
7 Comments
 
LVL 15

Assisted Solution

by:joharder
joharder earned 500 total points
ID: 39591398
When this occurs, are you getting a screen showing an HDX error?  If so, that is indicative of an issue mapping a printer, likely a printer driver.  On the local computer, go to Control Panel-->Devices and Printers and try printing a test page from each of the printers.

Also, try upgrading the Citrix client to v13.4/v3.4.
0
 
LVL 23

Author Comment

by:Dirk Kotte
ID: 39591418
hi, thanks for the answer
but we have no error-message.
with the WI-setting "low connection speed" (without drive or printer-mapping) the error occurs also.
error occurs with the most current client (from the citrix webpage) also.
0
 
LVL 15

Expert Comment

by:joharder
ID: 39592492
By chance, do any of the applications on the two farms have the same name?  For example, is there a Word2010 within each farm?

Check the event logs to see if there is anything revealing there.
0
ScreenConnect 6.0 Free Trial

Check out the updates in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI that improves session organization and overall user experience. See the enhancements for yourself!

 
LVL 23

Author Comment

by:Dirk Kotte
ID: 39593278
no,
one of the first admin-apps every time is "Taskmanager SERVERNAME".
So it is unique.

and the app start or reconnects, I see the app (and can type) for some seconds and then the session is disconnected.

Nothings at the server- or client- eventlogs.
0
 
LVL 15

Accepted Solution

by:
joharder earned 500 total points
ID: 39604122
When I have seen something like this, it has always been related to print drivers and printer creation.  Because printers get created after the app launches, you will typically get a few seconds of using the app before the printer creation happens (or doesn't happen!).

Please try this as a test.  Publish an application such that the app waits for printers to be created.  Try connecting to that application.  If the app launch never quite happens, it's because the printers can't get created.
0
 
LVL 23

Author Comment

by:Dirk Kotte
ID: 39638748
don't help
we publish an app and the Desktop with "wait for printers" and a "no printer" policy and have all the same result.
disconnect after some seconds.
0
 
LVL 23

Author Closing Comment

by:Dirk Kotte
ID: 39762348
the citrix support team solved the problem after 4 days debugging.
the source of the problem was a installed printer driver at the local pc  :-)
the problem occurs also with a "no printers policy".
0

Featured Post

ScreenConnect 6.0 Free Trial

At ScreenConnect, partner feedback doesn't fall on deaf ears. We collected partner suggestions off of their virtual wish list and transformed them into one game-changing release: ScreenConnect 6.0. Explore all of the extras and enhancements for yourself!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #POC #XenDesktop #vCenter #VMware #ESX
#CITRIX #XENDESKTOP #POC #Citrix Studio
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

778 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question