Solved

Sharing / Security Permission Full Control but files read only

Posted on 2013-10-22
4
1,205 Views
Last Modified: 2013-10-23
I am trying to share a folder with sub folders from the server with the Domain Users. While I have given Domain Users full control trough the sharing and security tabs, the users can open the files read only. I cannot determine why this would be the case. Help is appreciated.
0
Comment
Question by:nbittner
  • 2
4 Comments
 
LVL 2

Expert Comment

by:vverdura
ID: 39590900
And the files attributes are "Read-Only"? See this Attributes
Try to propagate the permissions with all child folders
0
 
LVL 10

Accepted Solution

by:
ienaxxx earned 500 total points
ID: 39590924
there are TWO places in which you should place authorizations:

the SHARING security ACLs
the NTFS security ACLs

if you want the authorized users to be able to modify i suggest you to place "everyone" or "Authenticated users" FULL CONTROLL in the SHARING ACLs and to add only the appropriate authorizations in the "security" tab (NTFS part).

the problem is often that the folder is shared with read only whie NTFS allows for full access, but the more restrictive policy wins

Hope this helps.
Bye! :-)
0
 

Author Closing Comment

by:nbittner
ID: 39591616
Thanks. I was unaware of whether the sharing or the security tab set the more restrictive setting.

I had more or less set both the NFTS security and sharing permissions equally. Instead of "Everyone" or "Authenticated Users" I had set "Users" to Full Control. So while my setup appeared well and good, the problem was finally determined to be a result of the Server not applying the permissions across the entire contents of the shared folder. The folder size was about 85 GB and it appears that the full control was only being applied to files in a few of the subfolders before timing out, but appearing as if the new permissions were in effect.  

I had been making the permission changes and then selecting OK, then a few file addresses would show in a dialog box for a minute then close. It was not until I selected Apply that the Full Control setting went through the entire folder contents for 5-10 minutes that the permission setting went into effect.

Now files are opening with read/write capability and not read only as before.

No idea why the process would stop before completing all the way.
0
 
LVL 10

Expert Comment

by:ienaxxx
ID: 39593450
glad you found the solution. :-)
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
When the confidentiality and security of your data is a must, trust the highly encrypted cloud fax portfolio used by 12 million businesses worldwide, including nearly half of the Fortune 500.
In this video, we show how to convert an image-only PDF file into a PDF Searchable Image file, that is, a file with both the image (typically from scanning) and text, which is created in an automated fashion with Optical Character Recognition (OCR) …
In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now