Solved

Autoresponder Not Working in OL2010 + Exchange 2010

Posted on 2013-10-22
17
643 Views
Last Modified: 2013-11-12
It's real simple: send email to thisguy@thatplace.com, and the auto responder does not respond.

I have already:
Set-RemoteDomain -AutoReplyEnabled $true

Open in new window

and
Set-RemoteDomain –AutoForwardEnabled $true

Open in new window


The user's automatic replies are already set as follows:

[x] Send automatic replies
[x] Send automatic reply messages to External Senders

And messages are set for both.

The user set these up in Outlook, and I confirmed the server "sees" it by checking through the OWA interface under options.

What am I missing here?
0
Comment
Question by:DrDamnit
  • 8
  • 6
17 Comments
 
LVL 58

Accepted Solution

by:
tigermatt earned 250 total points
ID: 39598151
If these are out-of-office replies, they are classed differently. They are not "automatic replies" so turning that on has no effect.

You need to use
Set-RemoteDomain "Remote Domain Name" -AllowedOOFType External

Open in new window

You can also turn off the two you've already enabled.

See http://technet.microsoft.com/en-us/library/bb124931%28v=exchg.141%29.aspx for more details of the commands.

-Matt
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39599448
Doesn't seem to help.

Here are the settings for all domains ("*"):

RunspaceId                           : a8406786-70b9-46f5-bb67-06371aa8d142
DomainName                           : *
IsInternal                           : False
TargetDeliveryDomain                 : False
ByteEncoderTypeFor7BitCharsets       : Undefined
CharacterSet                         : iso-8859-1
NonMimeCharacterSet                  : iso-8859-1
AllowedOOFType                       : External
AutoReplyEnabled                     : True
AutoForwardEnabled                   : True
DeliveryReportEnabled                : False
NDREnabled                           : True
MeetingForwardNotificationEnabled    : False
ContentType                          : MimeHtmlText
DisplaySenderName                    : True
PreferredInternetCodePageForShiftJis : Undefined
RequiredCharsetCoverage              :
TNEFEnabled                          :
LineWrapSize                         : unlimited
TrustedMailOutboundEnabled           : False
TrustedMailInboundEnabled            : False
IsCoexistenceDomain                  : False
UseSimpleDisplayName                 : False
NDRDiagnosticInfoEnabled             : True
AdminDisplayName                     :
ExchangeVersion                      : 0.1 (8.0.535.0)
Name                                 : Default
DistinguishedName                    : CN=Default,CN=Internet Message Formats,CN=Global Settings,CN=First Organization,
                                       CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydomain,DC=local
Identity                             : Default
Guid                                 : f75709fa-b0b1-47ed-8f00-567e631dd8e5
ObjectCategory                       : mydomain.local/Configuration/Schema/ms-Exch-Domain-Content-Config
ObjectClass                          : {top, msExchDomainContentConfig}
WhenChanged                          : 10/24/2013 10:48:35 PM
WhenCreated                          : 8/19/2013 1:24:55 PM
WhenChangedUTC                       : 10/25/2013 2:48:35 AM
WhenCreatedUTC                       : 8/19/2013 5:24:55 PM
OrganizationId                       :
OriginatingServer                    : Server01.mydomain.local
IsValid                              : True

Open in new window


All the users are experiencing the problem. The two that I have been testing with are:

RunspaceId       : a8406786-70b9-46f5-bb67-06371aa8d142
AutoReplyState   : Enabled
EndTime          : 10/25/2013 11:00:00 PM
ExternalAudience : All
ExternalMessage  : ---WORD HTML MESSAGE HERE. REMOVED FOR PRIVACY ---
InternalMessage  : ---WORD HTML MESSAGE HERE. REMOVED FOR PRIVACY ---
StartTime        : 10/24/2013 11:00:00 PM
MailboxOwnerId   : mydomain.local/mydomainOffice/john
Identity         : mydomain.local/mydomainOffice/john
IsValid          : True

Open in new window


and

RunspaceId       : a8406786-70b9-46f5-bb67-06371aa8d142
AutoReplyState   : Enabled
EndTime          : 10/25/2013 11:00:00 PM
ExternalAudience : All
ExternalMessage  : ---WORD HTML WITH MESSAGE HERE. REDACTED---
InternalMessage  : ---WORD HTML WITH MESSAGE HERE. REDACTED---
StartTime        : 10/24/2013 11:00:00 PM
MailboxOwnerId   : mydomain.local/mydomainOffice/ava
Identity         : mydomain.local/mydomainOffice/ava
IsValid          : True

Open in new window


The only other symptom I have is when you try to turn off the OOF in John's account via the webinterface, Exchange tells you: "Sorry we can't do this right now. Try again later."
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39599450
Of course, it is noteworthy that you'll only get one email autoresponse per person per day. So, I have been testing with multiple accounts via testuseraccounts.com.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39604965
It's probably worth finding out what it is you are trying to achieve.
Your original question tells us what you have done but not what the end goal is.
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39605892
@demazter:

The goal I am trying to achieve is to have Exchange send automatic replies when the automatic replies feature is set by the user.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39605909
And just to confirm, we are talking about Out of Office Automatic Replies?  When you go to Outlook

This is sent once per sender until the Out of Office is disabled and re-enabled.

You are saying this does not work?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39605940
Just reading through the whole thread properly (AGAIN!) :)

Can you disable the Out of Office within outlook client.  Close Outlook.
Then open OWA.  Confirm the Out of Office is disabled and try re-enabling it.

Please post any errors you receive when doing this.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 32

Author Comment

by:DrDamnit
ID: 39606603
Yes, enable and disable from Outlook does properly show up when I run the power shell scripts. I can see that outlook enables and disables it properly, and it is reflected in OWA as well as EMS. Changing it in EMS is also reflected in OWA and Outlook. Changing it in OWA is reflected in EMS and  Outlook.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39606645
You said in an earlier post that you received an error when changing it in one location and then trying to change it in another.  Is this not the case now?

Can you explain the Exchange setup for me?

Hub Transport role.  Is there any 3rd party applications installed here?

Do we go from here direct to the internet? Is there an Edge Transport server involved? Firewall? If so which? 3rd party filtering?
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39606765
I think that error was probably related to a temporary network condition. IT does not happen anymore (I just checked).

The exchange setup is very simple. Windows Server 2012 as a DC, Windows Server 2012 + Exchange 2010 as the Exhange box. This was an "upgrade" from SBS2008. As you probably know, there is no 'upgrade path' from SBS to non-SBS layouts. Thus, we had to export all the mailboxes using the ridiculous 32-bit management machine / 64-bit exchange layout to get the users to PST files so they could be imported into 2012/2010 (Win/Exchange).

This background is useful to know in that there should be no "funny business" that happened as the result of an upgrade. The Server install is new / from scratch. The Exchange install is new / from scratch. We created the users from a powershell script, and imported the mailboxes via powershell.

In hub transport is a 3rd party spam filter:

[PS] C:\Windows\system32>get-transportagent

Identity                                           Enabled         Priority
--------                                           -------         --------
Transport Rule Agent                               True            1
Text Messaging Routing Agent                       True            2
Text Messaging Delivery Agent                      True            3
Connection Filtering Agent                         True            4
Content Filter Agent                               True            5
Sender Id Agent                                    True            6
Sender Filter Agent                                True            7
Recipient Filter Agent                             True            8
Protocol Analysis Agent                            True            9
Vamsoft ORF SMTP Receive Agent                     True            10
Vamsoft ORF Routing Agent                          True            11

Open in new window


We are routing directly to the internet. No smarthosts or silly ISP mailservers involved.

No Edge Transport (no edge subscription).

There is a firewall, but I am not sure that is relevent in this setup because it does not filter mail / content. It's a custom built M0n0wall. (http://m0n0wall.ch). The firewall only filters IP addresses and ports.
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39606776
The only other rules I have are these:

[PS] C:\Windows\system32>Get-TransportRule

Name                                               State    Priority Comments
----                                               -----    -------- --------
Spamify .pw domains                                Enabled  0        Causes emails from domains with the .pw TLD to ...
Spamify .us domains                                Enabled  1
Spamify .me domains                                Enabled  2
SPAM Stamp                                         Enabled  3

Open in new window


Which sets the SCL level to 9 if the sending domain is a .pw, .me, or .us TLD. The last one sets the SCL to 9 if the subject contains "[SPAM]"
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39609426
Was that what you were looking for? Or do you need more information?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39610935
There is no inplace upgrade path as you say, but there is a migration path.  But that's neither here nor there.

When you test the out of office does it work for internal users? So when you turn it on and send that mailbox an email do you get the automatic response?
0
 
LVL 74

Assisted Solution

by:Glen Knight
Glen Knight earned 250 total points
ID: 39610955
I'd be interested to know the answer to the above.

Could you also run the following commands from the Exchange Management Console:

Get-AutoDiscoverVirtualDirectory | fl identity, *url

And post the results.

My guess is that this hasn't been configured.
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 39642209
Some change we made ultimately fixed it, but I don't know which one. It just started working after I left it alone for a day because I had to attend to other matters (and the person who was out of the office finally came back to work).
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now