Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 670
  • Last Modified:

Domain name is wrong when using remote web workplace

Our company's domain name for our Windows network is, e.g.

"ourbigcompanyinc.com"

And the short version of that is:

"BIGCOMPLTD"

However, when I log in to remote web workplace on SBS 2003, and I attempt to "connect to a computer at work" using the Remote Desktop utility, the username defaults to:

"ourbigcompanyinc\username".

Which is wrong... because the short domain name is "BIGCOMPLTD", not "ourbigcompanyinc".

Where is this stuff configured? Is there anywhere in remote web workplace (or in active directory in general) where I can configure the domain name?

---

My question is actually very similar to this person's:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_27513178.html

And this person seemed to have found a solution but I don't understand what they did:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Remote_Desktop-Terminal_Services/Q_25713461.html

But I need an actual solution. The NETBIOS name is populated incorrectly in SBS 2003 Remote Web Workplace because my NETBIOS name is different from the left hand side of my FQDN name.
0
Frosty555
Asked:
Frosty555
  • 2
1 Solution
 
Frosty555Author Commented:
Okay, I solved this one myself with a hack.

The problem was not a configuration issue in active directory, rather it was just a bug in the Remote Web Workplace code, which you can tweak manually.

The problem is Remote Web Workplace incorrectly assumes that your NETBIOS domain name will just be the left hand side of your regular domain name (e.g. full domain is ourbigcompanyinc.com, netbios name is assumed to be OURBIGCOMPANYINC). This is not correct in my domain.

So to fix it, you can edit the code in RWW and force it to use the desired domain name.

Make a backup, and then edit the file:

C:\INETPUB\Remote\tsweb.aspx

Put a note on line 33 after the <body> tag stating that you edited the file, so that a future administrator doesn't get totally confused by the behavior of Remote Web Workplace. e.g.:

...
	<body scroll=yes text="black" bottomMargin="0" bgColor="white" leftMargin="0" topMargin="0" rightMargin="0">

NOTE TO ADMINISTRATORS: This script has been  customized to force the "BIGCOMPLTD" domain name instead of using the (incorrect) HTTP GET parameter. See line 356 of C:\inetpub\remote\tsweb.aspx.
	
    <form id="headerform" runat="server">
...

Open in new window


Now, roughly around line 356, change this code:

			' If there is a domain name, set it
			domain = getQS("Domain")		

Open in new window


To this:

			' If there is a domain name, set it
			domain = "BIGCOMPLTD"		

Open in new window


Save it, and and now the domain name will be forced to "BIGCOMPLTD" when you attempt to remote desktop into a computer via Remote Web Workplace.

Obviously this is a fragile change. It can get reverted by Windows via an update or something else. Also it's only appropriate when you have a single domain. But it worked for me.
0
 
Frosty555Author Commented:
Found my own solution
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now