• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 379
  • Last Modified:

Java not working in IE works fine with other browsers

We have a client with Windows 7 32bit Pro  & IE9. Java installs  fine but does not seem to work in IE, when you access the exact same sites using Firefox though everything is fine.

System admin does not want the client using Firefox so IE is the only option.

The issue was the same with IE8.

We have even rebuilt the PC but the issues still stands.

The latest version of Java was installed today but to no avail.
0
diles
Asked:
diles
  • 7
  • 5
  • 4
  • +1
1 Solution
 
Ken ButtersCommented:
Can you expand on "Does Not work"...?
0
 
dilesAuthor Commented:
If the user visits the following page for example: http://www.easyjet.com/en/routemap
then the map will be displayed as a black box, however if you run the cursor over it you may get flashes of the map but it will always go back to being black. You cannot interact with it in any other way.

In Firefox the map will display perfectly.
0
 
Ken ButtersCommented:
This is a java test page.

http://java.com/en/download/installed.jsp

When you click on this link, you will most likely be prompted for permission to run the application.  

Allow it to run.  Does the browser report back that Java is installed ok?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
dilesAuthor Commented:
Nope

Verify Java Version

 
We are unable to verify if Java is currently installed and enabled in your browser.

 If you have installed Java and there is an error with the verification, there could be a configuration issue (eg. browser, Java control panel, security settings). Try restarting your browser before trying to verify the installation again.
0
 
Ken ButtersCommented:
It could be that java is not enabled in your browser.  
Here is how to enable Java in IE :

1.Click Tools and then Internet Options
2.Select the Security tab, and select the Custom Level button
3.Scroll down to Scripting of Java applets
4.Make sure the Enable radio button is checked
5.Click OK to save your preference

was the Scripting of Java applets radio button already checked?
0
 
dilesAuthor Commented:
Going in tomorrow morning, got a 2nd pc now doing the same after the latest Java update.
0
 
jcimarronCommented:
FWIW--I got the notice to install Java's latest version (Java 7 Update 45).  When installed I could no longer get the time readings on www.time.gov and http://nist.time.gov.
When I used System Restore to revert to Update 40, the time sites work fine.
0
 
David Johnson, CD, MVPOwnerCommented:
That site is javascript and not JAVA
0
 
jcimarronCommented:
ve3ofa--I assume you are posting to diles , and not me.  (I just took diles' word that the problem was with Java and offered my recent experience with Java.)

If you are correct, the answer by buttersk  ( http:#a39594709 ) should help, even though buttersk has also mixed up Java with javascript.  

And Active Scripting should also be set to Enable.
0
 
Ken ButtersCommented:
@jcimarron... I going to have to disagree with your comment on my mixing up javascript with java.

@Ve3ofa...   http://www.time.gov/ uses both Java and javascript.

The option to allow java applets, (which are small java programs... not javascript), is enabled or disabled as described above. (http:#a39594709)
0
 
dilesAuthor Commented:
Just checked teh seetinsg and the Java applets radio button is already checked.

It appears as if the issue is appears to be related to ActiveX Filtering rather than Java, it just so happened to occur after Java updates.
0
 
dilesAuthor Commented:
Disabled ActiveX Filtering and all websites we have tested appear to be working correctly. Sorry for teh mis-direction but it really was looking like a Java issue.

We have seven of the same PC's here and none of them have this issue, just odd that ActiveX filtering was obviously enabled by default on this image and not any of the others.
0
 
David Johnson, CD, MVPOwnerCommented:
@buttersk http://www.easyjet.com/en/routemap is the site the asker was having problems with not http://www.time.gov/ , as it turns out it was active-x filtering that was the problem.
0
 
dilesAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for diles's comment #a39596542

for the following reason:

This is what resolved the problem.
0
 
Ken ButtersCommented:
JCiMarron made the suggestion to enable activex scripting which ended up being the solution.

Since the solution used was provided as part of this question, I think that points should be awarded accordingly.
0
 
jcimarronCommented:
buttersk--Most considerate of you.
0
 
dilesAuthor Commented:
Apologies to jvimarron. My fault entirely I didn't read your post fully and accept that you should of course be awarded the points.
0
 
jcimarronCommented:
diles--Glad to have helped.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 7
  • 5
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now