Significant lag in viewing uploaded network files

We have several computers running Windows 7 Pro with Virtual XP Mode running on them as clients to a Windows Server 2008 file server.  XP Mode is using the physical network adapter as necessary for the domain configuration. When saving a file to a shared network drive from XP Mode the file appears immediately to the XP computer, but in many cases takes several minutes to show as an available file from the Windows 7 side. What could be causing this and how might we get around the problem?
Brian StricklinIT Systems AdministratorAsked:
Who is Participating?
 
gurutcConnect With a Mentor Commented:
The above comment is correct.  You want to disable SMB2. We had this exact same issue.
It's a well known problem.

Here's the MS link:

http://support.microsoft.com/kb/2696547

Ignore MS' warnings about leaving this disabled.  They're just wrong.

Good Luck,
- gurutc
0
 
Bill BachPresidentCommented:
For file sharing, Windows 2008 and Windows 7 use a newer networking protocol called SMB2. Windows XP uses an older SMB protocol.

Just because SMB2 is newer doesn't make it better. MS decided to create a "loose cache" for SMB2 which causes this lag.

Luckily, you can disable SMB2 if you want to, by just googling "disable SMB2" and following the short instructions. This can be done on either the server or client side.

With Windows 8 and Server 2012, SMB2 is replaced with SMB3, which doesn't have the same problems, so this is a temporary change until you get upgraded to the newer environments.
0
 
gurutcCommented:
You'll want to do this on both the Win 7 Clients as well as on your 2K8 Server.

- gurutc
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Brian StricklinIT Systems AdministratorAuthor Commented:
Does SMB2 have to be disabled on both the client and the server?  Or can it be done on the client or server alone?
0
 
gurutcCommented:
We've had to disable it on both sides to fix the issue at our site.

- gurutc
0
 
Brian StricklinIT Systems AdministratorAuthor Commented:
I will try it and see how it works for us.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.