Solved

Magento error

Posted on 2013-10-23
9
73 Views
Last Modified: 2016-06-12
Magento Enterprise 1.3

On front and backend getting this error running on Xampp local:

Fatal error: Uncaught exception 'Exception' with message 'Warning: file_put_contents(): Filename cannot be empty in /Users/tony/mage/app/code/local/Varien/Autoload.php on line 246' in /Users/tony/mage/app/code/core/Mage/Core/functions.php:245 Stack trace: #0 [internal function]: mageCoreErrorHandler(2, 'file_put_conten...', '/Users/tony...', 246, Array) #1 /Users/tony/mage/app/code/local/Varien/Autoload.php(246): file_put_contents('', 'a:319:{s:15:"Va...') #2 [internal function]: Varien_Autoload->__destruct() #3 {main} thrown in /Users/tony/mage/app/code/core/Mage/Core/functions.php on line 245

Its a restore from backup, just really stumped on this, any suggestion where to start??

Thanks
0
Comment
Question by:tonypearce
  • 3
  • 2
9 Comments
 
LVL 58

Expert Comment

by:Gary
ID: 39594747
Is your var folder and sub folders writable?
0
 

Author Comment

by:tonypearce
ID: 39594765
Yes, all set to 777...
Thanks, this does not fix issue.
0
 
LVL 58

Expert Comment

by:Gary
ID: 39594787
Then your PHP temp folder mustn't be writable or the user you are running under doesn't have permissions on the folder. This is on Linux?
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 

Author Comment

by:tonypearce
ID: 39594873
Hi,
I am running on a Mac, with XAMPP :
Apache 2.4.4, MySQL 5.5.32, PHP 5.4.19 & PEAR + SQLite 2.8.17/3.7.17 + multibyte (mbstring) support, Perl 5.16.3, ProFTPD 1.3.4c, phpMyAdmin 4.0.4, OpenSSL 1.0.1e

checked folder and looks like:

owner and group is 'daemon (1)'

path:
/Applications/XAMPP/xamppfiles/temp

How do I check this, sorry never come across this before.
0
 
LVL 25

Expert Comment

by:lenamtl
ID: 39597444
I think this is because your webserver have safe_mode on

http://www.magentocommerce.com/system-requirements
 
You need to set safe_mode to off in  php.ini and restart Xampp

php.ini is located in /xampp/apache/bin/php.ini
0
 

Accepted Solution

by:
tonypearce earned 0 total points
ID: 39597486
Hi,
I have thrown this out to others and solution ended up disabling cache, not ideal but sorted for a while and is local only.

thanks all
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

823 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question