Solved

Cisco 3750 Switch "DHCP: XID did NOT MATCH in dhcpc_for_us()" ERROR

Posted on 2013-10-23
10
1,266 Views
Last Modified: 2013-10-24
Receiving the following error on my 3750 switch after connecting to an ADTRAN switch. I trunked the Cisco switch ports with a native VLAN.

Cisco Switch port config;

interface GigabitEthernet3/0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet3/0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk


007417: Oct 23 15:40:50 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007418: Oct 23 15:40:50 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007419: Oct 23 15:42:12 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007420: Oct 23 15:43:13 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007421: Oct 23 15:44:07 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007422: Oct 23 15:44:08 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007423: Oct 23 15:46:10 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007424: Oct 23 15:46:11 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007425: Oct 23 15:46:22 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007426: Oct 23 15:46:23 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007427: Oct 23 15:46:24 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007428: Oct 23 15:46:25 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()
007429: Oct 23 15:46:26 EDT: DHCP: XID did NOT MATCH in dhcpc_for_us()


What is the error related to as the Cisco switch is not a DHCP server.
0
Comment
Question by:solarisjunkie
  • 6
  • 4
10 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 39595376
Are you sure dhcp isn't enabled? Can you post the config? Also the two trunk configs, are they part of a port channel or is one blocked by spanning tree?
0
 

Author Comment

by:solarisjunkie
ID: 39595435
DHCP isn't enabled and they are not part of a port channel Here is the config:

spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
!
!
port-channel load-balance src-dst-ip
!
vlan internal allocation policy ascending
!
vlan 2
 name mgmt
!
vlan 3
 name internet
!
vlan 5
 name servers
!
vlan 10
 name data
!
vlan 100
 name wireless_secure
!
vlan 101
 name wireless_guest
!
ip ssh version 2
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0
 no ip address
 no ip route-cache cef
 no ip route-cache
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/9
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/10
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/11
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
!
interface Vlan10
 description DATA VLAN
 ip address 192.168.33.1 255.255.255.0
 ip helper-address 192.168.35.10
!
0
 

Author Comment

by:solarisjunkie
ID: 39595486
dhcp helper address is actually enabled on the vlan interfaces
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39595738
Boom! Exactly! :)
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39595742
Remove and see if the errors still occur.
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Author Comment

by:solarisjunkie
ID: 39595810
the addresses are acquired via an AD server so if I take the ip helper off that vlan how will they know where to get the dhcp address from. Do I make it a global dhcp helper command?
The adtran switch is servicing our phones which are pulling an ip address from dhcp. Those Adtran switches are connected to the Cisco switches via the trunk ports and they are aslo trunked.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39595844
Okay, so you don't want to remove that command, but it's definitely coming from you dhcp relay agent.

Can you post your output for:

sh int trunk

sh spanning-tree vlan 10
0
 

Author Comment

by:solarisjunkie
ID: 39597086
***************
sh int trunk
***************
Gi1/0/23    on               802.1q         trunking      10
Gi1/0/24    on               802.1q         trunking      10
Po1            on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi3/0/23    1-4094
Gi3/0/24    1-4094
Po1            1-4094

Port        Vlans allowed and active in management domain
Gi1/0/23    1-3,5,10,100-101
Gi1/0/24    1-3,5,10,100-101
Po1            1-3,5,10,100-101

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/23    1-3,5,10,100-101
Gi1/0/24    1-3,5,10,100-101
Po1            1-3,5,10,100-101


***********************
sh spanning-tree vlan 10
***********************
VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     xxxx.xxxx.xxxx.xxxx
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     xxxx.xxxx.xxxx.xxxx
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec


Po1                    Desg FWD 3         128.488  P2p
Gi1/0/23            Desg FWD 4         128.131  P2p
Gi1/0/24            Desg FWD 4         128.132  P2p
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
ID: 39597246
What is the port channel connected to?  Also, can you post similar output from the adtran?
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39599028
What was the outcome?
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now