Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 445
  • Last Modified:

PDF opens from filesystem but not from email

Hi Experts,

I recently setup an old PC with WinXP SP3 and OE (Outlook Express 6) for a friend.

I installed Adobe Reader XI, but when the user tries to open PDFs attached to emails, this message comes up:
 "This file does not have a program associated with it for performing this action.  Create an association in the Folder Options control panel"
(The only button available from that error dialog box is "OK".)
To work around this, the PDF can be saved and opened from the filesystem (e.g. via Windows Explorer) by simply double-clicking it.

Q1. Why am I getting an error in OE but not in Windows Explorer?
Q2. How can it be resolved, so PDFs can be opened directly from OE?

Thanks.
Tel2
0
tel2
Asked:
tel2
  • 8
  • 5
  • 5
2 Solutions
 
Dave BaldwinFixer of ProblemsCommented:
OE has 'extra security' measures.  In Windows Explorer, it is assumed that the files belong to you... except that you can require access to downloaded files to put up a message before allowing you to open them.  In OE, Go to Tools -> Options and on the Security tab is a check box to block opening any attachments.
0
 
Steven HarrisPresidentCommented:
If Dave's suggestion doesn't solve it, you can try closing OE, resetting your PDF file association and restarting OE.
0
 
tel2Author Commented:
Hi Dave,

Thanks for the suggestion.  This is 1 of 2 PCs which are from the same source and are setup very similarly.  The other works fine in this OE PDF respect.  The one that fails with PDFs works fine with XLS files, etc.  The settings in OE > Tools > Options > Security are the same on both PCs, plus my PC which also has WinXP with OE6, i.e.:
    Internet zone (NOT selected)
    Restricted sites zone (selected)
    Warn me if other applications try... (checked)
    Do not allow attachments to be saved or opened that could potentially be a virus (checked)
    Block images... (checked)
    The 2 secure mail boxes are not checked.

What does this tell you?
I don't think it's about blocking opening attachments.  The error message indicates to me that it's about file/program associations.

Thanks.
Tel2
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
Dave BaldwinFixer of ProblemsCommented:
Then go into Folder Options in the control panel and see what file associations are setup.  The one that Windows Explorer is using obviously works.  See if there is another.  Yes, there really could be.

Also check to see if your anti-virus is blocking them.
0
 
tel2Author Commented:
Thanks Dave.

I don't have access to that PC at present, but I'll try to get back to you after I've checked it out.

Tel2
0
 
tel2Author Commented:
Hi Dave,

I've just been on the phone to someone who has access to the PC with the problem.  I got them to send me a screen dump of the Folder Options screen.  See attached.

Does that tell you anything, or is there something else we should be looking at?

I was not aware that Windows file associations were different depending on what program you are in when you open a type of file.  I thought they were simply about what program opens what types of files.  No?

TRS
Folder-Options---PDF.gif
0
 
Steven HarrisPresidentCommented:
Check .PRC as well.
0
 
tel2Author Commented:
Thanks TSS.
Please explain how PRC file associations might be the cause.  The attachments have .PDF extensions.
TRS
0
 
Steven HarrisPresidentCommented:
PRC is used within, or embedded into, PDFs.  So just covering the bases.
0
 
tel2Author Commented:
OK.  Thanks.
0
 
Steven HarrisPresidentCommented:
I just ran across the following on the Adobe Forums, but no OS info was given.  Maybe it will help:

0.  Close Outlook Express
1. Open the Folder Options dialogue box (Tools/Folder Options from any Explorer or My Computer window)
2. Select the 'File Types' tab at the top of this dialogue box
3. Locate the .pdf filetype and click 'Advanced'
4. The 'Edit File Type' dialogue box appears; I found that the 'Open' action is not listed, instead there was a 'Read' option. Click the 'New' button to create a new action
5. The 'New Action' dialogue box appears; in the 'Action' box, type 'Open' (no quotes) and then click 'Browse'
6. Locate Acrobat Reader's executable by navigating to c:\program files\adobe\acrobat[x]\ (where [x] is 6.0 or 7.0 or similar) and selecting the 'acrord32.exe' file, then hitting 'Open'
7. Ensure the 'Use DDE' checkbox is unticked, then hit 'OK'
8. Open Outlook Express and test that double-clicking a .pdf attachment opens the file directly in Acrobat Reader.
0
 
Dave BaldwinFixer of ProblemsCommented:
This is what I have for PDFs.  It is odd that your pic above refers to PDFs as "AudioCD" type file.
PDF file type info
0
 
tel2Author Commented:
OK TSS.  I might try that next time I'm on that PC.
Thanks.
TRS
0
 
Steven HarrisPresidentCommented:
Yes, I would definitely suggest looking...  If you look at DaveBaldwin's image, the second window has Open with Adobe Reader XI, which is what the Adobe Forum post shows  to be adding.
0
 
tel2Author Commented:
Hi Dave,
Thanks for that screen shot.  Sorry, I somehow missed your post until TSS brought it to my attention.
> It is odd that your pic above refers to PDFs as "AudioCD" type file.
Agreed!  But I had a look at it yesterday and for some reason, it would show the details of the previously selected extension, and as the "AudioCD" file type was the one at the very top of the list, so it showed the details for that.

I tried a few things.  Here are some of them:
The "Advanced" button didn't show, until after I clicked "Restore", then I tried adding an "Open" action, and pointed that to AcroRd32.exe, but alas, that made it even worse, coz even if I try to open a PDF via Windows Explorer it then gave me a new error:
 "There was an error opening this document. This file cannot be found."
So I'd have to click OK 3 or 4 times until the error dialog box disappeared, then I'd be in Adobe Reader, so I could click File > Open, and navigate to my PDF and open it successfully.
I then tried uninstalling Acrobat Reader via Control Panel > Add or Remove Programs, then reinstalling it (still version XI), but still got that same error when trying to open PDFs via Windows Explorer:
 "There was an error opening this document. This file cannot be found."
Tried Googling for the error, and found plenty of hits, but haven't had enough time to try any of them yet.
This one:
    http://forums.adobe.com/thread/1079420
is not quite my situation, but I'm hoping it will work for me.  Might be able to try it next Sunday.

TSS, I tried to find PRC, but there was none on that PC.  However, on my PC, PRC is a "Palm Application" (for my old Palm Treo phone, I think).
0
 
Dave BaldwinFixer of ProblemsCommented:
Right click on your file name in Windows Explorer and then click on Open and see what happens.  Also see if 'Play' instead of 'Open' is the default action which will be in bold text at the top of the right-click menu.  'Open' or 'Open with Adobe Reader XI' should be the default action.  If 'Play' is the default, go back into the file associations and remove it.  Also check to see if any other standard file associations are broken.
0
 
tel2Author Commented:
Hi experts,

Sorry for the long delay in responding.  Finally got a good opportunity to experiment with the PC which has this problem, yesterday.

Dave, when I right-clicked on a PDF file, in Windows Explorer, I think it showed:
    Open with Adobe Reader XI       [default]
    Open
    Print
But when I clicked edit on the above items, the "Application used to perform this action" was set to:
    "C:\Program Files\Adobe\Reader 11.0\Reader\AcroRd32.exe"
but there were no parameters after the path!  I saw from a working environment that:
For "Open with Adobe Reader XI" it should be:
    "C:\Program Files\Adobe\Reader 11.0\Reader\AcroRd32.exe" "%1"
(I think "Open" was the same as above - can't recall.)
For "Print" it should be:
    "C:\Program Files\Adobe\Reader 11.0\Reader\AcroRd32.exe" /p /h "%1"
For "Printto" it should be:
    "C:\Program Files\Adobe\Reader 11.0\Reader\AcroRd32.exe" /t "%1" "%2" "%3" "%4"
The other non-blank fields for all the above were:
    Use DDE (ticked)
    Application: AcroRd32
    Topic: System

I also noted that the icon that showed next to PDF files in Windows Explorer on the problem PC had a large white border surrounding the logo, which was different from the one on the working PC.

I deleted the PDF association, and re-added it with the above settings, PDFs started opening normally again, from email and from Windows Explorer.

Thanks for your help, everyone.

tel2
0
 
Dave BaldwinFixer of ProblemsCommented:
Good, glad you got it sorted out.  Thanks for the points.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 8
  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now