Solved

Outlook Express spell check in French only

Posted on 2013-10-23
32
508 Views
Last Modified: 2013-11-04
Hi Experts,

I recently setup an old PC with WinXP SP3 and OE (Outlook Express 6) for a friend.

The user likes to use the OE option:
    Tools > Options > Spelling > Always check spelling before sending
However, with that checked, when a message is sent it is picking up errors with basic English words, like "you", etc.
So, looking at:
    Tools > Options > Spelling > Language
we see that the only language available on the dropdown is French.

If we go into:
    Control Panel > Regional and Language Options > Languages > Details
we can see the Default input language is:
    "English (United States) - US"
and Installed services are
    EN  English (New Zealand)     (that's our country)
    ...
    EN  English (United States)
    ...

Q1. Why is French the only language available on the OE Spelling dropdown?
Q2. How can we set it to English (preferably NZ or UK)?

Thanks.
Tel2
0
Comment
Question by:tel2
  • 12
  • 6
  • 5
  • +3
32 Comments
 
LVL 90

Expert Comment

by:John Hurst
ID: 39595822
I have English US and others, French, and others.

Try this:  Go to Control Panel, Region and Language options, Advanced Tab. Select English US and then click on the setting at the bottom that says Apply current settings to current profile and default profile. BE CAREFUL. It will do what it says, and you may not want to do it without checking your settings first.

.... Thinkpads_User
0
 
LVL 11

Author Comment

by:tel2
ID: 39595885
Hi thinkpads_user,

OK - tried that, first with "English (New Zealand)", then with "English (United States)".  Each time I would tick the box to "Apply all settings...", then allow it to restart, but still that same issue - only French is listed on the OE Spelling dropdown.

Tel2
0
 
LVL 90

Assisted Solution

by:John Hurst
John Hurst earned 100 total points
ID: 39595892
You have another question out about Outlook Express and PDF files.

It may be your XP set up was set up in a bit of hurry and went wrong. My XP machine is Virtual (I run Windows 8 as a host machine), but I do not have these issues (spelling or PDF files).

I am not sure what to suggest because OE cannot be repaired. It either works or it doesn't.

Two options:

1. Try an Office Suite and use Outlook.
2. Reimage the XP machine and try again with a fresh install.

.... Thinkpads_User
0
 
LVL 23

Assisted Solution

by:Alan Henderson
Alan Henderson earned 50 total points
ID: 39595906
System File Checker often fixes mysterious problems. It's always worth a try:

Click Start,
Click Run,
Type sfc /scannow,
Then click OK and follow the instructions.
0
 
LVL 11

Author Comment

by:tel2
ID: 39595907
Hi thinkpads_user,

The same thing is happening on a different PC from the same source.  It was probably setup in the same way though.

I'm aware of those options, but I would hope there's a simpler fix.  Basically, OE seems to just not be seeing all the languages.

Let's see if anyone else has any ideas.

Thanks.
Tel2
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 39595916
You can try uninstalling SP3 first, then download SP2 from Microsoft and re-apply SP2. SP2 is a re-write of XP and so reinstalling SP2 may help. Reinstall SP3 after and patch XP fully.

... Thinkpads_User
0
 
LVL 11

Author Comment

by:tel2
ID: 39595929
Thanks vallis.  I recall doing that months ago on a different PC for something else.
Trying that now...

Thanks thinkpads_user.  Sounds complex and time consuming.  I'll see if vallis's suggestion works first, or if any one else has any other ideas.
0
 
LVL 11

Author Comment

by:tel2
ID: 39596010
Hi all,

Unfortunately, the sfc /scannow didn't help.

It seems that OE's spell check doesn't work (for anything except French) when you have Office 2007 installed, which I do in this case.

Here's some info on that:
    www.outlook-tips.net/tips/tip-379-office-2007-and-oe-spell-check
    http://support.microsoft.com/kb/932974
    http://help.wugnet.com/windows2/french-spellcheck-ftopict520643.html

Sorry - I didn't realise the version of Office was relevant in this case, so I didn't even think to mention it in my previous posts.
So, I might look at installing a different dictionary, or asking the user if they're willing to migrate to Outlook 2007.

But thanks to both of you for trying.

I'm planning to accept this post as the solution.  Any complaints?

Tel2
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 39596027
I suggested trying an Office Suite above. Also, you never mentioned having Office 2007 installed.

So then if you wish to close the question, you might wish to provide assist points.

... Thinkpads_User
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 39596031
Also, my own system had Office 2003 installed and OE spell checks just fine. I see the link above faults Outlook 2007.

Ah well, XP is dead and gone, OE is deader and gone, so whatever you wish to do.

... Thinkpads_User
0
 
LVL 11

Author Comment

by:tel2
ID: 39596034
Points taken, thinkpads_user.  I'll bear that in mind.

In my last post I explained why I didn't mention that I had Office 2007 installed, and I'm not sure whether that would have helped you answer my questions in this case.

I'm glad I didn't waste hours on guesses like:
- Reimage the XP machine and try again with a fresh install.
- You can try uninstalling SP3 first, then download SP2 from Microsoft and re-apply SP2. SP2 is a re-write of XP and so reinstalling SP2 may help. Reinstall SP3 after and patch XP fully.

because they would have taken ages and wouldn't have helped.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 39596048
I'm glad I didn't waste hours on guesses like ...:

So am I. At the time of my earlier post, we did not have all the facts at hand. And you are right - in this instance it would not have helped.

... Thinkpads_User
0
 
LVL 41

Expert Comment

by:Jackie Man
ID: 39596240
This is another fix which shall fulfill your requirements.

"Problem: spell check in OE comes up in French

(only for students that are have XP for OS and MS Office 2007 installed)

Cause: OE spell check dictionary is pulling from MS Office 2007 which is default in French

Fix:   Have the student open their MS Office word 2007>

Click the MS Office Icon

Go down to word options button

Click on proofing

Put a check in (suggest from main dictionary only)

Click the drop down button by – dictionary languages

Go down and select English (united states)

Click ok twice

Restart their OE and try again to use the spell check"

Source: http://blogs.msdn.com/b/dgoldman/archive/2007/01/03/how-to-fix-the-outlook-express-spelling-checker-when-the-french-dictionary-is-the-only-dictionary.aspx

Third-party dictionaries just for OE is not an option for me.
0
 
LVL 11

Author Comment

by:tel2
ID: 39596303
Thanks for that, Jackieman!

The part I'm struggling with is the instruction that says:
    Click the drop down button by – dictionary languages

Attached is a screen shot of my Word 2007 > Word Options > Profiling window.

Where is the dictionary languages dropdown?

I see a "Dictionary language:" dropdown appears if I click the "Custom Dictionaries" button, but that doesn't sound relevant, and it didn't help when I changed that to "English (U.S.)", etc, then started OE.

Thanks.
Tel2
Word-2007-Options-Profiling-1.GIF
0
 
LVL 62

Accepted Solution

by:
☠ MASQ ☠ earned 125 total points
ID: 39596389
There is no simple fix for this, once you install Word's spell checker OE's spell checker no longer functions.  There s a long-winded fix which has been suggested which - if you have no option to install a third-party checker - may be worth investigating in your case.

See my earlier comment here
0
 
LVL 41

Assisted Solution

by:Jackie Man
Jackie Man earned 100 total points
ID: 39596500
Agreed.

Sorry for the misleading info and it seems that the Spell Checker for OE 2.1 from majorgeeks is not a compelety third party solution as the files added are just the files from the orginal spell checker for OE6.

http://www.majorgeeks.com/files/details/spell_checker_for_oe.html

I will give it a green light to proceed with the fix above.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 11

Author Comment

by:tel2
ID: 39599628
Thanks for that, Masqueraid.


Hi Jackieman,
> Agreed.
Who and what are you agreeing with?  Something I said or something Masqueraid said?  What comment in particular?

Could you (or anyone else) please answer the following question from my previous post:
> Where is the dictionary languages dropdown?
See my previous post for context.

Thanks.
Tel2
0
 
LVL 62

Expert Comment

by:☠ MASQ ☠
ID: 39599658
Drop down should be here:

OE6 Spell Check Dictionary Choices (This is XP & Office 2003)
But it won't be functional if you've added the Office 2007 spell checker extensions. OE knows it has the dictionaries but it is their function that is broken by the Office install.
0
 
LVL 11

Author Comment

by:tel2
ID: 39599693
Thanks Masqueraid, but did you read my question in the context of the post it came from?  The dropdown I'm refering to should be on the: Word 2007 > Word Options screen, as per the instructions posted by Jackieman.  See the image attached to my 39596303 post to see what I'm seeing on that screen.
0
 
LVL 41

Assisted Solution

by:Jackie Man
Jackie Man earned 100 total points
ID: 39599900
Who and what are you agreeing with?  <- something Masqueraid said

It needs third party spelling utility to fix the OE issue.

You can custom install the spelling tool from Office 2003 if you got the CD or the ISO file for Office 2003.
0
 
LVL 62

Assisted Solution

by:☠ MASQ ☠
☠ MASQ ☠ earned 125 total points
ID: 39600135
>>did you read my question in the context of the post it came from?  

Sorry, clearly not :)

Changing the settings in Office isn't going to help with OE the .dll library used is separate but some of the files have the same name which is part of the issue with the Office install disabling OE

If you do want to get to the separate language selection dictionaries in Word 2007 though it's pretty much the route you've already shown in your screenshot:

- Hit the Start button on the 2007 Ribbon
- Choose the "Word Options" button at the bottom of that pane
- Choose the Proofing menu
- Then the "Custom Dictionaries" button

The Dictionary language drop down is at the bottom of the small window that opens, but by default should be set to "All Languages".
0
 
LVL 11

Author Comment

by:tel2
ID: 39601543
Thanks for that, Masqueraid,

>>did you read my question in the context of the post it came from?  
> Sorry, clearly not :)

I guess you didn't see the part where I wrote:
    > See my previous post for context.
either.   8)

> If you do want to get to the separate language selection dictionaries in Word 2007 though it's pretty much the route you've already shown in your screenshot:
Sure is, which is why I wrote:
> I see a "Dictionary language:" dropdown appears if I click the "Custom Dictionaries" button, but that doesn't sound relevant, and it didn't help when I changed that to "English (U.S.)", etc, then started OE.
Good to know I was on the right path, though.

Thanks.
0
 
LVL 62

Expert Comment

by:☠ MASQ ☠
ID: 39601761
Yes, had the context just added the detail for completeness, it's just that making changes there won't affect the OE spell checking.
0
 
LVL 50

Assisted Solution

by:jcimarron
jcimarron earned 125 total points
ID: 39602938
0
 
LVL 11

Author Comment

by:tel2
ID: 39604371
Hi jacimarron (and others),
Thanks for that.  Do you know if any of those UK English?  I don't know if you noticed my comment:
>   EN  English (New Zealand)     (that's our country)
but NZ used UK English.

I tried installing Office 2003's proofing tools on a different PC, and from memory that had a UK English option which worked, but having read the warnings about doing this, I don't think I'll use that solution.
0
 
LVL 50

Assisted Solution

by:jcimarron
jcimarron earned 125 total points
ID: 39604421
tel2--
No I do not know.  But OE had a built in spell checker which was nuked by installing Word 2007.  So maybe restoring the corrupted CSAPI3T1.DLL on a PC that presumably has UK English in other respects (such as Windows and Office) will allow OE to also work in UK English.
After the repair of doesn't OE have the option of many languages again in Tools > Options > Spelling > Language?
And what version of English is your Word set to?

And see
http://www.pcadvisor.co.uk/forums/1/tech-helproom/376703/uk-english-spell-checker-for-outlook-express/
0
 
LVL 62

Expert Comment

by:☠ MASQ ☠
ID: 39604427
Nope all the third-party OE6 fixes for the Office install problem are English (US) :(

This may be a step too far but if you've only just installed this machine for your friend you could get around all of this by reinstalling and using Office 2003 instead of 2007- just a thought.
0
 
LVL 50

Assisted Solution

by:jcimarron
jcimarron earned 125 total points
ID: 39604492
tel2----It could be hard to say whether replacement of the corrupt CSAPI3T1.DLL file with a new one is a third party fix.
Why don't you try it?  Set a System Restore point before doing so.  That way you can easily revert if you do not like the results.
0
 
LVL 11

Author Comment

by:tel2
ID: 39604582
OK - thanks for all that, guys.

Hi jacimarron,
> After the repair of doesn't OE have the option of many languages again in Tools > Options > Spelling > Language?
When I installed the Office 2003 proofing stuff, it had English (US) on the dropdown, but not English (UK).
> And what version of English is your Word set to?
Where do I check/set this?  I guessed the place to set this was under:
    Start > Programs > Microsoft Office > Microsoft Office Tools > Microsoft Office 2007 Language Settings.
The "Enabled Languages" which I set some time ago are:
  English (New Zealand)
  English (U.S.)
BTW, it allows me to remove "English (U.S.)", but if I click "OK" then go back to that screen, "English (U.S.)" comes back.
The "Primary editing language" on that same screen is set to:
  English (New Zealand)

I notice that in Word 2007 > ... > Word Options > Proofing, it has a "French modes" option half way down the screen.  Is that normal?

Thanks.
0
 
LVL 50

Assisted Solution

by:jcimarron
jcimarron earned 125 total points
ID: 39606516
tel2--
Yes, see this reference for info on French modes--under Select a French Mode
http://office.microsoft.com/en-us/help/choose-how-spelling-and-grammar-checking-work-HP010119467.aspx

Have you tried replacing CSAPI3T1.DLL
0
 
LVL 11

Author Closing Comment

by:tel2
ID: 39620737
Thanks to all of your for your suggestions.

Hi jcimarron,
Have you tried replacing CSAPI3T1.DLL.
No, but I've considered that and thanks for the suggestion.

tel2
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 39621984
tel2--
You are welcome.
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now