Solved

Cisco Wireless Bridge Speed

Posted on 2013-10-24
19
413 Views
Last Modified: 2013-10-25
I am having an issue with a wireless bridge I have setup were I am getting higher data rates on one segment (with the greater distance) than on the smaller segment.  The bridge consists of 4 Cisco Aironet 1300 units composing two segments with a simple Netgear ProSafe GS105 switch between them.

Segment 1:  Internet <-ethernet-> Cisco1300(A) <-wireless-> Cisco1300(B)
<--Switch-->
Segment 2:  Cisco1300(C) <-wireless-> Cisco1300(D) <-ethernet-> Computer

Both segments have clean line of sight.  Segment 1 is about 2/3 of a mile.  Segment 2 is about 500 yards.

If I plug my laptop into the switch between the segments I get ~9Mb/s connectivity.  However, if I plug into the switch at the end of segment 2 I only get ~2Mb/s.  Best I can tell all the 1300s are configured the same, but the interface has a lot of settings and I could easily be missing something. :-)  Any ideas?
0
Comment
Question by:slattdog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 8
19 Comments
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39597972
Can you post the config from each bridge, and also the output from show dot11 assoc detail
0
 

Author Comment

by:slattdog
ID: 39598282
I'm working in the GUI.  Is there a way to export that?
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39598292
Yes it's easy in the GUI. Go to Associations on the Root Bridge, then click on the MAC address of the remote bridge and screen-shot what you see.  That's the stats I need to see.

To get the config, go to the Software tab and you'll see a link to the configuration.  Click on config.txt and post the output.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:slattdog
ID: 39598325
Segment 1
Segment 1
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Aironet-Barn
!
enable secret 5 $1$INeR$QrX.4.EF2AIbWYmz1oDnc0
!
ip subnet-zero
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id common
!
dot11 ssid Middle-Earth
   authentication open mac-address mac_methods
!
dot11 network-map
!
!
username 8843e1d1fa9a password 7 1016514D5612430F5D022B7225
username 8843e1d1fa9a autocommand exit
username 0026cb6a39e0 password 7 101E594B5314105D0D57732E74
username 0026cb6a39e0 autocommand exit
username Cisco privilege 15 password 7 13361506290310097A
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 CFA85B41516184AB645703D6B7C9 transmit-key
 encryption mode wep mandatory
 !
 ssid Middle-Earth
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 192.168.7.10 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.7.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end
0
 

Author Comment

by:slattdog
ID: 39598330
Segment 2
Segment 2
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Aironet-Mark2
!
enable secret 5 $1$/Pj/$0Wap1kEJOPD1X8TJxCB0o.
!
ip subnet-zero
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id common
!
dot11 ssid Middle-Earth
   authentication open mac-address mac_methods
!
!
!
username 8843e1d1faee password 7 05535E5B72491F0D480316170E
username 8843e1d1faee autocommand exit
username 0026cb6a3d70 password 7 00544354525809500E72481959
username 0026cb6a3d70 autocommand exit
username Cisco password 7 122A0703300418277B
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 ECC22749423DEB8C70590102B88A transmit-key
 encryption mode wep mandatory
 !
 ssid Middle-Earth
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 192.168.7.14 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.7.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39598363
Ok, on each root bridge could you go to the association page, click on the remote bridge and do a link test, then post the result?
0
 

Author Comment

by:slattdog
ID: 39598423
Segment 1
Segment 1
0
 

Author Comment

by:slattdog
ID: 39598433
Segment 2

A window popped up saying the test was still running but not receiving a responce do I want to wait or cancel.
0
 

Author Comment

by:slattdog
ID: 39598486
I notice that this event occurs over and over in the log on 1300 at the non-root end of Segment 2:

duplex mismatch discovered on FastEthernet0 (not half duplex), with SIP30F70d5EDCF0 wlan0 (half duplex).

Not sure what that means or if it's significant.  I don't notice it on any of the other 3 though.
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39598612
That looks like a CDP message from an IP phone running SIP software.  Are any of the interfaces between the two sites running at half-duplex?
0
 
LVL 46

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 39598633
The link test is fluctuating between data-rates.

On that segment1 link can you change the channel to something different to what it is on now?  If it's on Channel 1, set it to Channel 11, or vice-versa.
0
 

Author Comment

by:slattdog
ID: 39598662
If they are running half duplex its not anything I would have set.  Unless they do that by default.  Where would I check that?
0
 

Author Comment

by:slattdog
ID: 39598698
Segment 1 after changing channel from 11 to 1
seg1
0
 

Author Comment

by:slattdog
ID: 39598702
Segment 2 after moving Segment 1 to different channel.

seg2
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39598904
Segment 2 - it's perfect.  Don't touch it again :-)

Segment 1 is a lot better than it was.  I'd test again now to see what the speeds are like.
0
 

Author Comment

by:slattdog
ID: 39600277
Speed at the end of segment 1 is still ~9Mb, but at the end of segment 2 it is now ~6Mb.  That is much impoved, but still doesn't make sense to me :-)  If segment 2 is "perfect" (and communicating at 54Mb) why is a mere 9Mb of bandwidth from segment 1 being further reduced?
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39600309
The traffic is being resent as the link isn't perfect at Segment1.  That reduces bandwidth.

The fact that you changed the channel and it got better tells me that there is some interference around the Segment1 link.  If you can play with the channels and do a link-test each time you change the channel you might find a channel which gives you 100% at 54Mbps, instead of some packets sent at lower data-rates.
0
 

Author Comment

by:slattdog
ID: 39600326
Sounds good.  I'll work on it.  Thanks so much for your fine help craigbeck!
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39600364
No problem - my pleasure :-)
0

Featured Post

Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question