Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook 2013 search fails because indexing never completes

Posted on 2013-10-25
8
Medium Priority
?
19,483 Views
1 Endorsement
Last Modified: 2013-11-18
Every time I enter some text into the "Search Inbox" field above the list of messages, it displays a message "Search results might be incomplete because items are being indexed" and no actual results appear.

Then, when I click on the message I get a dialog showing me that over 100,000 items are remaining to be indexed.  The actual number never changes even when I click on the message hours later.

I have tried to rebuild the index and even move it to a different folder but the indexing just never completes and the search function is totally useless.

How can I get the indexing to complete so I can actually search in Outlook?
1
Comment
Question by:KhaiPi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 97

Accepted Solution

by:
John Hurst earned 1500 total points
ID: 39600239
The indexing in Outlook depends on the indexing in Windows with modern systems.

Go to Programs and Features, Windows Features and make sure Microsoft Search is enabled (selected).

Now go to Control Panel, Indexing Options and make sure in the first tab the locations are correct. In a local system the Outlook PST file is in the users main folder, so make sure it is selected.

Then again in Indexing Options, Advanced Tab, click on Rebuild Index. Check every hour or so to make sure indexing is proceeding.

Once complete, search in Outlook should work just fine.

.... Thinkpads_User
0
 
LVL 12

Expert Comment

by:Sommerblink
ID: 39600878
You don't indicate the version of Windows you're running, but (at least) in Windows 7, the indexer is configured by default to 'backoff' when there is mouse or keyboard activity, which means the indexer is going to take a really, really, really long time to index 100,000 emails.

If you are running Windows 7, I have attached two registry files. One which will disable the backoff function and one that will re-enable the backoff function.

The process you will do is this:

1) Apply the disableIndexBackoff.reg file.
2) Depending on skill-level, either reboot the computer -or- go to Control Panel, Services, find "Windows Search", stop the service and start the service.
3) You can monitor the indexing process by launching "Indexing Options" from the search box.
4) Once complete, apply the "enableIndexBackoff.reg file and either reboot the computer or stop/start the Windows Search service again.

The attached registry key only modifies the following key:
HKLM\SOFTWARE\Policies\Microsoft\Windows\Windows Search and the value DisableBackoff, setting it to 1 to disable the backoff function and 0 (default) to enable the backoff function.

You can perform the same action yourself, if you don't trust these two files.
enableIndexBackoff.reg
disableIndexBackoff.reg
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 39601012
the indexer is going to take a really, really, really long time to index 100,000 emails.

If I have to re-index (start over) I give it about 4 hours and it will be done or very close to done. You can also run the indexer overnight and it will complete.

I do not make any registry changes to get this done.

.... Thinkpads_User
0
Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

 

Author Comment

by:KhaiPi
ID: 39640982
I am not sure what to do here...

I have waited a while to respond because after I initially tried the solution suggested by @thinkpads_user it showed some promise with the number of items to be indexed gradually coming down over time.  Then, some days later I was able to do searches again in Outlook.

However, a few days later when I again typed something into the search box I again got the original message about the search not being complete because there were items yet to be indexed.

When I checked I found this number to be over 100,00 again!  So then I repeated the entire process, waited a few days and then the complete cycle started over again.

Right now I am able to search but I fear that in a few days (or at any time really) all items will become un-indexed again.

How can I get the indexing to "stick" and what is causing the items to be un-indexed repeatedly?

BTW, I tried the suggestion of @Sommerblink but when I applied the first registry file the Windows Search Service could not shut down or restart so I undid the registry changes.
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 39641346
There are things that go wrong in an operating system, so that is probably what is happening here.

1. Run System File Checker. Run SFC /SCANNOW and allow to complete. Restart and trying indexing again.

2. Corrupt user profile. Set up a new user profile and try indexing in the new profile. This could be tricky because of a smaller number of items.

3. Run a Windows 7 Repair Install. Here is a Seven Forums Tutorial with instructions on how to do that.

http://www.sevenforums.com/tutorials/3413-repair-install.html

4. Viruses cause issues like this so scan carefully for viruses and malware.

It may be simply easier to back up the machine, reinstall Windows and set it up again.

..... Thinkpads_User
0
 

Author Closing Comment

by:KhaiPi
ID: 39647310
This suggestion did solve my problem but only temporarily.  While I am to search in Outlook *right now*, I am not convinced that this will be the case tomorrow :-(

EIther way, this suggestion was correct so you get my points.
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 39647497
@KhaiPi - Thanks and I was happy to help.

.... Thinkpads_User
0
 

Author Comment

by:KhaiPi
ID: 39656031
Sorry, I forgot to say "thanks" in my closing comment.  So thanks!  Search in Outlook has been working for a while now so fingers crossed...
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Mailbox Overload?
The advancement in technology has been a great source of betterment and empowerment for the human race, Nevertheless, this is not to say that technology doesn’t have any problems. We are bombarded with constant distractions, whether as an overload o…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question