• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1578
  • Last Modified:

Help installing missing libraries

Hi I am helping a friend install OpenVAS.  I am not a linux guru and cannot get these libraries installed via apt-get.

Can someone let me know that modules need to be installed?  

We get these errors:

The following packages have unmet dependencies:                                                                                
 greenbone-security-assistant : Depends: libglib2.0-0 (>= 2.31.8) but 2.24.2-1 is to be installed                              
                                Depends: libgnutls26 (>= 2.12.17-0) but 2.8.6-1+squeeze2 is to be installed                    
                                Depends: libgpg-error0 (>= 1.10) but 1.6-1 is to be installed                                  
                                Depends: libmicrohttpd10 but it is not going to be installed                                  
                                Depends: libopenvas6 (>= 6.0.0) but it is not going to be installed                            
 openvas-administrator : Depends: libgnutls26 (>= 2.12.17-0) but 2.8.6-1+squeeze2 is to be installed                          
                         Depends: libgpg-error0 (>= 1.10) but 1.6-1 is to be installed                                        
                         Depends: libopenvas6 (>= 6.0.0) but it is not going to be installed                                  
 openvas-cli : Depends: libgnutls26 (>= 2.12.17-0) but 2.8.6-1+squeeze2 is to be installed                                    
               Depends: libgpg-error0 (>= 1.10) but 1.6-1 is to be installed                                                  
               Depends: libopenvas6 (>= 6.0.0) but it is not going to be installed                                            
 openvas-manager : Depends: libgnutls26 (>= 2.12.17-0) but 2.8.6-1+squeeze2 is to be installed                                
                   Depends: libgpg-error0 (>= 1.10) but 1.6-1 is to be installed                                              
                   Depends: libopenvas6 (>= 6.0.0) but it is not going to be installed                                        
 openvas-scanner : Depends: libgnutls26 (>= 2.12.17-0) but 2.8.6-1+squeeze2 is to be installed                                
                   Depends: libgpg-error0 (>= 1.10) but 1.6-1 is to be installed                                              
                   Depends: libopenvas6 (>= 6.0.0) but it is not going to be installed
0
nappy_d
Asked:
nappy_d
1 Solution
 
jlevieCommented:
What you are trying to install is asking for later versions of libraries than the system has. In the general case, those versions won't be available for that version of the OS. You could possibly build later versions from source but I suspect that will reveal other problems. The most sane solution is upgrading to a later OS version that has the libraries or finding a copy of OpenVAS meant for the version of the OS you are using.
0
 
surbabu140977Commented:
you need a fix of broken dependencies first,

"sudo apt-get -f install"

Best,
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Author Commented:
OK some more information I totally forgot to post.

We are running Linux version 2.6.32-5-amd64 (Debian 2.6.32-48squeeze1) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Mon Feb
 25 00:26:11 UTC 2013  

I am trying to run this command for OpenVAS:
apt-get -y install greenbone-security-assistant openvas-cli openvas-manager openvas-scanner openvas-administrator sqlite3 xsltproc rsync

I tried the command above but the same output as before.
0
IT Degree with Certifications Included

Aspire to become a network administrator, network security analyst, or computer and information systems manager? Make the most of your experience as an IT professional by earning your B.S. in Network Operations and Security.

 
MazdajaiCommented:
Have you install the repository from OpenVAS?
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Author Commented:
@mazdajai...yes step two of the above link you provided is what started this thread.
0
 
MazdajaiCommented:
6 is an obsolete release (squeeze).

Try upgrade to 7 (wheezy), the packages needed by OpenVAS may not work on 6 anymore.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Author Commented:
Thanks I'll look into this when I have more time.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simple Misconfiguration =Network Vulnerability

In this technical webinar, AlgoSec will present several examples of common misconfigurations; including a basic device change, business application connectivity changes, and data center migrations. Learn best practices to protect your business from attack.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now