Solved

Exchagne 2010 OWA "Page Cannot Be Displayed"

Posted on 2013-10-25
21
5,760 Views
Last Modified: 2013-10-25
Hello Folks,

We have an install of Exchange 2010 and OWA has not been working for several days. When I try to access it with IE, it says "The Website Cannot Display the Page". I am not sure where to start. Can anyone assist?
0
Comment
Question by:JohnnyD74
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 9
  • 2
  • +1
21 Comments
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 39602089
Did you made any changes to Exchange since it was working?
Is the IIS service is started?

You may also check this article too: http://blogs.technet.com/b/exchange/archive/2008/12/31/3406686.aspx
0
 

Author Comment

by:JohnnyD74
ID: 39602107
Hello Clonyxlro,

IIS is running and I did not make any changes since it stopped working. I will try the article...thanks.
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602108
With issues like this, I like to start at https://testconnectivity.microsoft.com/

Most likely a DNS change that is affecting your service, if IE cannot display the page.
Can you access owa internally via http://localservername/owa ?
0
Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

 

Author Comment

by:JohnnyD74
ID: 39602111
Hello and thank you! it is not DNS as I cannot access intenally or even on the server desktop from http://localservername/owa.
0
 

Author Comment

by:JohnnyD74
ID: 39602116
This is what I got from the test tool:

http://screencast.com/t/kUy7JHMuD
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602119
Sorry, what about https://localservername/owa

If that doesnt work, try opening a telnet session to localservername 443
Perhaps a firewall issue?

Failing that, what is the internal url and external url set to?
From EMS, run this command:
get-owavirtualdirectory | fl and verify the internal and external url.
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602120
If the server is listening on 443 internally, then verify that 443 is forwarding on your router/firewall to the internal server.
If it is not responding internally, then it appears as mentioned by @JohnnyD74 that IIS is having some issues.  Restart the World Wide Web Publishing service by running services.msc > World Wide Web Publishing Service > right-click > restart.

Since Autodiscover failed as well, do you have an autodiscover CNAME setup in your registrar's DNS?
0
 

Author Comment

by:JohnnyD74
ID: 39602123
Thanks again :-) Even when I am logged on to the desktop of the exchange server and go to https://localservername/owa , I still cannot access. There are no firewalls running on the server.
0
 

Author Comment

by:JohnnyD74
ID: 39602127
I tried to restart the World Wide Web Publishing service but same problem.
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602128
What about the telnet session?  Does it time out or connect?

Try https://internalipaddress/owa
And also, telnet to the internal IP on 443.

Do any of those respond?
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602132
Could you post a screenshot of your OWA tab in EMC?
Server Configuration > Client Access > Outlook Web App tab.
See attached screenshot.
Screen-Shot-2013-10-25-at-10.53..png
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602148
If you can connect via the IP address internally, then it most definitely is a DNS configuration issue.  What has changed in the environment recently?

Also, are you still getting mail?  Are there more than one server in the environment?
0
 

Author Comment

by:JohnnyD74
ID: 39602150
Hi,

I tried to telnet but got no reponse. Here is a screenshot but I blocked out the addresses for security purposes. http://screencast.com/t/arbSv2rZ
0
 

Author Comment

by:JohnnyD74
ID: 39602153
We have just one exchange server. I cannot connect with the IP internally and am not aware of any changes recently. I am still getting email via Outlook however.
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602169
On the exchange server, can you open a command prompt and do netstat -aon

See if the server is listening on 443.

If it is, then revisit firewall and see if something has been turned on that shouldnt be.
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602171
If it is not, then IIS is not working properly, per @clonyxlro
0
 
LVL 8

Expert Comment

by:TMekeel
ID: 39602173
Secondly, if you ping the server does it respond on IPv4 or IPv6?
0
 
LVL 8

Accepted Solution

by:
piyushranusri earned 500 total points
ID: 39602174
are you trying from IE 7 or 8

please refer this article.
1. http://social.technet.microsoft.com/Forums/exchange/en-US/596c1182-8d15-4a4c-99ec-f9300c53b391/exchange-2010-owa-page-cannot-be-displayed-on-ie7-and-ie8?forum=exchange2010

2. To get the standard OWA login page, open ESM,
Expand Admin group and Servers
Expand your Server_name, Protocols, HTTP.
Right click on HTTP virtual server and go to it's properties, check the box for "Enable FBA" and restart your IIS

3.and another thing i would like to restart Microsoft Exchange Forms-Based Authentication service, MSExchangeFBA for short.

please share the output.
0
 

Author Comment

by:JohnnyD74
ID: 39602176
Yes...it looks like it is listening as shown: http://screencast.com/t/6IzfZeGgo3q

I tested OWA directly on the server so this eliminates the firewall.
0
 
LVL 8

Expert Comment

by:piyushranusri
ID: 39602203
did you restart Microsoft Exchange Forms-Based Authentication  service ?

some how i can not browse http://screencast.com/t/6IzfZeGgo3q (due to IS Policy).

and the best effort i will ask you try that..restart the exchange server. because you are saying nothing is changed and IIS config is also not changed.


please share the output
0
 

Author Closing Comment

by:JohnnyD74
ID: 39602211
Thank you so much! Resetting the exchange virtual directory per your recommended article below did the trick! It works fine now!

http://technet.microsoft.com/en-us/library/ff629372.aspx
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question