File sharing

In our office we have three locations all connected via our VPN router.  Same subnet but different IP address range at each location.

With Windows XP I was able to use file sharing by computer name by opening up the following ports with file sharing in the windows firewall for a desired subnet:

TCP 139
TCP 145
UDP 137
UDP 138

Now using a new / first time Windows 8 computer I find that I can see the other office computer by IP if I type in their name to open shared files it doesn't seem them.  If I open the above ports for all protocols it works.... however I feel that it exposes too much.  I was going to then do the same as I did with XP and only open these ports for file sharing but when I look in Windows 8's firewall there isn't just one file and print sharing setting but rather a half dozen.

How can I set Windows 8's File and Print Sharing as I had in Windows XP?

Thank you.
thandelAsked:
Who is Participating?
 
McKnifeConnect With a Mentor Commented:
About the Firewall: if you create a new rule of the type "predefined", then you'll have the type "file and Printer sharing" and below it many rules with "SMB" included already in the name.

PS:
> Many things I don't understand about the OS... but that is why I have a EE membership  ;)
Hmm... :) although this sheds good light on ee: don't trust forum knowledge too much. There are good pros here, bad pros here and simply "experts" where you sometimes ask yourself "experts...in what?".
In the end, you need to master the task and not ee.
0
 
McKnifeCommented:
Hi

Enable file and printer sharing and network discovery in network and sharing center. That should be all.
0
 
thandelAuthor Commented:
Thank you, both of those options were enabled previously under Public... off in Private.  Do I need to enable it as well in Private?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
McKnifeCommented:
Enable them in the profile you're in. And open port 445 for smb, maybe you forgot that.
0
 
thandelAuthor Commented:
I'm sorry but I am new to Windows 8... how can I tell what profile I'm in and what is SMB?

I am to have this working but only if I enable both Private and Public under advance for each of the above ports.  If I try only Private or only Public doesn't work but if both are enabled then it works.  Am I opening up myself with these ports open in this manner?
0
 
McKnifeCommented:
To be honest: don't mess with these type of settings if you don't know the bare minimum of background information. "What is smb"? - that protocol is what you are trying to use.
To know what network profile you are using, open network and sharing center.

I have to admit that I have no idea why you would need to adjust 2 network profiles while you are staying in one - theoretically this should not be.
Also read: http://en.wikipedia.org/wiki/Server_Message_Block
0
 
thandelAuthor Commented:
I can't "not mess" with this, as I have to get it working and thus my question to EE.  Many things I don't understand about the OS... but that is why I have a EE membership  ;)

I ask as I'm not seeing an SMB setting in the Windows Firewall.
0
 
thandelAuthor Commented:
Understand
0
All Courses

From novice to tech pro — start learning today.