Unable to add server to exchange 2010 DAG

Unable to add server to exchange 2010 DAG
Asked by: HFK-IKTSolved by: Netminder
Hello Experts!

I am about to jump off the roof because of a Exchange 2010 DAG-problem.

I have a 3 fresh installed Windows 2012 Servers with Exchange 2010 SP3.
I am trying to add the first server to my DAG but this operation fails with the following message:

A database availability group administrative operation failed. Error: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: Computer account 'dag' couldn't be validated by user 'NT AUTHORITY\SYSTEM'.

Error: Unknown error (0xc000005e) [Server: DAG1.xxx.xx]
    + CategoryInfo          : InvalidArgument: (:) [Add-DatabaseAvailabilityGroupServer], DagTaskOperationFailedException
    + FullyQualifiedErrorId : 974D64A6,Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityG
   roupServer
    + PSComputerName        : dag1.xxx.xx

I have two network interfaces on the servers and I am not able to see anything wrong with these.

Since Exchange is installed on 2012 servers i have pre-staged the CNO and tried to give both Exchange Trusted Subsystem and the first node (dag1) full access to the object. I also tried to add a DNS-record for the CNO.

I have attached the logfile from Dagtasks.

Hope you can assist me in this annoying problem. :-)

Sincerely

HFK-IKT
dagtask-2013-10-18-07-23-27.003-.log
HFK-IKTAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
lciprianionutConnect With a Mentor Commented:
So according to the logs you have next
The IP addresses for the DAG are (blank means DHCP): 10.54.0.6
Error: The fully qualified domain name for node 'dag' could not be found.
The computer account dag does not exist.

[2013-10-18T07:23:34] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateClusterNameAccount, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 21, szObjectName = dag, dwStatus = 0xc000005e )
[2013-10-18T07:23:34] Found a matching exception: Microsoft.Exchange.Cluster.Replay.DagTaskComputerAccountCouldNotBeValidatedException: A database availability group administrative operation failed. Error: Computer account 'dag' couldn't be validated by user 'NT AUTHORITY\SYSTEM'. Error: Unknown error (0xc000005e)
[2013-10-18T07:23:34] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateClusterNameAccount, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 21, szObjectName = dag, dwStatus = 0xc000005e )
[2013-10-18T07:23:34] Found a matching exception: Microsoft.Exchange.Cluster.Replay.DagTaskComputerAccountCouldNotBeValidatedException: A database availability group administrative operation failed. Error: Computer account 'dag' couldn't be validated by user 'NT AUTHORITY\SYSTEM'. Error: Unknown error (0xc000005e)
[2013-10-18T07:23:34] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseFailureCleanup, ePhaseType = ClusterSetupPhaseStart, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 21, szObjectName = DAG1.xxx.xx, dwStatus = 0x0 )

Check communication between DC and EX server, name resolution also, computer name in AD and CNO of DAG. Try to use static IP on Database Availability Group and not DHCP.
Also check this one: Creating a Windows Server 2012 Failover Cluster Fails with Error 0xc000005e
0
 
HFK-IKTAuthor Commented:
Opening port 464 to the DC's did it. Thanks alot! :)

HFK-IKT
0
All Courses

From novice to tech pro — start learning today.