Solved

Save Dialog does not come up

Posted on 2013-10-27
4
443 Views
Last Modified: 2013-11-03
I have been having a reoccurring issue with my Windows 7 64-bit desktop.
My comptuer is on 24x7 and often says on with out rebooting for weeks.
Dozens of times, the "save" dialog just stops working.
Outlook attachments, word, excel, internet explorer (right click, save), firefox (right click saving pictures) - when I hit the save or save as button on an unsaved document (word and excel) - the save dialog does not come up.

I can open my computer and windows explorer.

Reboot fixes it - and i have been living with it until tonight. Had 5 unsaved word documents open. Usually i just end task on word, reboot and the auto recovery picks them all up and i save them. This time it lost all 5 and i could not recover them.

I have tried rebooting office apps, going to taxk manager and ending "explorer.exe" and restarting it - but that does not help.

Any ideas?
0
Comment
Question by:stephen15c
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 92

Expert Comment

by:nobus
ID: 39604939
i would start by running sfc - or a repair :
http://www.sevenforums.com/tutorials/681-startup-repair.html            REPAIR
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html         SFC

other than that - you can also do a repair of the OFFICE
0
 
LVL 1

Author Comment

by:stephen15c
ID: 39606868
Done both.
Problem is not just with office.
Happens with IE, Firefox and other programs that pop up a save dialog box.
0
 
LVL 14

Assisted Solution

by:Rob Miners
Rob Miners earned 250 total points
ID: 39607057
If a reboot normally fixes it, you could try restating your PC a bit more regularly, as it's a good way to clear RAM (Memory) and stop any Services, Processes, that may not have terminated properly after being started by you or the System.

I would also suggest cleaning up Temporary files.

http://windows.microsoft.com/en-au/windows/delete-files-using-disk-cleanup#delete-files-using-disk-cleanup=windows-7

Optimize Windows 7 for better performance

http://windows.microsoft.com/en-AU/windows7/Optimize-Windows-7-for-better-performance

FYI:

I leave my systems running 24/7 but, every night I have an automated disk cleanup and auto restart using a batch file. I've been running my systems like this for years without any problems.

@echo off
rem run sageset once to create the registry environment, choose your settings and then rem it out. Once you have your settings remove the rem from the rest of the commands and rerun the Batch file.

%SystemRoot%\System32\Cmd.exe /c Cleanmgr /sageset:65535

rem %SystemRoot%\System32\Cmd.exe /c Cleanmgr /sagerun:65535
rem goto Shut
rem :shut
rem shutdown /r /c "Scheduled Reboot Normal Mode." /f /d P:4:1


The catch:

By default,temporary files are stored for 7 days and the default setting for LastAccess is 7 so this number needs to be changed to either 1 day or 0 for no days, otherwise you will not be able to delete most of the temp files. I've been running it with 0 zero days without any problems.

In order to delete all files you can right click and modify this registry key.

eXample:

Click Start, type regedt32 in the Start Search box, and then press Enter.
Click OK or Yes to the UAC prompt.

Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\VolumeCaches\Temporary Files

LastAccess REG_DWORD 0

Or you can run this commandline:

Click the Start button.
In the Start Search box, type in cmd
Right click on the Command Prompt in the search results and select Run as Administrator.
Click OK or Yes to the UAC prompt.

reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\VolumeCaches\Temporary Files" /v LastAccess /t REG_DWORD /d 0 /f

-=eol=-
0
 
LVL 92

Accepted Solution

by:
nobus earned 250 total points
ID: 39607957
another way is running msconfig - to disable startup programs and services
Programs : in startup tab - click disable all
Services : in services tab, click "hide MS services" now click disable all
reboot to test; and if it is better - re-enable the programs or services in groups

also - if you know when this started, a system restore can help you out
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So many times I have seen the words written in a question "if only I could show you" or " I know how hard it is for you since you can't see it" in any zone. That has inspired me to write about this tool in windows 7 called "Problem Steps Recorder…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question