Solved

InfoPath 2010 Repeating Table - Webservice

Posted on 2013-10-28
7
605 Views
Last Modified: 2014-01-15
Hi!

I am retrieving data through a web service into my browser based infopath form.  The connection is good and data is pulling in but not all rows.

How do I get all rows to display in the table?
0
Comment
Question by:Annette Wilson, MSIS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 28

Expert Comment

by:clayfox
ID: 39605341
How many rows do you get compared to what you think you should get.
by default you get all rows that match your query. The more common problem is getting all rows when you want less
also some web services have a set count that will limit what is returned.
0
 

Author Comment

by:Annette Wilson, MSIS
ID: 39605838
Thank you for responding clayfox.  I only get one row back.  The first row.
0
 
LVL 28

Expert Comment

by:clayfox
ID: 39605856
So you go through the receive data connection wizard?

some times there are multiple methods such as read and read multiple.

what kind of web service is it?

is the control a repeating table or section?
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 

Author Comment

by:Annette Wilson, MSIS
ID: 39605986
When I go through the receive data connection wizard,  there are no options to retrieve multiple.

It's a SOAP service

I have a repeating table

It looks like only the last row of the data is being displayed.
0
 
LVL 28

Accepted Solution

by:
clayfox earned 500 total points
ID: 39605997
Are you confident that the web service works?

Do you have a way to verify it?

You do not have any formatting on the repeating table that would filter anything?

Do you have query parameters or does it return all values?
0
 

Assisted Solution

by:Annette Wilson, MSIS
Annette Wilson, MSIS earned 0 total points
ID: 39610096
I see what the problem is.  My webservice code was only calling for one row.  I will correct this.
0
 

Author Closing Comment

by:Annette Wilson, MSIS
ID: 39781808
I saw that through using the main data set that I could only retrieve one row.  When I Use the secondary datasource  and added a repeating table from the secondary datasource, I was able to return all rows.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I used to be SharePoint evangelist in our company, so my Outlook always full of questions about how to do this, or where I can find that. One day I found such an email with the following question: "how to attach 3-State workflow (one of the workflow…
Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question