Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

VoIP issue - no audio

Posted on 2013-10-28
4
Medium Priority
?
837 Views
Last Modified: 2014-02-01
Hello,

We are attempting to setup 3 sites with a Panasonic TDE100 PBX and Panasonic IP phones.

There are 3 locations, all with static public IPs:
Site A
Site B
Site C

Site A is where the PBX is hosted. PBX is configured with an internal IP (192.168.1.x subnet). PBX is natted to an available IP at Site A for all network traffic (for example, let's say 10.1.1.1) .

Before any Cisco firewalls were implemented, the PBX sat with a public IP configured on it directly (10.1.1.1), and all 3 sites were able to make calls just fine. The issues began when we implemented Cisco firewalls, internal IPs, and started natting stuff.

Site A -> Site B is connected via an IPSec tunnel with Cisco ASA5505's on each end.

Phones at Site B have a 192.168.2.x subnet, and can see the PBX at Site A (via the 192.168.1.x IP over the tunnel) and calls work just fine, both internal extensions and outbound (xxx-xxx-xxxx numbers).

Site C does not have an ASA5505 (international location, ASA not possible at this time). However, the IP phones (same model as Site A and B) have public IP's configured directly on them. Phones at Site C try to connect to PBX at 10.1.1.1 since no VPN tunnel exists.

This setup worked fine before the Cisco's were installed. However, now, Site C phones get dial tone, but once a call is made, there is no audio both ways. Inbound and outbound calls same issue.

Cisco TAC attempted to work on packet capture, and sees all MGCP traffic passing through the ASA to 192.168.1.x PBX IP just fine.

Any ideas?
0
Comment
Question by:Spej
  • 3
4 Comments
 
LVL 15

Accepted Solution

by:
Phonebuff earned 2000 total points
ID: 39607378
You now have NAT Traversal in the picture when you are not going through the VPN..

Both the Phones & The IPBX need to be NAT Aware for this to work.

Google MGCP and NAT
==========
0
 
LVL 1

Author Comment

by:Spej
ID: 39609278
Thanks for pointing me in the right direction.

So it is to my understanding that the internal IP of the PBX in the SIP message is still "192.168.1.x" because the NAT on the ASA can't change that. So the phones at Site C reply back to the IP in the SIP message, which is "192.168.1.x" and it gets dropped once it reaches the WAN interface of the ASA at Site A.

The PBX has NAT Traversal as OFF. I will change that to FIXED IP.

Also, some documentation shows that we require a STUN server to change the IPs in the SIP messages, so that the SIP message sends out the IP of the WAN side of the ASA instead of the local IP of the PBX. Am I following all this correctly?
0
 
LVL 15

Expert Comment

by:Phonebuff
ID: 39610230
Yes,  To a Point -- In most IPBXs you set NAT to Yes, but also need to define the "External" (Public Facing IP) and internal (Local) IP Subnets, then since you have a mix you need to set NAT YES/NO on each device.  

I have no idea how you might do this on your Panasonic as I have not worked on any IP aware Panasonic PBXs to date.
0
 
LVL 15

Expert Comment

by:Phonebuff
ID: 39610233
PS: To use a STUN server the device has be enabled for that type connection.
0

Featured Post

[Video] Oticon Case Study

Open office environments can create the dynamics for innovation, but they also bring some challenges. With over 1,000 employees in an open office, Oticon needed a solution that would preserve the environment while mitigating disruptive background noises.

Watch how they did it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Almost all Internet protocol telephones have built-in switches at the back that allow you to connect your personal computer to one port and use the other port to connect your phone to to a Cisco switch.   Why we need to connect the PC to the pho…
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question