Solved

Cisco Switching from Layer 2 to Layer 3

Posted on 2013-10-28
4
448 Views
Last Modified: 2013-10-29
Hi,
I'm new to layer 3 switching and want to see if I can get some help. Currently I have no vlans, and everything works. However I would like to do the below configuration and have vlan 10 and vlan 20 talk to each other. Can someone guide me on what I need to do on switch l2 (layer 2) and l3 (layer 3)? I'm assuming the layer 3 switch will do the routing, but I don't know how the uplink plays into the vlans and how to configure the Layer 3 switch. Switch L2 is a layer 2 switch and Switch L3 is a layer 3 switch. Can someone please help me understand how to configure this scenario?


Switch L2

Port 10 / 192.168.1.4 - Client PC - vlan10 - I know how to make this a vlan
ip address: 192.168.1.4
subnet address: 255.255.255.0
gateway: 192.168.0.???? - What do I do here, put the internet gw 192.168.0.1

Port 20 / 192.168.2.2 - Client PC - vlan20 - I know how to make this a vlan
ip address: 192.168.1.4
subnet address: 255.255.255.0
gateway: 192.168.0.???? - What do I do here, put the internet gw 192.168.0.1

Switch L3

Port 1 / 192.168.0.1 - Internet - I don't know what to do here either.

1 Uplink from Switch L2 port 32 to Switch L3 port 33. - I don't know how to carry all the vlan traffic from switch l2 to the layer 3 switch.
0
Comment
Question by:jasonmohan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 18

Expert Comment

by:fgasimzade
ID: 39607946
Ok, you would need to create 2 interface vlan on L3, one for each vlan

For example

conf t
interface vlan 10
ip address 192.168.1.10 255.255.255.0

interface vlan 20
ip address 192.168.2.20 255.255.255.0

These IP addresses will be a default gateway for your vlans respectively.

After you configured this, you need to configure a static route for internet connection.

Most probably it is going to be

ip route 0.0.0.0 0.0.0.0 192.168.0.1 where X is your interner router/modem

What is your connection from L3 to Internet gateway?
0
 

Author Comment

by:jasonmohan
ID: 39608455
I have a Cisco ASA at 192.168.0.1 uplinked on port 1 of the Layer 3 switch, and port 1 on the Cisco ASA switch.

What do I need to do on the uplink port from layer 2 to layer 3 switch? I read some stuff regarding trunking but wasn't sure if I needed to add that, and how.
0
 
LVL 18

Accepted Solution

by:
fgasimzade earned 500 total points
ID: 39608476
You need to create vlans on both L2 and L3 switches and configure uplink ports between them in this manner:

conf t
interface fastethernet x/x
switchport trunk encap dot1q
switchport mode trunk

Then make sure you can ping interface VLANs' ip addresses from your PCs connected to L2 switch

When it comes to Internet, I would suggest configuring a new VLAN for communication between L3 and ASA

interface vlan 30
ip address 192.168.0.2 255.255.255.0

Then configure a port on L3 connected to ASA with vlan 30

Make sure you can ping from L3 to ASA 192.168.0.1

Dont forget about

ip route 0.0.0.0 0.0.0.0 192.168.0.1
0
 

Author Closing Comment

by:jasonmohan
ID: 39608626
Thanks for the help, and taking the time to explain.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Set up secondary Domain Controller 4 113
logon time 6 59
Cisco router 4400 and switch connection. 27 82
Failover for DMVPN 3 59
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question