Solved

How do I increase the max file uploaded on a SBS 2008 Sharepoint install?

Posted on 2013-10-28
12
528 Views
Last Modified: 2013-11-02
I have a standard SBS 2008 install with SharePoint services 3 SP3 installed. I have changed the max file upload size in the SharePoint configuration to the 2.5G max but it still won't take anything larger that 28M. Help!!
0
Comment
Question by:safeharbor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
12 Comments
 
LVL 3

Expert Comment

by:ltechsolutions
ID: 39607559
0
 

Author Comment

by:safeharbor
ID: 39607568
Found this and tried it already. No Luck. I found a note on a knowledge base article as follows:

On a Windows Server 2008 computer that has only IIS 7.0 installations, you can add the maxAllowedContentLength value to resolve the issue that is described in the "Symptoms" section. However, you cannot upload files that are larger than 28 MB, even though you have configured the large file upload setting when you are running Windows SharePoint Services on a Windows Server 2008 based computer that has IIS 7.0 installed.

This is the wall I am hitting, 28MB, if anyone knows how to get around this, it would be great.
0
 
LVL 3

Expert Comment

by:ltechsolutions
ID: 39607576
I'm not sure if this is helpful, but this person appears to have resolved the issue by using the IIS 7.0 Adminstration pack:

http://social.technet.microsoft.com/Forums/en-US/4c3777da-6097-467d-998d-b77a195efa3e/files-over-28mb-server-2008
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 4

Expert Comment

by:ShareD_Point
ID: 39607582
Hi,
When you are running WSS 3.0 on a Windows Server 2008 based computers which has IIS 7.0, you will find that you cannot upload files that are larger than 28 MB even though you have configured the large file upload settings already.

To work around this problem, edit the <configuration> section in the Web.config file for the web application. To do this, follow these steps:

Open the web application Web.config file in Notepad.
Note By default, this file is in the following folder:
    Inetpub\wwwroot\wss\VirtualDirectories\VirtualDirectoryFolder
Increase the value of maxAllowedContentLength in the requestLimits node. For example, edit the file as follows to set this value to its maximum size:
    <requestLimits maxAllowedContentLength="52428800"/>
Note If your Web.config file does not already have the <requestLimits> node, you must add it in the correct position in the section hierarchy:

    <configuration>
     <system.webServer>
      <security>
       <requestFiltering>
         <requestLimits maxAllowedContentLength="52428800"/>
       </requestFiltering>
      </security>
     </system.webServer>
    </configuration>

Ref Link:
http://support.microsoft.com/kb/925083

Hope this helps.
0
 

Author Comment

by:safeharbor
ID: 39607586
This was done as well. No dice.
0
 
LVL 4

Expert Comment

by:ShareD_Point
ID: 39607595
You may need to check whether your Anti Virus SW blocking the upload.
0
 
LVL 4

Expert Comment

by:ShareD_Point
ID: 39607598
What is the error you are getting?
0
 

Author Comment

by:safeharbor
ID: 39607605
Nope. checked that too. AVG says its all or nothing. Any files uploaded over 28MB just don't show up. process looks to complete but doesn't list the upload.
0
 

Author Comment

by:safeharbor
ID: 39607608
Have to go look at the logs because it doesn't display an error to the user via sharepoint
0
 
LVL 4

Expert Comment

by:ShareD_Point
ID: 39607611
Increase the connection timeout setting in IIS and try.
0
 

Accepted Solution

by:
safeharbor earned 0 total points
ID: 39607629
I solved the issue by installing the IIS 7 Administration Pack then using the included tools to edit the request filtering via the Configuration Editor under the Management section. I increased the limits there reset IIS and it worked.

Thx  ltechsolutions for the link. This is a problem that looks like it has stumped a few people via google and this is the first fix I found to work. Thanks again
0
 

Author Closing Comment

by:safeharbor
ID: 39618578
This worked right off. Without errors and took 10 minutes to install and test.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question