Solved

WSP not activating

Posted on 2013-10-29
6
187 Views
Last Modified: 2013-11-14
I have a sample site template (.wsp) that a vid course I'm taking gives me. It says to upload it to the solutions gallery. It uploads. I press activate from the solutions gallery form and it "seems" to activate and it shows as activated in the Solutions library. I go to use this site template to create a new site, and the template shows up on the list. When I select it and try to create it, it tells me that it has to be activated at the site collection level. I check the site collection features to manually activate it, and it is nowhere to be found. I'm guessing this is a sandboxed solution. I checked to see if the sandbox solutions service is running in Central admin. It is. It is also shown as started in my windows services. I may have uploaded this same solution a while back, but I don't think I did but I can't be sure. But I never saw any trace of it before I just uploaded it.

Does anybody know what could cause this odd behavior? If I did upload it in the past and deleted it, would that cause a problem like this?
0
Comment
Question by:BobHavertyComh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 1

Expert Comment

by:jeanf88
ID: 39611767
Does it tell you that you have to activate a certain feature and then it give you a guid ? If it's the case you will need to activate the missing feature that the template required. The guid will tell you which feature need to be activated.

Can you copy the error message you are getting ?
0
 
LVL 9

Author Comment

by:BobHavertyComh
ID: 39648618
Hi Jean, yes it does, but the feature shows up as activated in the features list and it shows up in the site template list when I go to create a new site using that template.
0
 
LVL 1

Expert Comment

by:jeanf88
ID: 39648647
When you create a site template (wsp) or take one from somewhere and bring it to another farm you need to activate the site collection features that the site template need before you can create them. If it's the case, when you create the site the error message should give you a guid that will help you to identify which feature you need to activate.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 9

Author Comment

by:BobHavertyComh
ID: 39648818
So do I have to go through all of the feature folders in the 14 root and open their Feature.xml to look for this guid?
0
 
LVL 1

Accepted Solution

by:
jeanf88 earned 500 total points
ID: 39648840
when you create the site did you get a guid ? All the sharepoint feature guid is listed here,

http://blogs.msdn.com/b/mcsnoiwb/archive/2010/01/07/features-and-their-guid-s-in-sp2010.aspx
0
 
LVL 9

Author Closing Comment

by:BobHavertyComh
ID: 39649525
Yes, I did say that I got a guid as part of the ERROR message before, so I don't know why you asked me whether I got a guid when I created the site because I was never able to create the site, and got an error message with a guid instead. But I think you are correct and I appreciate the feature guid reference and I assume this is the correct answer. Thank you.
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Summary In SharePoint 2010 it is easy to create custom color themes to jazz up a site. Theme colors can also be created in PowerPoint 2010 with a few clicks. But how do the chosen colors actually look in the SharePoint site? The attached PowerPoint…
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question