website ASP pages Server 2008 R2

I'm trying to move my companies website which currently sits on a Windows 2000 Server to a virtual server on my Server 2008 R2 machine.  I've moved everything over and then browsed the home page to find that my top header of the home page doesn't show up and the header is a .asp page.  We're running IIS 7.0 and the service of ASP is running.  What am I doing wrong?
RCL_BurcoAsked:
Who is Participating?
 
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
I think what SterlingMcClung is referring to is  parent path's are turned off.  The reason is for security.  If you have include files, instead of using

<!--#include file="../folder/file.asp"-->

change to

<!--#include virtual="/folder/file.asp"-->

http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-parent-paths-are-disabled-by-default
0
 
Dave BaldwinFixer of ProblemsCommented:
That's a little vague.  Is the 'top header' in an 'include' statement or something else?  Have you double checked the path?

And while ASP.NET 'automatically' runs in IIS 7, Classic ASP does not and has to be installed.

http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8
0
 
SterlingMcClungCommented:
In addition, I believe that IIS 7.0 disables "..\..\" style includes in the asp files.  There is an option under the ASP section o IIS to enable this, but I don't recall its exact title at this point.  This was enabled by default in previous versions, so if you use it, you will need to enable it.
0
 
SterlingMcClungCommented:
That would be the term I was looking for.  You are right, that it was for security purposes and I should have mentioned that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.