Solved

EMC "selector value" error - Exchange 2010 on SBS 2011

Posted on 2013-10-30
4
2,093 Views
Last Modified: 2014-02-22
Configuration: SBS 2011 Standard running Exchange 2010 with all MS updates installed.

Until recently I could open Exchange Management Console (EMC) when logged in as Domain\Administrator and everything was fine.

Currently I get the message:-

Starting a command on remote server failed with the following error message : The Windows Remote Shell cannot process the request; the selector value <SID> specified in the request was not found.

Searching on the web suggests that this is a problem with Windows Remote Management but I have:-
a) winrm quickconfig   - this returns no problems
b) checked the kerberos settings in default web site - powershell - modules and that's also fine
c) read this http://www.arconi.com/index.php/blog/item/exchange-2010-sp1-or-sp2-trouble-with-the-virtual-directory-powershell-already-exists and discovered that in IIS - default web site I have a virtual folder called PowerShell and one called PowerShell-Proxy . I don't know why I have the Proxy or whether it should even be there!

I've looked at the various event logs and I get a:-

MSExchangePowerShellAppPool exceeded time limites event ID 5013 but don't know if this is related.

The reason I discovered the EMC issue was because I need to renew a SSL certificate that expires in 4 days and I keep getting the "command on remote server failed" message.
0
Comment
Question by:MarcusN
  • 3
4 Comments
 
LVL 11

Expert Comment

by:Sanjay Santoki
Comment Utility
Hello,

Please make sure IPv6 is enabled which is required as per Microsoft even though it is not used in your network.

Also, You can try reinsalling WinRM.

Regards,
Sanjay Santoki
0
 

Author Comment

by:MarcusN
Comment Utility
IPv6 is enabled.

How do I reinstall WinRM? It's not in "control panel - programmes".

There is a folder %systemroot%\system32\winrm\0409 containing 1 file winrm.ini
0
 

Accepted Solution

by:
MarcusN earned 0 total points
Comment Utility
OK, after a lot of searching I have fixed this myself. This article was a great help;

http://blogs.technet.com/b/jonjor/archive/2009/01/09/winrm-windows-remote-management-troubleshooting.aspx

So, this is the solution.
1) Open "Windows Firewall with Advanced Security"
2) Select "Inbound Rules"
3) Find the rule "Windows Remote Management - Compatibility Mode (HTTP-In)" and enable it.

Problem solved.

There's probably another way to do this that involves the default port 5985 somewhere in the Exchange Console settings, but I couldn't find it; probably something to do with "Tools - Remote Connectivity Analyzer" but I couldn't find any way to sort that out.
0
 

Author Closing Comment

by:MarcusN
Comment Utility
I had no real help and it took me a long time to track down the source of the problem which I have now tested and applied. I can say it fixes the problem completely.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Easy CSR creation in Exchange 2007,2010 and 2013
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video discusses moving either the default database or any database to a new volume.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now