Solved

Every other page printing blank using Tablix

Posted on 2013-10-30
5
408 Views
Last Modified: 2013-11-09
I have had a problem with the Tablix printing ever since I have been using them.  Currently I am using 2008 R2.

My problem is that no matter how narrow I make my Tablix, including it only expanding to a width the fraction of the printed page size, if there is more than one page of information, I always get a blank page, every other page throughout the report.

I never thought to post the question but it happens so often, and I'm so frustrated with it, I decided it was time to ask.

Thank you for any help you can give on this.
0
Comment
Question by:CalBob
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 65

Expert Comment

by:Jim Horn
ID: 39611961
<wild guesses>
If your tablix includes groups where the desginer creates columns to the left of a dashed vertical bar, then delete those columns.
Add up the left margin, right margin, and width of the report, and make sure it does not go beyond the page width
0
 

Author Comment

by:CalBob
ID: 39612296
There is a column left of the dashed vertical bar, but it is not a group. I don't see any problem with that.  And the tablix has plenty more room to expand on the printed page.  :(

Any other ideas from anyone?
0
 
LVL 16

Expert Comment

by:DcpKing
ID: 39618283
Down at the bottom, below the design area, there are a pai of areas with orange ribbons representing the groups. Investigate the properties of the groups to make sure that you don't have a group that has "page break at end of group" or something similar set on. You can right-click the groups there and also left-click them and look at their properties page. The two ways don't always show the same info.

Also check out the properties of your pages, in case you've done something like added a pagebreak to a footer and then always used that standard footer ...


hth

Mike
0
 

Accepted Solution

by:
CalBob earned 0 total points
ID: 39622020
I found the problem on some of the reports I looked at to be the Report property setting ConsumeContainerWhitespace.  This should be set to True.  The default is False.

I did some research on the internet and found this to be a problem for others as well.  Having said that it did not solve the problem on all of my Tablix reports where I am having a problem, but it did work for some of them, including the one I was working on.

Thanks for you input.
0
 

Author Closing Comment

by:CalBob
ID: 39635442
This resolved the problem for the tablix report I was working on.  As I note in the response, it did not work for every report, but it does for some.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Everyone has problem when going to load data into Data warehouse (EDW). They all need to confirm that data quality is good but they don't no how to proceed. Microsoft has provided new task within SSIS 2008 called "Data Profiler Task". It solve th…
I have a large data set and a SSIS package. How can I load this file in multi threading?
Using examples as well as descriptions, and references to Books Online, show the different Recovery Models available in SQL Server and explain, as well as show how full, differential and transaction log backups are performed
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question