Solved

Why is my ASA 5505 upload speed so slow?

Posted on 2013-10-30
7
2,475 Views
Last Modified: 2013-11-25
I got new 100Mb up/down service today from my internet provider. Downloads clock in from any number of speedtests at 90+ Mb, so Im thrilled with that.

When I do the upload test though my speeds are WAY below acceptable - 15 Mbs or so.

Looking at ADSM CPU and memory do not look to be being taxed (10% CPU and 67% free memory)

What should I be looking for here?

If we do the speed tests with the ASA out of the equation I get the 100/100 speeds Im paying for.

ASA Version 8.2(5) 
!
hostname myhost
domain-name mydomain.com

names
name 192.168.19.0 My-CO-Home
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6

!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.19.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.220 255.255.255.0 
!
ftp mode passive
clock timezone MST -7
clock summer-time MDT recurring
dns server-group DefaultDNS
 domain-name mydomain.com
same-security-traffic permit intra-interface
object-group network HQ_Sites
 network-object 192.168.0.0 255.255.252.0
 network-object 192.168.250.0 255.255.255.0
 network-object 192.168.254.0 255.255.255.0
 network-object 10.1.8.0 255.255.255.0

object-group network ExtSites
 description All the External Sites within the extended network
 network-object 192.168.11.0 255.255.255.0
 network-object 192.168.12.0 255.255.255.0
 network-object 192.168.13.0 255.255.255.0
 network-object 192.168.14.0 255.255.255.0
 network-object 192.168.15.0 255.255.255.0
 network-object 192.168.16.0 255.255.255.0
 network-object 192.168.17.0 255.255.255.0
 network-object 192.168.85.0 255.255.255.0
 network-object 192.168.80.0 255.255.255.0
 network-object 192.168.90.0 255.255.255.0
 network-object 192.168.95.0 255.255.255.0
 network-object 192.168.100.0 255.255.255.0
 network-object 192.168.120.0 255.255.255.0
 network-object 192.168.160.0 255.255.255.0
 network-object 192.168.170.0 255.255.255.0
 network-object 192.168.180.0 255.255.255.0
 network-object 192.168.190.0 255.255.255.0
 network-object 192.168.30.0 255.255.255.0
 network-object 192.168.40.0 255.255.255.0
 network-object 192.168.18.0 255.255.255.0
object-group network DM_INLINE_NETWORK_1
 group-object ExtSites
 group-object HQ_Sites
access-list outside_1_cryptomap extended permit ip My-CO-Home 255.255.255.0 object-group DM_INLINE_NETWORK_1 
access-list inside_nat0_outbound extended permit ip My-CO-Home 255.255.255.0 object-group DM_INLINE_NETWORK_1 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 

aaa authentication telnet console LOCAL 
http server enable
http My-CO-Home 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group5
crypto map outside_map 1 set peer x.x.x.194 
crypto map outside_map 1 set transform-set ESP-AES-256-SHA
crypto map outside_map interface outside
crypto isakmp enable outside

crypto isakmp policy 1
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
crypto isakmp nat-traversal 3600
telnet My-CO-Home 255.255.255.0 inside
telnet timeout 5
ssh My-CO-Home 255.255.255.0 inside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.19.200-192.168.19.230 inside
dhcpd dns 192.168.0.41 interface inside
dhcpd lease 259200 interface inside

dhcpd domain mydomain.com interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn

tunnel-group x.x.x.194 type ipsec-l2l
tunnel-group x.x.x.194 ipsec-attributes
 pre-shared-key *****
!
!
smtp-server x.x.x.x
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:a15952be8d76136861b2733e83cd7b75



My-co-5505# sh ver

Cisco Adaptive Security Appliance Software Version 8.2(5) 
Device Manager Version 6.4(5)

Compiled on Fri 20-May-11 16:00 by builders
System image file is "disk0:/asa825-k8.bin"
Config file at boot was "startup-config"

My-co-5505 up 23 mins 28 secs

Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
Internal ATA Compact Flash, 128MB
BIOS Flash Firmware Hub @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-5505 on-board accelerator (revision 0x0)
                             Boot microcode   : CN1000-MC-BOOT-2.00 
                             SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
                             IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.05

 0: Int: Internal-Data0/0    : address is 7cad.7424.1e30, irq 11
 1: Ext: Ethernet0/0         : address is 7cad.7424.1e28, irq 255
 2: Ext: Ethernet0/1         : address is 7cad.7424.1e29, irq 255
 3: Ext: Ethernet0/2         : address is 7cad.7424.1e2a, irq 255
 4: Ext: Ethernet0/3         : address is 7cad.7424.1e2b, irq 255
 5: Ext: Ethernet0/4         : address is 7cad.7424.1e2c, irq 255
 6: Ext: Ethernet0/5         : address is 7cad.7424.1e2d, irq 255
 7: Ext: Ethernet0/6         : address is 7cad.7424.1e2e, irq 255
 8: Ext: Ethernet0/7         : address is 7cad.7424.1e2f, irq 255
 9: Int: Internal-Data0/1    : address is 0000.0003.0002, irq 255
10: Int: Not used            : irq 255
11: Int: Not used            : irq 255

Licensed features for this platform:
Maximum Physical Interfaces    : 8         
VLANs                          : 3, DMZ Restricted
Inside Hosts                   : 50        
Failover                       : Disabled
VPN-DES                        : Enabled   
VPN-3DES-AES                   : Enabled   
SSL VPN Peers                  : 2         
Total VPN Peers                : 10        
Dual ISPs                      : Disabled  
VLAN Trunk Ports               : 0         
Shared License                 : Disabled
AnyConnect for Mobile          : Disabled  
AnyConnect for Cisco VPN Phone : Disabled  
AnyConnect Essentials          : Disabled  
Advanced Endpoint Assessment   : Disabled  
UC Phone Proxy Sessions        : 2         

Total UC Proxy Sessions        : 2         
Botnet Traffic Filter          : Disabled  

This platform has a Base license.

Serial Number: xxxxxxxxx
Running Activation Key: xxxxxx
Configuration register is 0x1
Configuration has not been modified since last system restart.

Open in new window

0
Comment
Question by:Eric_Price
  • 4
  • 3
7 Comments
 
LVL 17

Assisted Solution

by:Garry-G
Garry-G earned 500 total points
Comment Utility
Maybe something completely simple ... check if your speed/duplex settings on the interfaces are right ... if either side doesn't correctly do auto negotiation, you'll end up with 100 half duplex which will slow you down severely. In that case, set your interfaces to static 100/full to fix ...
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
Speed is listed at 100 with full duplex, though it is set to Auto. Setting it to manual 100 / Full killed my connection and I had to have the local guy reset the ASA.

As an additional point of info, with the PC plugged directly in the ASA (and nothing else plugged in) I got to 66 Mbs

When I route the PC through the Cisco phone uploads drop to below 30 Mbs.

This Cisco phone is not on its own VLAN like it would be in a regular environment, and it is registering to our  main Cisco phone system via the VPN tunnel that gets established.
0
 
LVL 17

Assisted Solution

by:Garry-G
Garry-G earned 500 total points
Comment Utility
Hm ... new information there ... I don't know which phone you use, and do not have experience as to how well they operate as a switch, but you could try to hook up a second PC e.g. to another of the ASA's internal ports, than use a tool like jperf/iperf to see whether there's a general problem with throughput there... I assume you're using a PoE port of the firewall to supply it with power, so hooking up a PC on either side of the phone will most likely not work?
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
Its a 9971. Seems to be the case at all the locations - just more noticeable than here.

It is a POE port.

Removing the phone from the scenario sees upload speeds return to "normal".

Im going to open a TAC case I guess.
0
 
LVL 17

Accepted Solution

by:
Garry-G earned 500 total points
Comment Utility
So, in essence:

...[Internet]---ASA----Phone----PC

results in slow uploads, while

...[Internet]---ASA---PC

results in expected speeds?

With its 1G-capable Ethernet ports, I assume it ought to deliver enough performance to saturate your internet link. My money is on speed/duplex mismatch caused by either fixed settings somewhere, or failure to automatically recognize the connected devices' settings uniformly ...

Do you have a status page or something on the phone where you can see what the two Ethernet ports are running at? Then compare what the ASA port and the PC's port say they are running at ... If there's a "half duplex" anywhere, you have your culprit ...
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
That is correct, and your assumption makes sense. If its a wrong setting its a wrong setting on both of the PCs at that location, as the problem is identical on both, and the scenario is the same.  To me, that reduces the likelihood that a setting is wrong.  I'll see about getting some output on status today in case Im overlooking something obvious. I've never done that on a cisco phone before though, so Ill need to exercise a little google-foo I suppose.

The line in question is a 100Mbs/100Mbs line of site service.  Stay tuned.
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
FYI I confirmed this phenomenon on another site.

With phone

20 down 13.2 up

without phone

20 down, 36 up
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

This is about downgrading PIX Version 8.0(4) & ASDM 6.1(5) to PIX 7.2(4) and ASDM 5.2(4) but with only 64MB RAM and 16MB flash. Background: You have a Cisco Pix 515E which was running on PIX 7.2(4) and its supporting ASDM 5.2(4) without any i…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now