Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 379
  • Last Modified:

User homeDirectory share permissions

We have a Win2K8 file server with drive D:

On drive D, there's a folder called students, shared as students$.

Using a separate script, I'm populating the AD atttributes for homeDrive and homeDirectory so users get mapped to J:\\server\students$\username

It works fine on Windows 7, but with Windows XP the users are shown the root of the students folder when clicking on "J" drive. They see every other student's home folder AND can delete them.

What are the correct share and NTFS permissions/settings that should be applied at the root of the share (students)? And what permissions/settings should be applied to the individual home folders?

Thanks in advance.
0
Dallas Smetter
Asked:
Dallas Smetter
2 Solutions
 
pony10usCommented:
Microsoft has a KB that may be of assistance:  http://support.microsoft.com/kb/969006

Do you have the mapping as J:\\server\students$\%username% (notice the percent signs)
0
 
comfortjeaniusCommented:
If you using active directory you can configure on the Profile tab  ----> Home Folder ----> Select the Connect Radio button ----> drop down select J ----> To: \\server\students$\username.  Every time they authenticate to the workstation it will automatically connect to their user folder.


Click on the Security tab ----> Click Advanced ----> Uncheck " Allow inheritable permissions from the parent......"  Now click Add..  Add full control to the Administrator and the specified user account. Click "Apply or Ok".

Plus on right-click the folder and click the Sharing tab ------> Select "Share this Folder" radio button.  Enter a Share name ie. username.  Now click on "Permission" button. Make sure the domain admin and specified user account have Full Control.  Click "Apply or Ok".

I hope this helps.
0
 
Dallas SmetterSolution EngineerAuthor Commented:
My script does not (and cannot for other reasons) set it using the %username% variable. Will try the suggestions and post back...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now