Solved

JackBe multiple tables with tabs in IE10

Posted on 2013-10-31
21
425 Views
Last Modified: 2013-11-05
Hi Experts,

We have been using JackBe multiple tables(sortable column) with tabs for a few years and it doesn't work anymore in IE10. It still works ok in FF.

There seems to be some problems in gs_4.js file

var ie_ver=5.5,
    nav=navigator.appName,
    ver=navigator.userAgent,
    accept='',
    sfr=ver.indexOf('Safari');

if(nav=='Microsoft Internet Explorer'){
	var a=ver.substr(ver.indexOf('MSIE'),ver.substr(ver.indexOf('MSIE')).indexOf(';')),
	app_ver=parseFloat(a.substr(a.indexOf(' ')));
	if(app_ver>=ie_ver){
		accept='ie';
	}
}
else if(sfr>-1){
	accept='sf';
}
else{
	accept='ff';
}

if(accept!=''){
	JkB={LCL:navigator[(accept=='ie'?'userL':'l')+'anguage']};
	JkB.namespace=function(a,b){
		var c=b?b:window,
			d=a.split('.'),
			i;
		for(i=0;i<d.length;i++){
			if(!c[d[i]]){
				c[d[i]]={};
				c=c[d[i]];
		    }
		}
		return c;
     };
}
Gcs=EHRCONTEXT+"/jackbe/css/";
Gfb=EHRCONTEXT+"/jackbe/fb/";
Gjf=EHRCONTEXT+"/jackbe/jf/";
Gjj=EHRCONTEXT+"/jackbe/";
Gjd=EHRCONTEXT+"/jackbe/";
IP=Gjj+"img/"+""+EHRCONTEXT+"/jackbe/img/";
CVM={css:{apl:1,axischart:1,calendar:1,contextMenu:1,jbtable:1,menu:1,pager:1,slider:1,tabs:1,toolbar:1,treeview:1,menuS:1},rb:{jackbeMessages:1},jc:{},fb:{document:4,pd:1},jf:{filter:1,filterForm:1}};
JkB.userPatterns={};
JkB.userMasks={};
Gv=1;
document.write('<LINK REL=stylesheet id="_$cSs0" MEDIA="all" TYPE="text/css" href="'+Gcs+'apl_'+CVM["css"]["apl"]+'.css">');
if(accept=="ie"){
	document.write('<script LANGUAGE="JScript.encode" charset="ISO-8859-1" src="'+Gjj+'jkb/ini_'+Gv+'.jpg"></script>');
}
else if(accept=="ff"||accept=="sf"){
	var ext=accept=="sf"?".js":".gif";
	document.write('<script charset="ISO-8859-1" src="'+Gjj+'jkb/ini_'+Gv+ext+'"></script>');
}
else{
	alert("Your browser doesn't support JackBe.\nIf you want to browse use:\n-Microsoft Internet Explorer 5.5+\n-Netscape 7.1+\n-Firefox 1.0+\n-Safari 2.0+");
}

Open in new window


Has anyone used jackbe and experienced this issue?

thanks in advance
0
Comment
Question by:dkim18
  • 11
  • 10
21 Comments
 
LVL 58

Expert Comment

by:Gary
ID: 39614498
Have you tried disabling compatibility view? Either thru the tools menu or clicking what looks like a torn page to the right of the address bar
0
 

Author Comment

by:dkim18
ID: 39614578
thanks for your quick reply.
yes, it works.
does it mean it tells the browser to render the page as if it were older IE version ?
since this is a large intranet web app, could it affect other pages then?
0
 

Author Comment

by:dkim18
ID: 39614583
indeed, this changes some other area's look&feel....
0
 
LVL 58

Expert Comment

by:Gary
ID: 39614592
If it is blue then it is going into compatibility mode, which can mean older websites will render better.
You can specify specific websites if needed or switch between the views by clicking the torn page icon

Though just to be sure are you saying it is working in compatibility view or with compatibility turned off?  Normally IE will not go into compat mode and you can disable it by adding an header to your intranet pages.
0
 

Author Comment

by:dkim18
ID: 39615011
if I turn the compat mode off, then I can make on/off by just clicking the torn page icon. If the icon is blue, then it changes person's info on the top of the each page so far.

Can I just set the compat on for this particular page that display jackbe stuff?(w/o user click the torn page icon..)
0
 
LVL 58

Expert Comment

by:Gary
ID: 39615020
Under Tools/Compatibility settings you can add it to the list
0
 

Author Comment

by:dkim18
ID: 39615135
Under Tools/Compatibility settings, I can't set particular page. It will affect entire site.
0
 
LVL 58

Expert Comment

by:Gary
ID: 39615154
Yes it is site wide, you can just click the Compat icon as and when you need it - that's the best you can get.
0
 

Author Comment

by:dkim18
ID: 39615169
hm....we can't ask that kind of additional task to users. when the page is loaded, it should be working page at first glance.
0
 
LVL 58

Accepted Solution

by:
Gary earned 500 total points
ID: 39615194
As I said earlier you could add an header to the page/s .e.g
<meta http-equiv="X-UA-Compatible" content="IE=9">
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:dkim18
ID: 39615440
I added that in the header, but didn't work.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<html>
  <head>
     <meta http-equiv="Cache-Control" content="no-store,max-age=-1">
     <meta http-equiv="X-UA-Compatible" content="IE=10"> 
		<meta name="expires" content="0">
		<title>xxxxxx</title>
...
...
...

Open in new window

0
 
LVL 58

Expert Comment

by:Gary
ID: 39615458
Needs to be IE=9 or less not 10
0
 

Author Comment

by:dkim18
ID: 39615471
this particular page with jackbe doesn't work properly on IE10 as the title of this question stated. So, I need to make it work on IE10.
(It works ok on IE8.)
0
 
LVL 58

Expert Comment

by:Gary
ID: 39615476
That's why you need to set the compat mode to a lower version of IE
0
 

Author Comment

by:dkim18
ID: 39615482
I already tried that on IE10 and it doesn't work. I thought it didn't work b/c I put lower version number and ran it on IE10.
0
 
LVL 58

Expert Comment

by:Gary
ID: 39615496
When you click F12 in the top bar does is it show IE 10 Compatibility View?
0
 

Author Comment

by:dkim18
ID: 39615500
yes, it does.
Browser mode: IE10  
Document Mode: IE9 standards
0
 
LVL 58

Expert Comment

by:Gary
ID: 39615504
If it was in Compat mode it would say IE 10 Compat View - so it isn't going into compatibility mode.
Move the meta tag so it is the first line and try again.
0
 

Author Comment

by:dkim18
ID: 39615513
still doesn't work...

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<html>
  <head>
          <meta http-equiv="X-UA-Compatible" content="IE=9">
          <meta http-equiv="Cache-Control" content="no-store,max-age=-1">
     
            <meta name="expires" content="0">
            <title>

Open in new window

0
 
LVL 58

Expert Comment

by:Gary
ID: 39615521
Don't know what else to suggest - it should work, it's quite bad on their part that they don't support a browser that has been around for a year.
You may just have to tell your users to use a different browser like Chrome.
0
 

Author Closing Comment

by:dkim18
ID: 39626122
it worked with "IE=8" instead of "IE=9"
thanks!
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

Styling your websites can become very complex. Here I'll show how SASS can help you better organize, maintain and reuse your CSS code.
This article explains how to prepare an HTML email signature template file containing dynamic placeholders for users' Azure AD data. Furthermore, it explains how to use this file to remotely set up a department-wide email signature policy in Office …
In this tutorial viewers will learn how to code links for mobile sites that, once clicked, send a call or text to a specified number. For a telephone link (once clicked, calls a number), begin with a normal "<a href=" link tag. For the href, specify…
In this tutorial viewers will learn how to customize the background color and font color of highlighted text using the ::selection element in CSS Begin by defining the selected text as an element in CSS by typing "::selection": Style the ::selection…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now