Solved

Error when doing send receive from Outlook 2010 to Sharepoint 2010 calendar

Posted on 2013-10-31
8
836 Views
Last Modified: 2013-11-11
I added a calendar to Outlook by using connect to outlook from within a Sharepoint Calendar.  It added but will not sync.  The error from send / receive in outlook is:

Task 'Sharepoint' reported error (0x80070005):  You do not have permisions to view this Sharepoint list (IT - Calendar).  Contact the Sharepoint site administrator.  HTTP 302.'

I have ruled out permissions.  I think this has to do with alternate access mappings.
I have tested this using outlook connected internally and externally and get the same error.  We have http redirecting to https for our sharepoint site.

The alt. access mappings are setup so that http://home.domain.com is in the Intranet zone and https://home.domain.com is in the Internet zone.

Lastly we have tmg proxy setup for external access but I don't think that should impact my interna users as they should go right to the Sharepoint server.
0
Comment
Question by:dmwynne
  • 4
  • 4
8 Comments
 
LVL 9

Accepted Solution

by:
BobHavertyComh earned 500 total points
ID: 39616711
I think this has to do with the order of your AAM. This might solve your problem.

http://bloggingsharepoint.blogspot.com/2011/09/outlook-calendar-synchronization.html
0
 
LVL 14

Author Comment

by:dmwynne
ID: 39622004
It is not clear to me what to change it to based on that link.
0
 
LVL 9

Expert Comment

by:BobHavertyComh
ID: 39625108
Sorry I've been away. Two things you can try.  Make your non ssl address you use for intranet also be the entry for "default". Also, does this happen with only one list? Try to make a very generic list and see if you get the same problem. Outlook will not work with customs lists. And sometimes it is a problem with a custom column and not the entire list itself.
0
 
LVL 9

Expert Comment

by:BobHavertyComh
ID: 39625175
Also, you didn't mention all of the versions you are using, whether you have done any upgrades recently etc....

I found this as it relates to SP 365, but it could relate to your situation as well.

"One has to have Wins 7 and Outlook 2010 as a minimum in order for the new SharePoint 2013 "Connect to Outlook" feature to work."
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 14

Author Comment

by:dmwynne
ID: 39625269
Sharepoint 2010 and Outlook 2010.

This is a test calendar with nothing in it.  I was testing it out but I did try it with another document library and got the same thing.

So should I change the http://home.domain.com to default or create a new entry?  Also for both internal and external users are redirected from http to https automatically.
0
 
LVL 9

Expert Comment

by:BobHavertyComh
ID: 39625758
OH, so both are redirected to the https address. You didn't mention that.  Thank you. If they are both directed to the https address, then I believe that the https address needs to be the default address in AAM. And that is the situation that the article I linked was speaking of. Let me know if I misunderstood something. But the thing to remember, is the precedence order in which Outlook processes these things that the article that I linked mentioned. That much is factual. AAM is mainly for Outlook and mail. It just simply decides what address you are accessing the site from, so that it can do proper email addresses or other addresses for alerts etc..... So if you are accessing the site through an http address, it makes any links that it has to create for emails, workflows or alerts or even links to lists to  use that prefix, but if someone is accessing it a different way, it changes the address of everything to an https address. And this could include links to lists and outlook themselves.
0
 
LVL 14

Author Comment

by:dmwynne
ID: 39630119
I set the https address to be the default but am still getting the same error.
0
 
LVL 14

Author Comment

by:dmwynne
ID: 39630981
I changed https://home.domain.com to Default but had not changed the http.  I went ahead and  changed http://home.domain.com to Internet from Intranet and now it is working.  So your original link was correct.  I just wanted to make sure I understood this as much as possible before making the change as this is in production.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
As with any other System Center product, the installation for the Authoring Tool can be quite a pain sometimes. This article serves to help you avoid making these mistakes and hopefully save you a ton of time on troubleshooting :)  Step 1: Make sur…
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
The view will learn how to download and install SIMTOOLS and FORMLIST into Excel, how to use SIMTOOLS to generate a Monte Carlo simulation of 30 sales calls, and how to calculate the conditional probability based on the results of the Monte Carlo …

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now