Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

set up a reverse dns with bind9 on ubuntu server 9.04

Posted on 2013-10-31
4
Medium Priority
?
366 Views
Last Modified: 2013-11-02
Hi,
I have configured a dns server on ubuntu 9.04 with bind 9 but I have a probleme to set up the reverse dns I have the following error : ** server can't find 3.207.168.192.in-addr.arpa: SERVFAIL  when using nslookup .  The dns forward is working good. It's a basic setup,  something is  wrong but I cannot figure it out.

I attach my configuration file.

Thx in advance for your help.
db.192.168.10.txt
db.mainbranch.txt
named.conf.txt
0
Comment
Question by:samkeen
  • 2
  • 2
4 Comments
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 39615325
Your config line zone "0.in-addr.arpa" tells named that you can resolve any address. Remove it. Also remove the 127 line and the 255 line.
The complained-of address 192.168.207.3 can not be resolved by any file you have posted.
Network 127/8 should be defined in /etc/hosts and nowhere else.
0
 

Author Comment

by:samkeen
ID: 39616522
HI, I followed your instructions as you can see bellow and I have the same error.
Are there any other files involved in the reverse resolution?
thank .

The ip 192.168.207.3 is my mistake it was from an other test, wrong copy/paste.


root@budo:/etc/bind# /etc/init.d/bind9 restart
 * Stopping domain name service... bind9                                                                                                                         [ OK ]
 * Starting domain name service... bind9                                                                                                                         [ OK ]

root@budo:/etc/bind# nslookup toto
Server:         192.168.10.1
Address:        192.168.10.1#53
Name:  toto.mainbranch
Address: 192.168.10.5

root@budo:/etc/bind# nslookup 192.168.10.5
Server:         192.168.10.1
Address:        192.168.10.1#53
** server can't find 5.10.168.192.in-addr.arpa: SERVFAIL
root@budo:/etc/bind#
named.conf.txt
db.mainbranch.txt
db.192.168.10.txt
0
 
LVL 35

Accepted Solution

by:
Duncan Roe earned 400 total points
ID: 39618153
I've attached my corresponding files. They work, so if you modify yours to match, then yours should work too.
named.conf.txt
local.net.txt
ten.lacol.txt
0
 

Author Closing Comment

by:samkeen
ID: 39619454
Thank you the files were very helpfull.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month14 days, 7 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question