Can't Open Phone and Modem Menu

Posted on 2013-11-01
Last Modified: 2013-11-04
I'm having an issue on one of our PCs when it comes to the ShoreTel software. After doing some troubleshooting, ShoreTel support was trying to open the Phone and Modem menu from the Control Panel but kept getting the error, "Phone and Modem control panel cannot be opened. You may have a problem starting telephony service." I can't even open this when I'm logged in as the domain admin, so I don't think it's a permission thing. This is a Windows 7 64-bit machine.
Question by:pantherguy
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
LVL 15

Expert Comment

ID: 39618660
What version of ShoreTel communicator are you using?  

If it is just the phone and modem applet, I am not sure what changes the Shoretel communicator/call manager would make to it.

For giggles, can you open a command prompt as admin (right click choose run as administrator)  then run a SFC /scannow

Author Comment

ID: 39621684

We're running 10.2.

I know they have a TAPI configured in there because I can see it when I open the Phone and Modem menu on all of our other PCs.

I ran the command and it said it couldn't find any issues.
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.


Author Comment

ID: 39621689
I also took a look at the link but the regedit path was already set correctly.
LVL 15

Accepted Solution

getzjd earned 500 total points
ID: 39621835
Has it ever worked?  If so, are you able to use Windows 7 restore points to go back to where it worked?   Have you tried removing the communicator software to see if you can then open the applet?

Unfortunately, I cannot reproduce the issue as we are on 12.2 now, however, when we were on 10.2, we did not have this issue.   The only issue we had on 10.2 was if SAP and ShoreTel communicator were installed on the same machine.   We could not uninstall, update, or reinstalled SAP as long as ShoreTel was installed.   We had to uninstall ShoreTel before we could upgrade or modify SAP.   Thankfully, this disappeared with the 12.2 client.

Do you have partner or enterprise support?  If so, I would start there.  Otherwise, when it comes to issue like this, if I cannot resolve a software quirk in an hour or two, I just reimage the machine.  If I spend more than 2 hours troubleshooting a software issue that may still not yield the desired result, it is better for me to spend 2-3 hours and just reload the machine from scratch.

Author Comment

ID: 39621876
It's worked for 4+ years and then just stopped working a week ago. All of our PCs are the same build and this is the only one that's having an issue. I haven't tried a restore point but I may give that a shot. We do have support but I guess 10.2 does not support Windows 7, so they're not much help.
LVL 15

Expert Comment

ID: 39621931
I would try the restore point.  

If you do have support, I would definitely look to upgrade from 12.2.   Obviously, that requires a planning and slight downtime.  If I am correct, Shoretel typically maintains a 2 version inplace upgrade capability, thus meaning you can go directly from 10.2 to 12.2  but not from 10.2. to 13.2 or 14.2 (when available).      We adopted a policy of never being more than 2 versions out of date, thus allowing for in-place upgrades as well as better client operating system compatibility.   You may want to consider a maintenance plan that takes the 2 version difference into consideration.

Author Comment

ID: 39621938
Thanks, I'll try that.

Yeah, during my discussion with support, we are now planning to upgrade so Windows 7 and Office 2010 is supported.

Author Comment

ID: 39622766
A system restore fixed the issue. I'm not sure what it was but a Windows file had to have been damaged or something. Thanks again for your help.

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question