Cannot Delete Folder

Posted on 2013-11-01
Last Modified: 2013-11-23
I am attempting to delete a folder within a file share on a cluster.  When attempting to delete the folder, I receive "Item Not Found - This is no longer located in ... Verify the item's location and try again".  The folder appears to be partially delete because I can create a folder with the identical name and both can exist.  I am then only able to delete the newly created folder name.  We have failed the share to another cluster and it still occurs.  I have tried deleting from the command prompt with no luck.  Are there any other built in tools to delete the file?  The servers it's running on is Server 2008 SP2 64-bit.
Question by:ifoote
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
LVL 26

Expert Comment

ID: 39616802
Have you tried rebooting the server?  It has been a long time since I have seen this (I think back in the days when NT was the server OS) but sometimes we would delete something that would remain listed until we rebooted. Never did figure out the cause though.
LVL 27

Expert Comment

by:Jason Watkins
ID: 39616966
I'd stop sharing the folder first, i.e. take it offline and then delete with Explorer.

Author Comment

ID: 39617035
The server has been rebooted however when we reboot, we fail the cluster over to another server.  We are unable to stop sharing as this is a network share and would impact the whole company.
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

LVL 26

Expert Comment

ID: 39617197
Was the folder itself shared?  If so try this:

net share sharename /delete

where sharename = the name the folder was being share as.

Author Comment

ID: 39657137
The folder itself was not shared

Accepted Solution

ifoote earned 0 total points
ID: 39657611
I was able to find a resolution by doing the following.

To solve, follow these steps:
1. Open up a command prompt (run cmd.exe from the Start Menu).
2. Navigate to the folder that the object resides in.
3. Run "dir /a /x /p" to display the contents of the folder, including hidden files (/a) and 8.3 filenames (/x).
4. Find the 8.3 filename of the object to the left of the regular, long filename.
5. Run "ren <8.3 name>" to rename the object, "del <8.3 name>" to delete it if it's a file and "rd /s <8.3 name>" to delete it if it's a folder.
LVL 26

Expert Comment

ID: 39657631
Thank you for posting what finally worked.  This may help someone with the same issue in the future.

Author Comment

ID: 39657656
I was able to resolve on my own.

Author Closing Comment

ID: 39671105
I was able to resolve on my own.

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
DNS Replication 12 71
Backup of system state (VMware) 19 98
Measure time after installing Antivirus 8 59
Google Chrome GPO Not Applying 5 32
I was asked if I could set up a fax machine so that incoming faxes were delivered to people's Exchange inboxes and so that they could send faxes from their desktops without needing to print the document first.  I knew it was possible but I had no id…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question