• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 248
  • Last Modified:

Exchange 2007 external Autodiscover issues

I'm having an issue where externally we are getting weird results with our autodiscover.

When we try to create a new Outlook account externally, it gives a certificate error and points to some wrong URL/cert that it wants to pull down. I'm assuming this is because its trying to go to http://mydomain.com/AutoDiscover but our @ is pointing to our website host.

So I created an autodiscover.mydomain.com and I also created a SRV record which points at autodiscover.mydomain.com which points to the same IP as our mail.mydomain.com

When I do the tests at testexchangeconnectivity.com - it passes but it does fail the first step at http://mydomain.com/autodiscover - which is giving the same exact result that we're seeing on outlook clients.

what am i missing....
0
Metaltree
Asked:
Metaltree
  • 6
  • 4
1 Solution
 
lpadmin1Commented:
I would post the results of your autodiscover tests.  This sounds like a DNS issue.  Did you try an MX record and is your firewall configured properly?  Do previous users also have this issue with OWA or only new mailboxes?
0
 
MetaltreeAuthor Commented:
Yes, obviously this is a DNS issue, thats what Autodiscover utilizes.
What does a MX record have to do with it?
There is already a NAT policy for 443 in place to the Exchange server, so yes the firewall is configured properly.
This is not an OWA issue.
0
 
Simon Butler (Sembee)ConsultantCommented:
Autodiscover tries to use https://example.com/Autodiscover/Autodiscover.xml first.
If that works then you get an SSL error. You need to speak to your web host and get them to turn it off for your domain so that Outlook goes on to the next variant.

Simon.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
MetaltreeAuthor Commented:
Thanks Simon, I thought that might be the issue.
0
 
MetaltreeAuthor Commented:
Simon,

Apparently our webhost is claiming that there is no /AutoDiscover/ under our root domain, so I explained that we're getting the Cert from another company which I'm guessing is hosted on that same server, which he confirmed it is. He said hes going to look as to how to disable it completely so that the /AutoDiscover/ offers no response.

Seem right to you?
0
 
Simon Butler (Sembee)ConsultantCommented:
That is usually what happens.
A server can host multiple sites on HTTP, but only one site on HTTPS. It is the one site that will be causing the problems.

Therefore it isn't that you have /Autodiscover under your domain, but /Autodiscover is on the SSL site.

Simon.
0
 
MetaltreeAuthor Commented:
My web hosting guy's mind appears to be blown and he is literally clueless on how to fix this issue. Simon, or anyone who might know a thing or two about IIS/web servers can you shed some light on what I can tell him needs to get done?
0
 
Simon Butler (Sembee)ConsultantCommented:
If there is a control panel on the server then it needs to be removed using that. It is control panels that cause the problem.

Simon.
0
 
MetaltreeAuthor Commented:
What?
0
 
Simon Butler (Sembee)ConsultantCommented:
I thought it was pretty clear.

Most web hosts use control panels for managing their sites. That is the cause of this problem - one of the control panel vendors has started to use the Autodiscover protocol for their own needs and most web hosts just use the default settings for everything, when in actual fact, most web hosts aren't setup correctly to use Autodiscover and it just gets in the way of Exchange servers.

Simon.
0
 
MetaltreeAuthor Commented:
So you're saying like a 3rd party control panel for web services?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now