Solved

Dell M1000e w/ 2 Dell M6220 s to a Cisco 2960-S using LACP

Posted on 2013-11-01
6
1,167 Views
Last Modified: 2016-11-23
Here is our setup:
iSCSI devices to Cisco 2960-S
2960-S to multiple VMWare Servers & 2 M6220 Switches in a M1000e Chassis
The 1st M6220 works fine - no errors or anything
As soon I turn ports on the 2nd M6220 it starts port flapping

Cisco log:
*Mar 27 03:38:44.105: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.c999.eec1 in vlan 1 is flapping between port Gi1/0/13 and port Gi1/0/16
*Mar 27 03:39:14.126: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.c999.eec1 in vlan 1 is flapping between port Gi1/0/13 and port Gi1/0/16
*Mar 27 03:39:44.099: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.c999.eec1 in vlan 1 is flapping between port Gi1/0/13 and port Gi1/0/16
*Mar 27 03:40:14.120: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.c999.eec1 in vlan 1 is flapping between port Gi1/0/13 and port Gi1/0/16

When I look in the address table for 001e.c999.eec1 on the 1st M6220 the Type is 'Other' and the interface is 'Vl1' it is not in the address table for the 2nd M6220. I have no clue where 001e.c999.eec1 is coming from, I am assuming from the CMC managment interface?

I just would like to have 2 iSCSI ports per blade and have the M6220's connection to the Cisco redundantly and as fast a possible, to reduce as many bottlenecks as possible.
0
Comment
Question by:burdit
  • 4
  • 2
6 Comments
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
How do you currently have the 2960 connected to the Dell Blade switches. Config?
0
 
LVL 2

Author Comment

by:burdit
Comment Utility
Here is the current config: Dell switches are LACP'd int ports 13-16 for our A2 M6220 switch and 45-48 for our B1 M6220 switch.


Current configuration : 7291 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname sanswitch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$42Le$rdLjJct8SuzhA8CBsjYrv1
!
username admin privilege 15 password 7 045A0F0B5B701E1E584826
!
!
no aaa new-model
clock timezone CST -6
clock summer-time CDT recurring
switch 1 provision ws-c2960s-48ts-l
!
no ip domain-lookup
ip domain-name burd.local
!
!
crypto pki trustpoint TP-self-signed-438887424
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-438887424
 revocation-check none
 rsakeypair TP-self-signed-438887424
!
!
crypto pki certificate chain TP-self-signed-438887424
 certificate self-signed 01
  3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34333838 38373432 34301E17 0D393330 33303130 30303331
  305A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3433 38383837
  34323430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  AF7AB609 7BCED88B 8E8C894D A89CC99A 3B790688 A5CEB610 9A1D88EC E2033884
  2F8D0B65 83809890 65111B07 01727982 9E42A075 19031830 AA615448 610F8F3A
  2F36F6E1 A2410523 9DBC0AF0 C7A6E78D BAE26995 8303124B 0DD6EFE1 692E343A
  F34E95AB 271E660A 70D0BAEB D2377947 F1D27E7F 09FB52DB AACB45A0 35F1F839
  02030100 01A37430 72300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  11041830 16821473 616E7377 69746368 2E627572 642E6C6F 63616C30 1F060355
  1D230418 30168014 339947CD 1E3A2F17 A3E11BDE E143F126 B3EA5A85 301D0603
  551D0E04 16041433 9947CD1E 3A2F17A3 E11BDEE1 43F126B3 EA5A8530 0D06092A
  864886F7 0D010104 05000381 81002BDC F3B01F26 F2716C56 E6D1849C 163E291B
  C670B0D8 5868D50F 4D63BF3E 1EB4A275 5C702141 040600EC A4F1E864 A6C67E4A
  0B0752CB 17C31A18 A13ABFD9 D3B1DA53 16606E14 48EC2BA1 B936D60B D01D0674
  03A4EDB3 14BBA139 35A5F1FC D82744E7 B978B792 48017C22 8363D4BE 9B06EE2C
  9C1B13D2 7BF12FF9 A787796B 1ADF
  quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel5
interface Port-channel6
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/9
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/10
 flowcontrol receive desired
 spanning-tree portfast
!
 interface GigabitEthernet1/0/11
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/13
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2000
 channel-group 5 mode active
!
interface GigabitEthernet1/0/14
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2000
 channel-group 5 mode active
!
interface GigabitEthernet1/0/15
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2000
 channel-group 5 mode active
!
interface GigabitEthernet1/0/16
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2000
 channel-group 5 mode active
!
interface GigabitEthernet1/0/17
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/18
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/19
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/20
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/21
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/22
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/23
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/24
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/25
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/26
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/27
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/28
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/29
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/30
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/31
 flowcontrol receive desired
 spanning-tree portfast
!
 interface GigabitEthernet1/0/32
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/33
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/34
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/35
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/36
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/37
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/38
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/39
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/40
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/41
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/42
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/43
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/44
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/45
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2001
 channel-group 6 mode active
!
interface GigabitEthernet1/0/46
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2001
 channel-group 6 mode active
!
interface GigabitEthernet1/0/47
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2001
 channel-group 6 mode active
!
interface GigabitEthernet1/0/48
 switchport mode access
 flowcontrol receive desired
 lacp port-priority 2001
 channel-group 6 mode active
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 ip address 123.0.0.99 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
line vty 0 4
 login local
 transport input telnet ssh
line vty 5 15
 login local
 transport input telnet ssh
!
end
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Can you post:

sh ether summary

sh spanning tree
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 2

Author Comment

by:burdit
Comment Utility
Sure! Here they are:

sanswitch#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
5      Po5(SD)         LACP      Gi1/0/13(I) Gi1/0/14(I) Gi1/0/15(I)
                                 Gi1/0/16(I)
6      Po6(SD)         LACP      Gi1/0/45(D) Gi1/0/46(I) Gi1/0/47(D)
                                 Gi1/0/48(D)

                                                 
                                                 
                                                 
sanswitch#show spannin
sanswitch#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     001e.c999.eebf
             Cost        4
             Port        14 (GigabitEthernet1/0/14)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5478.1a28.e400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1             Desg FWD 4         128.1    P2p Edge
Gi1/0/2             Desg FWD 4         128.2    P2p Edge
Gi1/0/3             Desg FWD 4         128.3    P2p Edge
Gi1/0/4             Desg FWD 4         128.4    P2p Edge
Gi1/0/5             Desg FWD 4         128.5    P2p Edge
Gi1/0/6             Desg FWD 4         128.6    P2p Edge
Gi1/0/7             Desg FWD 4         128.7    P2p Edge
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Gi1/0/8             Desg FWD 4         128.8    P2p Edge
Gi1/0/9             Desg FWD 4         128.9    P2p Edge
Gi1/0/10            Desg FWD 4         128.10   P2p Edge
Gi1/0/11            Desg FWD 4         128.11   P2p Edge
Gi1/0/12            Desg FWD 4         128.12   P2p Edge
Gi1/0/13            Altn BLK 4         128.13   P2p
Gi1/0/14            Root FWD 4         128.14   P2p
Gi1/0/15            Altn BLK 4         128.15   P2p
Gi1/0/16            Altn BLK 4         128.16   P2p
Gi1/0/17            Desg FWD 4         128.17   P2p Edge
Gi1/0/18            Desg FWD 4         128.18   P2p Edge
Gi1/0/19            Desg FWD 4         128.19   P2p Edge
Gi1/0/20            Desg FWD 4         128.20   P2p Edge
Gi1/0/21            Desg FWD 4         128.21   P2p Edge
Gi1/0/22            Desg FWD 4         128.22   P2p Edge
Gi1/0/23            Desg FWD 4         128.23   P2p Edge
Gi1/0/24            Desg FWD 4         128.24   P2p Edge
Gi1/0/25            Desg FWD 4         128.25   P2p Edge
Gi1/0/26            Desg FWD 4         128.26   P2p Edge
Gi1/0/31            Desg FWD 4         128.31   P2p Edge
Gi1/0/32            Desg FWD 4         128.32   P2p Edge
Gi1/0/33            Desg FWD 4         128.33   P2p Edge
Gi1/0/34            Desg FWD 4         128.34   P2p Edge
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Gi1/0/35            Desg FWD 4         128.35   P2p Edge
Gi1/0/36            Desg FWD 4         128.36   P2p Edge
Gi1/0/37            Desg FWD 4         128.37   P2p Edge
Gi1/0/38            Desg FWD 4         128.38   P2p Edge
Gi1/0/39            Desg FWD 4         128.39   P2p Edge
Gi1/0/40            Desg FWD 4         128.40   P2p Edge
Gi1/0/41            Desg FWD 4         128.41   P2p Edge
Gi1/0/42            Desg FWD 4         128.42   P2p Edge
Gi1/0/46            Desg FWD 4         128.46   P2p
0
 
LVL 2

Accepted Solution

by:
burdit earned 0 total points
Comment Utility
In the Dell M6220 LACP had to be set up with LAG ports. After we added the LAG port group that corresponded with the Cisco channel group the port flapping went away and we are now error free.
0
 
LVL 2

Author Closing Comment

by:burdit
Comment Utility
After doing a lot of quick learning about iSCSI, Dell M1000e chassis, Dell M6220 switches, and Cisco switched, Finally figured out that while we had set up LACP priority in both the Cisco and the Dell switches, the Port-Channel group was only set up in the Cisco thus creating the port flapping, once we also set up Port-Channels on the Dell (LAG is what they call it) the flapping stopped.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

AWS has developed and created its highly available global infrastructure allowing users to deploy and manage their estates all across the world through the use of the following geographical components   RegionsAvailability ZonesEdge Locations  Wh…
Transparency shows that a company is the kind of business that it wants people to think it is.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now