Setting up SQL server on my laptop

I installed SQL server 2008 R2 on my laptop but when i try to login i get this error. What do i need to do?

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.
vbnetcoderAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
In Administrative Tools under Services and Applications is the SQL Server Configuration Manager.  The set up for the SQL Native Client is there, look under client protocols.  There is a similar set up for SQL Server itself but only on the machine that is running SQL Server.  Enable TCP/IP on both of them.  More info here: http://msdn.microsoft.com/en-us/library/bb909712%28v=vs.90%29.aspx
0
 
rshqCommented:
Hi
  Please check your instance maybe (local\sqlexpress)
0
 
vbnetcoderAuthor Commented:
Is that the same as server name?  Sorry, i don't know much about this
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
Dave BaldwinFixer of ProblemsCommented:
How are you trying to login?  Did you download SQL Server Management Studio (SSMS) also so you could 'manage' it?  SSMS on my systems always let me login using Windows Authentication so I could set up other methods.
0
 
BDirksCommented:
If you are using <machinename>\<instancename> in your connection string, then you will need to enable TCP/IP protocol in order to allow "remote" connections to your machine.  Even thought the connection is not "remote", using the machine name as part of the connection string requires the TCP/IP protocol.
0
 
Dave BaldwinFixer of ProblemsCommented:
Also if you are trying to connect by name, you need to turn the 'sqlbrowser.exe' service because that's where the 'connect by name' function connects to.  If you use the IP address, you can connect directly without the sqlbrowser service.
0
 
vbnetcoderAuthor Commented:
will come back to
0
 
vbnetcoderAuthor Commented:
How do i enable TCP/IP protocol?
0
 
vbnetcoderAuthor Commented:
OK -- I enabled it.  I am running everything on my laptop since i am setting this up for testing and learning more about SQL server so there isn't another computer.

I am still getting the error though.  Any else?
0
 
Dave BaldwinFixer of ProblemsCommented:
Did you enable TCP/IP on both the SQL Native Client and the SQL Server?  What connection string are you using?  What program or language for that matter?
0
 
vbnetcoderAuthor Commented:
ty
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.