How to prevent a computer from locking out despite idle settings?

Hi,
I have a dilemma that i would appreciate any help.
I have a security cam computer, that like all others has a policy to lock itself every 15 min. obviously this computer is in the domain but is pretty much used only as a monitor, there is someone watching it 24\7 and it becomes a problem where there's no activity but it's suppose to stay unlocked.

I want to create a condition using a program\script or any other tool that would mean - As long as program X is running, the computer won't go to idle.

any ideas?
johnnyjonathanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ashok DewanFreelancerCommented:
To disable Lock:

Under HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System, create a new DWORD value named DisableLockWorkstation and set value to 1.

Then restart the computer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnnyjonathanAuthor Commented:
Thanks Neil. but that would mean that the unlock will be disabled all together, i'm looking for a way to have it locked only if a specific program isn't running on the computer
0
McKnifeCommented:
Hi.

The lock will only happen if the screen saver kicks in. To prevent the screen saver, write a schedule task that runs a batch every 14 minutes that sends a message to localhost every few minutes if the monitoring process (the executable of the software) is active.
Like this:
tasklist |findstr iexplore.exe && msg * ie is active, screen saver stopped

To close the message boxes, simply use a switch for a short displaying time:
tasklist |findstr iexplore.exe && msg /time:1 * ie is active, screen saver stopped.
0
johnnyjonathanAuthor Commented:
Accepted, works great!
0
McKnifeCommented:
Sorry, WHAT works great, mine or his? I suppose you selected the wrong solution :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.