[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2457
  • Last Modified:

Can ping but cant see LAN-device on WLAN-computer

On my computers conneted to my LAN i can Discover my TV Connected to the LAN. I also have a WLAN in the same net and i can ping the TV from a pc connected to the WLAN but i cant see tv in "Add Device" management as i can do from my pc on LAN.
I have Windows 8 and Router is a Sonicwall TZ200 .
I have bridged WLAN and LAN in router.

X0 / LAN / 192.168.0.1 / 255.255.255.0 / Primary Bridged I/F / Bridged to W0
W0 / WLAN / 192.168.0.1 / 255.255.255.0 / Secondary Bridged I/F / Bridged to X0

Do I miss something?
0
Adam_Li
Asked:
Adam_Li
  • 7
  • 5
  • 5
  • +1
2 Solutions
 
Aaron TomoskyTechnology ConsultantCommented:
Is the wlan zone trusted?
0
 
Blue Street TechLast KnightsCommented:
Hi Adam_Li,

In order to achieve an L2 Bridge between the LAN and WLAN you need to set it up like this:

Step 1: For configuring the Sonicwall WLAN interface go to Network > Interfaces > WLAN configure. Select the IP Assignment to Layer 2 Bridge Mode. And on the Bridge to drop-down menu select X0 which is the default LAN on the Sonicwall.

Note: You can bridge the SonicWALL WLAN with the interface that belongs to LAN or DMZ zone or in other words to any interface which belongs to a custom created zone of Type "Trusted" and "Public". You cannot create the Bridge Pair to WAN which is a Untrusted zone or any interface which is part of the WAN zone.

Step 2: After selecting the Primary Bridged Interface. Click on OK and save the settings. You will get an warning pop-up message that says "Interface Bridge Doesn't Change its zone. Only allow rule between bridge pair will be auto-added.  Please add other necessary rules manually."

Click OK on the box

Step 3: Now the X0 Interface and the W0 interface are bridged with the same IP address for their Interfaces.

Step 4: An auto added allow Access Rule will be created from WLAN to LAN under Firewall Access Rules.

Step 5: Under Network > Address Objects page both W0 (WLAN) Subnet and LAN Primary Subnet will be pointing to the same subnet.
 
Step 6: When wireless clients connect to the Sonicwall WLAN they will get an IP address from the SonicWALL LAN Segment.

If the SonicWALL is the DHCP server the WLAN clients can get an IP from the LAN DHCP lease scope on the SonicWALL. If there is a DHCP server you don't need to create an IP Helper policy since the WLAN and LAN fall under bridge pair. No relay IP is needed. The wireless client computers can access the local resources and the Internet without any access rule.

When using SonicPoint (connected to say the X2 interface), connect the X0 (LAN) interface and the Sonicpoints (connected to the X2 (WLAN) interface), to separate switches.

Verify those settings. Can you take a screenshot of your Access Rules and post them for the applicable Zones (LAN & WLAN).

Make sure you SonicOS is current too.

Also, check your Windows Firewall settings and make sure Inbound Rules are not restricted to specific Zones, subnets or IP Ranges.

Thanks!
0
 
Craig BeckCommented:
You will need to ensure that broadcast traffic is allowed between the LAN and WLAN or this won't work.
0
New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

 
Adam_LiAuthor Commented:
Thanks for answering.

aarontomosky: Its trusted. Do you mean Internet Properties - Trusted Sites, right?

diverseit: Thanks but this was what i allready had done. I will add screenshots from my Access Rules. As i said, the problem is that i cant add TV-Device to my Wireless PC.

craigbeck: Could you please explain where i can find this config?
ar-1.JPG
ar-2.JPG
ar-3.JPG
0
 
Craig BeckCommented:
If you are using simple L2 bridging and not captive bridging, broadcast traffic should be enabled.
0
 
Blue Street TechLast KnightsCommented:
Yes, I just wanted to make sure you set it up correctly.

You should check Access Rule #29 W0 Subnet and make sure it's the correct subnet or rather change it to Any.

I also wanted to you check your Window's firewall rules. Try disabling and retest.

If I'm not mistaken I believe Device Management works off of Network Discovery. Try adding the TV to the HOST file of the laptop.
0
 
Aaron TomoskyTechnology ConsultantCommented:
Check the workgroup name of the laptop. If it's not the same it won't show up.
0
 
Adam_LiAuthor Commented:
Still not working. Think i have tried everything by now.
The Laptop has former been part of a domain, but now in my home Workgroup. Could that be the issue maybe? Maybe something is locked somewhere in computer..  registry maybe?
0
 
Blue Street TechLast KnightsCommented:
Workgroups provide a basis for file and printer sharing, but they don't actually set up sharing for you. Did you try disabling the Windows Firewall via Services rather than the GUI (Control Panel)? Due to OS corruption there can be an disparity between the GUI and the firewall services still running.

Have you tried Homegroups rather than Workgroups? A Homegroup makes sharing easier.
Have you turned on Find Devices and Content? See here for details on setup: http://windows.microsoft.com/en-us/windows-8/find-pcs-devices-content-on-network

Do you have access to another laptop (friend or someone else) you could try to duplicate the issue?
0
 
Blue Street TechLast KnightsCommented:
Any update on this?
0
 
Adam_LiAuthor Commented:
Nothing.. Tried almost everything.. Been kind of busy too, but will test with another Laptop soon. This case has been a real pain in the ass so far.
0
 
Aaron TomoskyTechnology ConsultantCommented:
I mean the zones->configure wlan-> Allow Interface Trust
0
 
Adam_LiAuthor Commented:
Wlan allow interface trust is enabled.
I tried with another laptop but still cant see tv. then connect to LAN and tv appears in device list.
0
 
Adam_LiAuthor Commented:
Thanks but still not working. :( Why why why (crying out load)
0
 
Aaron TomoskyTechnology ConsultantCommented:
Do you have current firmware? I know these ways both work as I've done them multiple times at different sites with all sorts of different sonicwall devices.
0
 
Adam_LiAuthor Commented:
Thanks folks!
I did a Firmware update and a clean setup. Easy. I now discovers my TV on WLAN.
The problem know is that i Cant discover my NAS. It works on LAN. I'll probably find a solution soon.. :)
0
 
Adam_LiAuthor Commented:
Hi again!
Could someone help med map my NAS? I only maps when on LAN, not WLAN.
Its the reversed issue then last time.
0
 
Blue Street TechLast KnightsCommented:
I'd suggest opening a new Question to do so since this one is already closed.

I'll keep my eye open for it.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 5
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now