Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 910
  • Last Modified:

Strange Hard Drive Problem

Here's one I have not personally seen before.

Scenario
- new USB3 SIIG Host adapter card
- new external USB3 dock
- new Seagate 2TB SATA HDD

I installed the above host adapter (in order to have USB3 ports) in a Windows 7 system and ensured the latest drivers were installed with it. Then hooked up the USB3 dock and plugged in the HDD. All was just fine.

The disk was not partitioned and I began to write backup data after allowing a quick NTFS format (portability was not a concern) and assigning a drive letter. All was still fine and this worked for a few days. Suddenly, the disk appeared offline. Checked another disk and it mounted just fine. Remounted the 'new' disk and nothing.

Checked disk manager in windows and found the attached to my surprise. Not that not only are there multiple partitions but also that the volume size is incorrect. Would like to have recovered as I had been writing data out to it!

For the partitions that show healthy, there are no options except to delete. I cannot assign a driver letter. For the unallocated space, I can choose to create a new simple volume but when I try, I only get an error message saying "the operation is not supported by this object".

Again - I have never seen a drive split itself up into multiple partitions like this, leaving also unallocated space and reporting a larger capacity. Preference is to not try to delete the partitions and start over (although I somehow doubt it will let me). I have also not seen a HDD fail like this either. I have not run surface scans but I do not believe this issue has anything to do with surface defects.

Anyone seen anything like this before?
Any suggestions? (See image)
2013-1103-1217.45-ss--HDD-Issue-.jpg
2013-1103-1220.56-ss---e1-.jpg
0
DanielT
Asked:
DanielT
2 Solutions
 
n2fcCommented:
Sounds like the partition table got slammed...

Probable cause:
Errors from 1 of the 3 components in the path (adapter, dock or HDD)...

Make sure that your power options are such that you do not allow the USB to power down or sleep during low activity...

You might also want to ensure that "write-behind caching" is deactivated for USB drives in case this error is persists.

I would check to see if the HDD is still under mfr. warranty & look to get a replacement if possible as well.
0
 
willcompCommented:
Can you connect the hard disk directly to a SATA port on the motherboard? If so, try that and see if it behaves normally.
0
 
DavidPresidentCommented:
The symptoms indicate catastrophic HDD failure.  The reason it looks so strange is that the USB bridge chip is low end and incapable of translating the errors to the host O/S.

If there is a warranty, take it back. If there is no warranty then crack open the case and direct attach the SATA disk to the controller.  Then run some HDD diagnostics that you can download from the WD, Seagate or whatever other hDD model it is.

Sorry.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
DanielTAuthor Commented:
Thanks for the responses.
A bit more info follows.

The HDD - when moved to an alternate case (USB2 as well) showed same issues.

Since I am in trouble for data on the drive anyway I tried two more things...

1) tried to delete a partition (the smallest in the last screenshot I included) and Windows 7 reported that the selected partition was not created by Windows and may contain data recognized from other operating systems. Allowed it anyway and the partition was removed.

2) tried to create a partition in the first "unallocated" space. It created a new partition OK and mounted as a functional (writable) drive. Have not proceeded to delete others.

Both of these actions would seem to me (only prelim) to indicate drive may be OK and that there indeed may be issue with host controller or dock. Have never seen partition table get messed up before like this - but I also hope it is isn't related to trying USB3 adapter and dock!

(ps; HDD is only a few days old)
0
 
DanielTAuthor Commented:
Should have held off a couple of minutes and posted with above but...

Decided to delete the unknown partitions and as I did (unfortunately did not notice at which point) the overall drive size reported correctly (did not change at first deletion or two but was OK before last one was deleted). Cleaned up drive and recreated one partition. Formatted and mounted OK and it is now writing data. Will let it do this as it is just backup data anyway (and secondary backup at that).

Will see what happens by tomorrow sometime.
Should have written  about 450GB for these backup sets.
0
 
DavidPresidentCommented:
Your drive had data corruption. You need to take it back.  Think about it, a few days into the life of the drive it lost data.  Why would you possibly want to continue to use it?
0
 
DanielTAuthor Commented:
dlethe - am in full agreement for a bad HDD! Thx. I generally do not play around with questionable drives for exactly that reason. In this case, though, I also have two other new components, including the USB3 controller (which I would think is next biggest potential cause). Since partitions are an OS created item I am thinking I need to be just as concerned for a hardware problem that may have messed up partitions - although I do not know how.

I am thinking I may indeed need to install direct to internal SATA to weed out.
Will update.
0
 
DavidPresidentCommented:
Feel free, but it is near a statistical improbability it is the enclosure (unless it is power).  There are 2 wires for read, 2 wires for write.  A single chip isn't going to selectively munge data at physical block#0 one minute, then let it work another.   The bridge has no cache, and translates instructions.

Neither the bridge or drive have any idea what a partition is, an O/S, or anything else like that.  They read/write X blocks starting at offset Y.

Every bit of data on that HDD is suspect, not just the partitioning.   A direct connection will eliminate the bridge, as well as provide a mechanism to run  MFG diags and get an RMA issued.
0
 
DanielTAuthor Commented:
Thanks dlethe. Appreciate your additional input.
As I said I am always very cautious about HDD issues myself.

I am also not concerned about the dock and am most suspicious of the HDD but the interface is involved with 'translating' communication to HDD. This is why I wonder if it could still be an issue there as a result. The HDD was fully functional with one partition and then suddenly 'thought' it had many. After cleaning these up, things are functional again. What could be wrong with the HDD if it is working again? This seems similar to your (quite valid) comment about not working one minute then working the next.

As well, this should be of no significance - so I did not include the detail before - but the dock is a dual port dock. I actually find it very odd that the partitions were the sizes as reported and very near 50% of the sizes of the installed HDDs at the time and (almost) in two identical sets of similar sized divisions (see previous sceenshot). There was a 2TB HDD installed and a 500GB. Could just be coincidence. At the same time, the 500GB HDD did not have issues and it is an older drive; the 500GB HDD has been left out of the device for time being.
0
 
DavidPresidentCommented:
The translation method would mostly get you when encapsulating the ATA commands that require accessing a block > FFFFFFFF hex.   In layman's terms, if the HDD is > a little more than 2 TB then the offset is too big to fit in the standard command-set that most bridges use.

If you had a HDD > 2TB then you need to check with the MFG if the device uses the 16-byte commands that can talk to blocks > FFFFFFFF rather than the 10-byte commands that have served us well before HDDs were that big.

If your disk was also > 2TB then that could also explain some of this behavior.  The $2.00 chip will drop the leading bit, so block # 100000004 would be read/written to #4, which would make everything look fine until the time your data needed to be written at a location this high.
0
 
DanielTAuthor Commented:
Thx again!
Actually makes sense! :))

All these devices are new so I am fairly confident they support larger hard drive capacities. I recall seeing support for up to 4TB so I checked and it was noted that the dock was tested with 4TB. The bridge (host adapter card) is a USB 3, PCI express 2.1 card so it should also be OK.

Anyway... am just between other tasks and this.
Will advise of final actions!
0
 
DanielTAuthor Commented:
I am closing this thread on a best info basis.

The Host Adapter Card and Dock have remained in operation and have not given any issues with any other HDD. Of course, if anything  else, it would most likely have been the controller vs the dock.

But - due to the fact that the HDD was under warranty - it was returned via RMA for a replacement. I do not have that yet but due to performance of the remaining hardware, the HDD must have been the cause and I am closing on that basis.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now