Solved

MS Exchnage 2010 error log- MSexchange common, Event ID 106

Posted on 2013-11-03
11
5,894 Views
Last Modified: 2013-11-14
Recently we moved the mail box role from our exchange 2010 single server to another ex2010.  Both servers are in vertulized with VMware, in an IBM storage. Now on the old server (CAS, Hub Transport only), I am getting the following error,

Performance counter updating error. Counter name is Explicit Sign-On Inbound Proxy Sessions - Total, category name is

MSExchange Control Panel. Optional code: 3. Exception: The exception thrown is : System.InvalidOperationException: The

requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
   at System.Diagnostics.PerformanceCounter.Initialize()
   at System.Diagnostics.PerformanceCounter.set_RawValue(Int64 value)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.set_RawValue(Int64 value)
Last worker process info : System.ArgumentException: Process with an Id of 2224 is not running.
   at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetLastWorkerProcessInfo()
Processes running while Performance counter failed to update:
1772 Microsoft.Exchange.ProtectedServiceHost
392 ccSvcHst
2952 Microsoft.Exchange.EdgeSyncSvc
2752 Microsoft.Exchange.AddressBook.Service
2552 Rtvscan
2156 SMSvcHost
972 Smc
6656 SAVFMSESp
772 LogonUI
4908 svchost
5688 conhost
564 w3wp
2336 Locator
560 SMSMSEMgmtSrv
944 svchost
2716 svchost
6852 SAVFMSESrv
5148 SAVFMSELog
940 SAVFMSESp
3500 w3wp
344 csrss
2312 svchost
5660 SAVFMSEUI
1128 svchost
5852 CmafReportSrv
7032 SAVFMSESp
2892 Microsoft.Exchange.AntispamUpdateSvc
1512 MSExchangeADTopologyService
4072 w3wp
520 lsm
512 lsass
1448 inetinfo
1688 Microsoft.Exchange.Monitoring
1096 msdtc
504 services
700 svchost
1092 MSExchangeMailboxReplication
1288 spoolsv
2072 conhost
2660 SAVFMSESp
5416 SAVFMSESp
884 svchost
3044 MsExchangeFDS
2056 EdgeTransport
2644 vmtoolsd
1264 MSExchangeTransportLogSearch
4808 SAVFMSESp
1412 svchost
836 svchost
3424 WmiPrvSE
3888 w3wp
3024 SAVFMSECTRL
4840 TranscodingService
1836 Microsoft.Exchange.RpcClientAccess.Service
6760 SAVFMSESJM
6956 SAVFMSESp
5772 w3wp
3492 w3wp
792 svchost
252 svchost
444 winlogon
1624 exfba
6728 ConsoleAppMgr
240 smss
5556 SMSUtilityService
624 svchost
2396 SAVFMSETask
3576 svchost
5564 conhost
400 wininit
5532 SAVFMSESp
408 csrss
4740 svchost
1980 MSExchangeTransport
6500 SAVFMSESp
6704 conhost
4 System
1912 Microsoft.Exchange.ServiceHost
4532 w3wp
0 Idle
Performance Counters Layout information: FileMappingNotFoundException for category MSExchange Control Panel :

Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name : Global

\netfxcustomperfcounters.1.0msexchange control panel
   at Microsoft.Exchange.Diagnostics.FileMapping.OpenFileMapping(String name, Boolean writable)
   at Microsoft.Exchange.Diagnostics.FileMapping..ctor(String name, Boolean writable)
   at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean

writable)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)

Note: The existing old server was migrated form ex2003.
0
Comment
Question by:Zacharia Kurian
  • 6
  • 5
11 Comments
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39620911
What events occur immediately before and after this event may provide more information about the root cause of this error

Was there some updates done to this server for CAS role ?
Did you run EXBPA to check if it reports something related to this issue ?

- Rancy
0
 
LVL 9

Author Comment

by:Zacharia Kurian
ID: 39621290
no errors or warning before or after this. This what I have done;

Updated it with SP3.
Installed another server with Mail box role.
Moved all the mailboxes, public folders to the new server.
Moved all the arbitration mailboxes to the new server.
Cross checked if anything related mail box role is still exists in the server. Once confirmed all, uninstalled the mail box role and rebooted the server.

Please note that the servers are in VM, in an IBM storage.

Yes I run EXBPA and the only message is as follows;

Disk timeout on server  is not set at the default of 10 seconds. This is normal if third-party storage software is installed. Current timeout value is 60 seconds
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39621327
I have seen if there is a server with only mailbox role and not CAS then this even is quiet common .... MS article

- Rancy
0
 
LVL 9

Author Comment

by:Zacharia Kurian
ID: 39621398
do you have the MS article link? Do you mean to say it is quite normal and can be ignored?
Please confirm.

Thank you.
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39621466
Event ID 106 is logged when you start the RPC Client Access service on Exchange Server 2010
http://support.microsoft.com/kb/982679

Check this column CAUSE
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 9

Author Comment

by:Zacharia Kurian
ID: 39623652
Thank you for the link. But I am getting the errors on the server, which has CAS & HUB. My other server which has only Mail Box Role, doesn't throw any errors.
0
 
LVL 9

Author Comment

by:Zacharia Kurian
ID: 39623685
a few thoughts/findings;

In my server where I am getting errors (has only CAS & HUB), i could not find the registry key as  "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE"

I was reading a post on
http://blogs.technet.com/b/mikelag/archive/2010/09/10/how-to-unload-reload-performance-counters-on-exchange-2010.aspx

where it says to have a look on the above registry key.  Now my questions is this, should I export the above key from my other server where it has only mailbox role and can import to the server which has the errors?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39624173
Take a registry backup then Export and Import into CAS server and restart and check

- Rancy
0
 
LVL 9

Accepted Solution

by:
Zacharia Kurian earned 0 total points
ID: 39626574
I really banged my head and finally got the solution from the below post;

http://social.technet.microsoft.com/Forums/exchange/en-US/58692b89-d83e-4f3a-b991-9bb38b8ccad0/performance-counters-update-errors-exchange-active-manager-client-ones?forum=exchange2010

No the errors stopped on the server which has only CAS & HUB.
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39627008
Good to know and Thanks for sharing :) .... you can close the post too now

- Rancy
0
 
LVL 9

Author Closing Comment

by:Zacharia Kurian
ID: 39647409
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now