Trouble sending as another user in exchange 2010

I am running an sbs 2011 system. It has the following version of exchange:
Microsoft Exchange Server 2010 SP2

I have a particular account that needs access to another users mailbox.
I have set the full access permission (so they can view the mailbox and check the emails) and also the send as permission, so they can send email as the other user.

However, send as is not working, when I try to send as the second mailbox, from the first user, I get the following error message:

"You do not have permission to send on behalf of the specified user."

I understand that send on behalf of, takes precedence over send as, but I have not deliberately set send on behalf of permission, so I don't know why in this case, send as is not being recognized.

Any help would be appreciated.
davids355Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
You should do it only from the GAL (and can then select from the auto complete). A drop down/type in may not be the right address.

Simon.
0
 
Chris WongCommented:
You do not have the permission to send the message on behalf of the specified user.
http://www.andyamos.com/?p=174
0
 
Simon Butler (Sembee)ConsultantCommented:
Full Mailbox does not give you permissions to send as the user as well. They are two different permissions. Therefore you need to set Send As specifically through EMC on to the account.

As you have already tried to use the permissions, it could take two hours before it is fully effective.

Simon.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
davids355Author Commented:
Thanks Simon. I did set that permission as well - via the EMC. I had done so quite some time ago (weeks) but it has only just been tested by the user, and is bringing up that message.

The only troubleshooting steps I have taken so far is to go into EMC, remove the send as permission, then add it back in again.
Then wait 24 hours and tested again. still producing the same error message.
0
 
Simon Butler (Sembee)ConsultantCommented:
How was the user selecting that address to send as?
Was it being typed in or selected from the GAL?

Simon.
0
 
davids355Author Commented:
It is being selected from the dropdown (recently typed), the option I am selecting displays the full address though so I am assuming that its been typed in full at some point.
But I will try typing it in full now, and also manually selecting from GAL.
0
 
davids355Author Commented:
Thanks Simon. I deleted the autocomplete entries, then added the from address via GAL and it worked.

Now I have realised that I may have done something very stupid:

the address in question was written in the plural, like volunteers, but I think I was trying to send as volunteer, without the S.

Thanks a lot for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.