HP 2910al firmware unable to login as admin

Hi
i just upgraded the firmware on a HP 2910al-24G Switch (J9145A) to version W.15.12.0011

- first i uploaded the new firmware as the primary image but when the switch was rebooted it did not use the new firmware.
- then i uploaded the new firmware as the secondary and rebooted and the new firmware booted up.

all settings that were before the firmware flash are still unchanged but i am unable to make any changes to the switch since it does not want to log in as administrator using the password that was used before the firmware update.
both web interface and telnet interface have this problem.

https://h10145.www1.hp.com/downloads/DownloadSoftware.aspx?SoftwareReleaseUId=10569&ProductNumber=J9145A&lang=&cc=&prodSeriesId=&SerialNumber=&PurchaseDate=
Hoddi1Asked:
Who is Participating?
 
ienaxxxConnect With a Mentor Commented:
soory for the question: did u try a blank password (as it should be the default one).

Since there's a warning message in the firmware download page that states that it can eventually update the boot rom as well... something strange might have happened...
0
 
Hoddi1Author Commented:
Hi
Yes, i have tried a blank password both without a username and with various combination of possible default usernames.
probably something has gone wrong like you said, any ideas what can be done to fix since there is no access to reflash or anything ?
0
 
ienaxxxConnect With a Mentor Commented:
There should be the password recovery button (clear button) on the switch.
Press it for a couple seconds and ... resets the passwords, you get it.
0
 
atrevidoConnect With a Mentor Commented:
Have you tried console access first?  You said web and telnet - did you plug a console cable in and press return a couple times?  If you cannot get in that way then leave console cable plugged in and reboot it - watch the console screen.  Maybe there will be a clue as to what is wrong or where it is stuck.  Barring that, last resort is password recovery:

password recovery on a 2910 can be done by performing  these steps:
1.Using pointed objects (Paperclips work good), simultaneously press both the Reset and Clear buttons on the front of the switch.
2.Continue to press the Clear button while releasing the Reset button.
3.When the Self Test LED begins to blink, release the Clear button.
The switch will then complete its self test and begin operating with its configuration restored to the factory default settings.
To restore the factory default configuration using the console, execute the erase startup-config command from the console command prompt.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.