Solved

Cannot delete files as Administrator or owner

Posted on 2013-11-04
18
629 Views
Last Modified: 2013-11-06
I cannot delete files even though I own them.

I am trying to delete files from a Windows directory, which is now the 2nd internal drive, previously it was the main drive.

I re-named the folder to Windows-orig, and things are fine, so I don't need this folder. When I go to delete files / folders, it says "You need permission to perform this action" - but I am the owner of the file.

I followed the instructions here which looked perfect, but I still can't delete . . .
Here:
 file to delete - owned by Stephendelete warning (shield)cannot delete msgStephen = admin
0
Comment
Question by:Alaska Cowboy
  • 9
  • 5
  • 2
  • +2
18 Comments
 
LVL 92

Assisted Solution

by:John Hurst
John Hurst earned 150 total points
ID: 39623230
Since it is a different Windows setup, you probably got a slightly different internal userid in Windows which is preventing this.

Can you right click on windows.old and take ownership of it?   That may allow you to delete the files.

.... Thinkpads_User
0
 
LVL 52

Assisted Solution

by:Joe Winograd, EE MVE
Joe Winograd, EE MVE earned 50 total points
ID: 39623280
In the first screenshot you posted, click the Edit button:
Edit - Change owner toSelect one of the Names that it displays in the "Change owner to" box and then try to delete. Regards, Joe
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39623316
thinkpads_user,
>>right click on windows.old and take ownership of it
-- I assume you're referring to my windows-orig. If so, I took ownership yesterday (as Administrators), but couldn't delete everything / anything. So then I dropped down to an individual folder / file to delete, and still couldn't do it . . .
-- A lot of the files were owned by "Trusted Installer" (or something like that), so I thought I had it fixed, but nooooooo....

Joe,
>>Select one of the Names that it displays in the "Change owner to" box
-- ??, not sure what you mean, that's what I did, and I selected Stephen - Administrator.
owned by Stephen
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 3

Accepted Solution

by:
jmorourke80 earned 50 total points
ID: 39623333
File/Folder ownership doesn't necessarily mean you have permission to delete or modify the file, it just means you have permission to control the NTFS permissions on the file.

You're already the owner, so go to the permissions tab and make sure you account has Full Control (or, at very least, Modify permission) on the stuff you want to delete. You can also look at the permissions of the "CREATOR OWNER" object since that's your account to by virtue of your ownership of the file.

Failing that, post some screenshots of the Permissions tab and the Effective Permissions tab (looking specifically at your account's effective permissions).

- Jason
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39623358
jmorouke80,
>>go to the permissions tab and make sure you account has Full Control
-- worked ! (for one file). I'll check more tomorrow night and close out. Thanks !
0
 
LVL 52

Expert Comment

by:Joe Winograd, EE MVE
ID: 39623389
> that's what I did, and I selected Stephen - Administrator.

That's good...wanted to be sure about Ownership. Next step was Permissions, but I see that Jason already got you there. Regards, Joe
0
 
LVL 46

Expert Comment

by:noxcho
ID: 39623595
Your solution could be booting from Linux CD such as Parted Magic or GParted and deleting the file via it instead of playing with ownership settings in Windows.
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39623958
Joe, thanks for checking in and tips.

noxcho, ok, good tip, thanks, will keep that in mind.
0
 
LVL 92

Assisted Solution

by:John Hurst
John Hurst earned 150 total points
ID: 39623995
Another thing that often works (for future reference) is to create a new Windows Userid, make it a member of the administrators group, and log in as the new user. You can often take full control in this new userid and delete files that way.

.... Thinkpads_User
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39624218
Thinkpads_User, ok, good too, I will have that at the ready tonight as well.
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39626078
still not quite working . . . Wallpaper is owned by Stephen (Administrator) - with full control, but still can't delete it. I can muddle through this, but it seems weird and frustrating.
Wallpaper ownerWallpaper permissionsWallpaper cannot deleteWallpaper cannot delete-2Wallpaper-permissions.PNG
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 39626093
Can you go to the top of this folder structure?  Go to Security Options (as you show above) and then click on Advanced.  Make sure you are applying admin permissions and then check (select) the box that says Replace all child object permissions with inheritable permissions from this object.

.... Thinkpads_User
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39626103
Thinkpads_user,
I did that and it looks good to me . . . but it wasn't working so I tried a lower level folder (Wallpaper)
Windows-orig propertiesWindows-orig owner
0
 
LVL 92

Assisted Solution

by:John Hurst
John Hurst earned 150 total points
ID: 39626115
Try logging on as a different user and re-assigning permissions from the top. That has always worked for me.

There was a prior comment about booting with a Linux CD.  Try booting with Ultimate Boot CD (Windows) and see if you can delete the file using UBCD.

.... Thinkpads_User
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39626171
>>Try logging on as a different user and re-assigning permissions from the top. That has always worked for me.
- ok, trying that now.
0
 
LVL 1

Author Comment

by:Alaska Cowboy
ID: 39626236
I set up Bill as Administrator, changed permissions on Window-orig, but still can't delete . . . also tried changing on Web, but no luck :-( No worries, I'll just work on this piece-meal.

Windows-orig propertiesWeb folder propertiesWeb folder cannot deleteBill = Admin
0
 
LVL 1

Author Closing Comment

by:Alaska Cowboy
ID: 39627392
It's not perfect, but I can work through it, I have the fundamentals to delete. I will just work on this bit-by-bit, hopefully I'll catch the global issue and be able to zap it all.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 39627744
@williampeck - Thanks for the update and I was happy to help.

... Thinkpads_User
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will go in depth within Systems and Security in Windows 7 and will go into detail regarding Action Center, Windows Firewall, System, etc. This will be demonstrated using Windows 7 operating system.

805 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question