?
Solved

Procurve Stacking problem (2 x 2610-24 and a E2620-48)

Posted on 2013-11-05
8
Medium Priority
?
1,271 Views
Last Modified: 2013-11-06
Hi All,

Im banging my head against a wall here.

Im trying to stack 3 switches together (2 x 2610-24 and a E2620-48), two are already stacked both 2610-24's and im trying to add a E2620-48.

I've gotten onto the console of the switch and set everything up as identical as i could to the other two

Created VLANS, Given the switch a different IP assigned the same Vlan as the default as the two existing switches.

Configured PORT's 49 and 50 as the trunk ports (TRUNK 1), and tagged them in each VLAN.

when I patch the cables into the new switch, i can no longer ping the first two switches and the network goes down until i remove the cables and patch them back to the way they used to be.

SWITCH 3 SETTINGS (NEW SWITCH)

PORT
                   Switch Configuration - Port/Trunk Settings

  Port    Type      Enabled      Mode      Flow Ctrl  Group  Type
  ----  --------- + -------  ------------  ---------  -----  -----
  41    10/100TX  | Yes      Auto          Disable
  42    10/100TX  | Yes      Auto          Disable
  43    10/100TX  | Yes      Auto          Disable
  44    10/100TX  | Yes      Auto          Disable
  45    10/100TX  | Yes      Auto          Disable
  46    10/100TX  | Yes      Auto          Disable
  47    10/100TX  | Yes      Auto          Disable
  48    10/100TX  | Yes      Auto          Disable
  49    1000T     | Yes      Auto          Disable    Trk1   Trunk
  50    1000T     | Yes      Auto          Disable    Trk1   Trunk
  51              | Yes                    Disable
  52              | Yes                    Disable

Open in new window


IP
  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20



          VLAN           IP Config     IP Address       Subnet Mask
  -------------------- + ----------  ---------------  ---------------
  DEFAULT_VLAN         | Disabled
  Core                 | Manual      10.0.200.3       255.255.255.0
  Clients              | Manual      10.0.210.3       255.255.255.0
  Voice                | Disabled

Open in new window


SWITCH 2 SETTINGS

PORT
  Port    Type      Enabled      Mode      Flow Ctrl  Group  Type
  ----  --------- + -------  ------------  ---------  -----  -----
  17    10/100TX  | Yes      Auto          Disable
  18    10/100TX  | Yes      Auto          Disable
  19    10/100TX  | Yes      Auto          Disable
  20    10/100TX  | Yes      Auto          Disable
  21    10/100TX  | Yes      Auto          Disable
  22    10/100TX  | Yes      Auto          Disable
  23    10/100TX  | Yes      Auto          Disable
  24    10/100TX  | Yes      Auto          Disable
  25    1000T     | Yes      Auto          Disable    Trk1   Trunk
  26    1000T     | Yes      Auto          Disable    Trk1   Trunk
  27              | No                     Disable
  28              | No                     Disable

Open in new window


IP
  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20



          VLAN           IP Config     IP Address       Subnet Mask    Proxy ARP
  -------------------- + ----------  ---------------  --------------->
  DEFAULT_VLAN         | Disabled
  Core                 | Manual      10.0.200.2       255.255.255.0    No
  Clients              | Manual      10.0.210.2       255.255.255.0    No
  Voice                | Disabled

Open in new window


SWITCH 1 SETTINGS
PORT
  Port    Type      Enabled      Mode      Flow Ctrl  Group  Type
  ----  --------- + -------  ------------  ---------  -----  -----
  17    10/100TX  | Yes      Auto          Disable
  18    10/100TX  | Yes      Auto          Disable
  19    10/100TX  | Yes      Auto          Disable
  20    10/100TX  | Yes      Auto          Disable
  21    10/100TX  | Yes      Auto          Disable
  22    10/100TX  | Yes      Auto          Disable
  23    10/100TX  | Yes      Auto          Disable
  24    10/100TX  | Yes      Auto          Disable
  25    1000T     | Yes      Auto          Disable    Trk1   Trunk
  26    1000T     | Yes      Auto          Disable    Trk1   Trunk
  27              | No                     Disable
  28              | No                     Disable

Open in new window


IP
  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20



          VLAN           IP Config     IP Address       Subnet Mask    Proxy ARP
  -------------------- + ----------  ---------------  --------------->
  DEFAULT_VLAN         | Disabled
  Core                 | Manual      10.0.200.1       255.255.255.0    No
  Clients              | Manual      10.0.210.1       255.255.255.0    No
  Voice                | Disabled

Open in new window

0
Comment
Question by:Wean
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39624125
Can you post the configs?
0
 
LVL 1

Author Comment

by:Wean
ID: 39624188
SWITCH 3 (NEW SWITCH)
SWITCH3# show config

Startup configuration:

; J9626A Configuration Editor; Created on release #RA.15.05.0006
; Ver #01:01:00

hostname "SWITCH3"
time daylight-time-rule Western-Europe
no stack auto-join
trunk 49-50 Trk1 Trunk
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48,51-52,Trk1
   no ip address
   exit
vlan 200
   name "Core"
   ip address 10.0.200.3 255.255.255.0
   tagged 37-48,51-52,Trk1
   exit
vlan 210
   name "Clients"
   ip address 10.0.210.3 255.255.255.0
   tagged 1-36,Trk1
   exit
vlan 250
   name "Voice"
   tagged Trk1
   no ip address
   exit
timesync sntp
sntp unicast
sntp server priority 1 10.0.200.33
no telnet-server
snmp-server community "relit" unrestricted
snmp-server community "publicit" operator
snmp-server contact "Infrastructure" location "Travel Centre"
spanning-tree
spanning-tree Trk1 priority 4
primary-vlan 200
no dhcp config-file-update
password manager

SWITCH3#

Open in new window


SWITCH2
SWITCH2# show config

Startup configuration:

; J9085A Configuration Editor; Created on release #R.11.72

hostname "SWITCH2"
snmp-server contact "Infrastructure"
snmp-server location "Travel Centre"
time daylight-time-rule Western-Europe
mirror-port 23
no web-management
web-management ssl
no telnet-server
qos dscp-map 101110 priority 6
interface 27
   disable
exit
interface 28
   disable
exit
trunk 25-26 Trk1 Trunk
ip routing
timesync sntp
snmp-server community "relit" Unrestricted
snmp-server community "publicit" Operator
vlan 1
   name "DEFAULT_VLAN"
   no ip address
   no untagged 1-24,27-28,Trk1
   exit
vlan 200
   name "Core"
   untagged 1-2,4-18
   ip address 10.0.200.2 255.255.255.0
   tagged 27-28,Trk1
   exit
vlan 250
   name "Voice"
   untagged 3
   no ip address
   qos priority 6
   tagged 2,Trk1
   exit
vlan 210
   name "Clients"
   untagged 19-24
   ip address 10.0.210.2 255.255.255.0
   ip helper-address 10.0.200.33
   tagged Trk1
   exit
interface 25-26
   monitor
   exit
qos device-priority 10.0.250.10 dscp 101110
qos device-priority 10.0.250.12 dscp 101110
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 10.0.200.5
primary-vlan 200
snmp-server host 10.0.10.50 community "public"
sntp unicast
sntp server 10.0.200.33
spanning-tree
spanning-tree Trk1 priority 4
ip ssh
password manager
password operator

SWITCH2#

Open in new window


SWITCH1
SWITCH1# show config

Startup configuration:

; J9085A Configuration Editor; Created on release #R.11.72

hostname "SWITCH1"
snmp-server contact "Infrastructure"
snmp-server location "Travel Centre"
time daylight-time-rule Western-Europe
no web-management
web-management ssl
no telnet-server
qos dscp-map 101110 priority 6
interface 27
   disable
exit
interface 28
   disable
exit
trunk 25-26 Trk1 Trunk
ip routing
timesync sntp
snmp-server community "relit" Unrestricted
snmp-server community "publicit" Operator
vlan 1
   name "DEFAULT_VLAN"
   no ip address
   no untagged 1-24,27-28,Trk1
   exit
vlan 200
   name "Core"
   untagged 1-2,4-17
   ip address 10.0.200.1 255.255.255.0
   tagged 27-28,Trk1
   exit
vlan 250
   name "Voice"
   untagged 3
   no ip address
   qos priority 6
   tagged 2,Trk1
   exit
vlan 210
   name "Clients"
   untagged 18-24
   ip address 10.0.210.1 255.255.255.0
   ip helper-address 10.0.200.33
   tagged Trk1
   exit
qos device-priority 10.0.250.10 dscp 101110
qos device-priority 10.0.250.12 dscp 101110
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 10.0.200.5
primary-vlan 200
snmp-server host 10.0.10.50 community "public"
sntp unicast
sntp server 10.0.200.33
spanning-tree
spanning-tree Trk1 priority 4
ip ssh
password manager
password operator

SWITCH1#

Open in new window

0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39624206
Ok, what ports are you using to connect each switch to each switch?

I can see that you've got a trunk between switch 1 and 2 via ports 25 and 26 on each switch, but what ports are you using to connect the new switch, and to which of the two switches are you connecting it to?
0
Get proactive database performance tuning online

At Percona’s web store you can order full Percona Database Performance Audit in minutes. Find out the health of your database, and how to improve it. Pay online with a credit card. Improve your database performance now!

 
LVL 1

Author Comment

by:Wean
ID: 39624238
Currently:
Swich1 Port 25 goes to Switch2 26
Switch2 Port 26 goes to Switch1 25

What im trying to do is:
Cable from Switch1 Port 26 to Switch2 Port 25
Cable from Switch2 Port 26 to Switch3 Port 49
Cable from Switch3 Port 50 to Switch1 port 25
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39624265
Hmmm you can't do that as you can't create trunks between dissimilar switches.  If the switches were truly stacked this would probably be possible in some circumstances, but this is uplinking not stacking.

You have to connect all ports in the trunk to the same remote switch.  Both ends should have the same configuration.
0
 
LVL 1

Author Comment

by:Wean
ID: 39624285
So do i create a "Trunk2" on the first switch and add the 3rd?
0
 
LVL 46

Accepted Solution

by:
Craig Beck earned 2000 total points
ID: 39624319
Yes, that would be the way to go.  You would need to connect the third switch to a new trunk on the first or second switch - whichever you want to connect it to.

So, connect switch1 ports 27-28 to switch3 ports 51-52...

Switch1
trunk 27-28 Trk2 Trunk
vlan 1
   name "DEFAULT_VLAN"
   no ip address
   no untagged 1-24,Trk1,Trk2
   exit
vlan 200
   name "Core"
   untagged 1-2,4-17
   ip address 10.0.200.1 255.255.255.0
   tagged Trk1,Trk2
   exit
vlan 250
   name "Voice"
   untagged 3
   no ip address
   qos priority 6
   tagged 2,Trk1,Trk2
   exit
vlan 210
   name "Clients"
   untagged 18-24
   ip address 10.0.210.1 255.255.255.0
   ip helper-address 10.0.200.33
   tagged Trk1,Trk2
   exit
spanning-tree Trk2 priority 4

Open in new window



Switch3
trunk 51-52 Trk2 Trunk
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48,Trk1,Trk2
   no ip address
   exit
vlan 200
   name "Core"
   ip address 10.0.200.3 255.255.255.0
   tagged 37-48,Trk1,Trk2
   exit
vlan 210
   name "Clients"
   ip address 10.0.210.3 255.255.255.0
   tagged 1-36,Trk1,Trk2
   exit
vlan 250
   name "Voice"
   tagged Trk1,Trk2
   no ip address
   exit
spanning-tree Trk2 priority 4

Open in new window

0
 
LVL 1

Author Closing Comment

by:Wean
ID: 39626685
Thank you, i havent tried this yet as it was too late yesterday, i will give this a go early next week, but i can see that this should work
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question