Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4868
  • Last Modified:

Cannot open Links in Outlook -- General Failure URL -- Class not registered

Using Outlook 2010-- on Windows 7 Ultimate x64
Did an in place upgrade trying to fix a VSS issue. The upgrade failed to complete due to an unexpected error-- but I found a regedit that allowed the upgrade to complete.
Everything seems to work fine except anytime a link is chosen in outlook emails an error appears
"General Failure URL (the url) Class not registered"
Using IE 8
When Chrome or Firefox are the default browsers-- this works and opens with them. But making IE the default browser and the error continues.
I upgraded to IE 9 -- made sure HTTP and HTTPs opens use IE defaults in Default Programs
Uninstalled Chrome and reinstalled chrome-- made IE default-- same issue
Installed Firefox and then made IE default again-- same issue
Reset IE -- same issue
Any suggestions? Client is upset and wants IE to open when choosing the Outlook links in emails.
I heard upgrading to IE10 worked for some but I tried that with 9 and it did not work and I don't know if the client can use 10 yet for a web program they are using.
Thanks in advanced--
0
electricdad
Asked:
electricdad
1 Solution
 
Pete LongTechnical ConsultantCommented:
Change your default web browser to something other than Internet Explorer (like Chrome or Firefox)
0
 
cklukaCommented:
Do a "repair" operation on office in add/remove programs.
0
 
jcimarronCommented:
electricdad --
In Control Panel\All Control Panel Items\Default Programs\Set Associations scroll to the very bottom of the window.  Is IE set as default for HTTP and HTTPS?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
electricdadAuthor Commented:
The client wants the links to open with IE-- IE was set as default for HTTP and HTTPs
I did not try the repair operation yet. I will try it although I read that it did not work for others.
The client is using Plex as a hosted Exchange. Although I don't see why that would matter.
0
 
electricdadAuthor Commented:
I have decided to fresh install here-- no time to keep on this. There are other problems discovered in the kernel and Better to just reload.
Thanks for your help.
0
 
electricdadAuthor Commented:
This needed more work than what it was worth. Wipe and load is the way to go.
0
 
Kevin DudzikWindows Server / Security/ NetworkCommented:
This has to a Group Policy (preferences) setting that changes IE settings  Intranet / Trusted / Internet.
Regarding ActiveX or domains.

You can uninstall the product/repair the product and the problem settings will come back.
You can click on reset Internet Explorer settings, and it will work until the Group Policy is applied again.

Has anyone figured out what exactly those settings are? In Group policy / User Configuration / Control Panel Settings / Internet Settings / IE 10/11 or 8/9 Policy / Zone - Custom Settings
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now