[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

User Can't Connect to PC using Remote Desktop

Posted on 2013-11-05
8
Medium Priority
?
421 Views
Last Modified: 2013-11-09
I need to set up a user to access their PC remotely.  I've set up remote desktop connection on the user's PC and added the user to the RDC user group on our domain controller as well as an authorized PC that she needs to access.

A few other folks in our organization are able to access their PCs remotely and I can't figure out what's missing.

Attached is a screenshot of what I get when I try to log into the computer with the user's account.

RDC Screenshot
0
Comment
Question by:sscal
  • 4
  • 4
8 Comments
 
LVL 15

Expert Comment

by:Skyler Kincaid
ID: 39625865
You need to modify a group policy setting to allow the connection:

Type in "gpedit.msc" into the search bar in the start menu and hit enter

From Group Policy Management navigate to:

Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment

In the right-hand pane, locate the entry named "Allow Log on through Terminal Services" and double-click on it.

Click "Add User or Group.."

Type "everyone" or the name of the user  and click "Check Names"

Click Okay.

It is weird you have to add them to the remote desktop users group and also make the group policy change but I have seen that before.
0
 
LVL 1

Author Comment

by:sscal
ID: 39627495
I found the Group Policy setting, but the option to add users is grayed out - see attached image. Any thoughts?

RDS Permissions
0
 
LVL 15

Accepted Solution

by:
Skyler Kincaid earned 2000 total points
ID: 39627575
Is the computer part of a domain? If it is you will need to make the setting changes from Group Policy Management Console on your server.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 1

Author Comment

by:sscal
ID: 39627736
Yes, it is part of a domain.  I can't figure out where on domain controller the setting is.

If you can't tell, I'm not a server guy.  Thanks for all your help.
0
 
LVL 15

Expert Comment

by:Skyler Kincaid
ID: 39627751
When you are trying to make the setting change through the local group policy on the machine you need to be logged in as an administrator. Were you?
0
 
LVL 1

Author Comment

by:sscal
ID: 39627763
I was logged in as the user (no admin rights) but provided admin credentials when prompted to enter the group policy settings on the user's machine.
0
 
LVL 15

Expert Comment

by:Skyler Kincaid
ID: 39627783
Log in as administrator and you will be able to make the settings change.

The issue is being caused by the user not being an administrator. The other users listed in the Group Policy setting are there because they were added to the local administrator group on the computer. If you don't mind the user being a local admin you can also add them to the group which will allow them to log into the computer via remote desktop.

This can be done by:

1. Logging in as an administrator (locally or on the domain)
2. Click the start menu and right click on Computer, select manage
3. Expand Local Users and Groups
4. Expand Groups
5. Double click on Administrators
6. Click add...
7. Add the user in and hit ok.

The user will now be a local admin which by default allows them access via remote desktop in the group policy settings. That is probably how all the other users are setup and when you are in the administrators group you will probably see the other users.
0
 
LVL 1

Author Comment

by:sscal
ID: 39635993
Thanks for your help.  Making the edit locally didn't work, but I found the server group policy and was able to update that. All appears to be working correctly now.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question