• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 548
  • Last Modified:

DTSX package run as a SQL JOB - importing Access Data

I have a DTSX package that runs great if I manually run. The DTSX package deletes all data from 15 tables and then reimports the data back into the 15 tables. The source is Access 2003 and it works great if double click and execute. The SQL is 20005. I only have to run this once a night for reporting.

The problem is the schedule of job. I have tried everything. I created a Proxy and I selected RUN AS this proxy. My Proxy has everything selected in ACTIVE IN THE SUBSYSTEMS and I feel I have tried all the principals as well. It keeps failing. I am not sure if its rights or if its Access related. Any help?

HERE IS MY ERROR:

The job failed.  The Job was invoked by User ServerName\Administrator.
Code: 0xC0202009     Source: FinalTest Connection manager "SourceConnectionOLEDB"     Description: SSIS Error Code DTS_E_OLEDBERROR.  
An OLE DB error has occurred. Error code: 0x80004005.  
An OLE DB record is available.  
Source: "Microsoft JET Database Engine"  
Hresult: 0x80004005  
Description: "The Microsoft Jet database engine cannot open the file '\\ServerA\Libary\Database\TheDatabase.mdb'.  
It is already opened exclusively by another user<c/> or you need permission to view its data.".  
End Error  Error: 2013-11-06 19:52:32.67    
Code: 0xC020801C     Source: Data Flow Task Source - COMPONENTS [1]    
Description: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  
The AcquireConnection method call to the connection manager "SourceConnectionOL...  
The package execution fa...  The step failed.,00:00:01,0,0,,,,0
0
allenkent
Asked:
allenkent
  • 2
  • 2
1 Solution
 
chaauCommented:
What happens if you login as user "ServerName\Administrator" and try to open file \\ServerA\Libary\Database\TheDatabase.mdb? Have you tried this?
0
 
allenkentAuthor Commented:
Yes I can open the file.
0
 
chaauCommented:
You probably also need to change the security permission on this folder (\\ServerA\Libary\Database\TheDatabase.mdb) to grant access to the user that is configured to run as the SQL Server Agent account. By default, I believe it is  NT Service\SQLSERVERAGENT. You have two options:
1. Grant access to  NT Service\SQLSERVERAGENT to the file system folder
2. Modify the user that the SQL Server Agent uses to login with. This page describes how to change the account properties for the service. The page is rather big, just jump to "Changing Account Properties" section
0
 
allenkentAuthor Commented:
The security portion above must be the issue but I solved it a different way.

Once I copied the database to the local machine the job worked. If I use the same database copy on a network it does not make the Access connection.

SOLUTION: Copied the Access Database to the local C before running the job
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now