Solved

Start program and enable desktop on terminal services logon

Posted on 2013-11-07
5
394 Views
Last Modified: 2013-11-18
Hi Experts - we are trying to get a program to start upon remote desktop login and have access to the desktop/start menu as well.   We are currently using this GPO to start the program on login but cannot access the desktop as the GPO is designed to do this.
http://technet.microsoft.com/en-us/library/cc770821.aspx
Is there another way to do this?
We need to start a different program for different users based on the OU they are contained in.  I'm not too well versed on Remote Desktop Services, so please let me know if you need additional information about our setup.

Running Server 2008 R2 datacenter.
0
Comment
Question by:thecomputerplace
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 19

Expert Comment

by:Miguel Angel Perez Muñoz
ID: 39630308
You can create one GPO per OU with different programs you need to run. Then, link this GPO to OU as needed. This article may help you to create GPO: http://technet.microsoft.com/en-us/library/cc786890(v=ws.10).aspx; http://www.virtualizationadmin.com/articles-tutorials/terminal-services/general/managing-terminal-services-group-policy.html
0
 

Author Comment

by:thecomputerplace
ID: 39630368
Thanks for the post Drashiel - but have that working, the program starts, but we want users to have access to the desktop as well.  Is this possible?  Do we need to incorporate loopback processing so it starts the program via one gpo but then enables the desktop via both of these settings?
rdp.png
0
 
LVL 19

Expert Comment

by:Miguel Angel Perez Muñoz
ID: 39632816
I think that this not possible. When you configure a program to start, disables access to desktop. Maybe you can try launching explorer.exe and your program (on a bat file or similar), but I haven´t tested.
0
 

Accepted Solution

by:
thecomputerplace earned 0 total points
ID: 39646198
I couldn't find a way to get this working - although I didn't try to put the shortcut in startup folder of each user account instead of using GPO.   We were able to work around needing access to desktop by forwarding the local drive to the RDP session and allowing the user to export data to their local hard drive.
0
 

Author Closing Comment

by:thecomputerplace
ID: 39656005
we couldn't find a way to get this to work but a workaround was found.
thank you
0

Featured Post

Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This collection of functions covers all the normal rounding methods of just about any numeric value.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
The viewer will learn how to simulate a series of sales calls dependent on a single skill level and learn how to simulate a series of sales calls dependent on two skill levels. Simulating Independent Sales Calls: Enter .75 into cell C2 – “skill leve…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question