?
Solved

Out of Office Issue

Posted on 2013-11-07
12
Medium Priority
?
317 Views
Last Modified: 2013-12-11
Hi,

I have an issue with all my users not being able to set their OOO.  They get an error message saying "your out of office settings cannot be displayed, because the server is currently unavailable.  try again later".

This happens for all our users who use Outlook 2007, 2010 & Outlook 2011 for Mac even though all users can set their OOO using the OWA.

I used the testoutlookconnectivity tool which throws up no errors.  I've even reset the Virtual Directories for EWS & Autodiscover.

Also after resetting the Virtual Directory for EWS I can no longer configure Outlook 2011 for any new users and also my current MAC users can no longer connect to the Exchange server.

I've also configured the internalurl & externalurl for each of the EWS & Autodiscover Virtual Directories, but still not luck.

Can anyone shed any light on what I am doing wrong or anything that I may have missed?

Your help is much appreciated.

novatek
0
Comment
Question by:novatekitsolutions
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39630342
Does Autodiscover work?
Internal and External URL on the Autodiscover virtual directory is a waste of time, as it isn't used. You should set those back to "null".

The value that matters is what you see here:

get-clientaccessserver | select identity, autodiscoverserviceinternaluri

The host name on that value must
a. Resolve to Exchange internally.
b. The host name must be on the SSL certificate
c. the SSL certificate must be trusted by the clients.

If any of that fails, then Autodiscover doesn't work, and the clients cannot find availability information, which includes OOTO.

Simon.
0
 

Author Comment

by:novatekitsolutions
ID: 39630439
Hi sembee2,

Thanks for the prompt response.

I have removed the internal/external URL & when I run the Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

I get the following results, which is what I expected:

Identity: exchangeservername
AutoDiscoverServiceInternalUri: https://owa.maildomain.co.uk/autodiscover/autodiscover.xml


As for the hostname resolving, and being on the SSL cert, this again is all correct as well as being trusted by all the clients.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39630662
To be clear here, it resolves to the INTERNAL IP address of the server?
Do you have a proxy on your network?

Simon.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 

Author Comment

by:novatekitsolutions
ID: 39630946
Hi Simon,

Yes it resolves to the internal IP of the server.

Also we don't have a proxy in our network.

Also, I just tried going to https://mymailserver/ews/exchange.asmx and I got the following error:


Server Error in '/EWS' Application.
--------------------------------------------------------------------------------


Parser Error
  Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

 Parser Error Message: Could not load type 'Microsoft.Exchange.Services.Global'.

Source Error:



Line 1:  <%@ Application Language="C#" Inherits="Microsoft.Exchange.Services.Global"%>

 

 Source File:  /EWS/global.asax    Line:  1


This is really weird.  I've checked all the settings in IIS as well and nothing seems a miss there either.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39631293
That is net framework error. Exactly what version of Exchange and Windows are you running?

Simon.
0
 

Author Comment

by:novatekitsolutions
ID: 39632906
We are using Exchange 2010 SP3 on Windows Server 2008 R2 Standard.

All 3 roles are installed on this one server.

novatek
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39633387
I would start by resetting the virtual directories using the wizard in EMC.

Simon.
0
 

Author Comment

by:novatekitsolutions
ID: 39633606
That was one of the first things I tried...but still no luck.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39637244
Exactly what virtual directories did you reset?

Simon.
0
 

Author Comment

by:novatekitsolutions
ID: 39638145
I reset the Autodiscover & EWS Virtual directories.

novatek
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 1500 total points
ID: 39638211
It looks like there is something wrong with the configuration of .netframework. However this isn't something I have seen before, so I think you are looking at three options only.

1. Remove and reinstall the CAS role, and IIS. Instructions for that are on TechNet.
2. Build a replacement server and migrate everything to that.
3. Call Microsoft.

Simon.
0
 

Author Closing Comment

by:novatekitsolutions
ID: 39711968
Built a new CAS Server and migrated everything across to that.  OOO is now functioning correctly.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question